Multitrack Drum Quantizing Problems

Hi everyone,
I’m almost ready to throw in the towel! I cannot figure out how to quantize my drums so that they’ll play smoothly when solo’d. There’s multiple problems that I cannot seem to fix. Here’s what’s going on:

  • 6 close mic’d drum tracks played through a presonus firestudio project linked to Cubase 6. Genre I would call punk rock or grungy alternative type stuff.

  • Brand new studio-dedicated Compac PC, Windows 7, 4 gigs RAM, 500 GB hard drive

  • When tracking to the rest of the music, I would play a 99% flawless drum performance. When I sit back down at the computer to listen to it, as the song plays the drums drift further and further from the the rest of the guitar/vox tracks. By mid song it’s unlistenable. I’m assuming I have a latency issue?

  • My bigger issue is with trying to edit the drums to the click. I put all of the drums in a folder and select group editing. IQuantize is turned off. I set my thresholds for kick, snare and hats/ride depending on what part of the song I’m trying to edit (I cut the song into segments so that I’m not biting off more than I can chew). I slice and crossfade and play back the drum performance. It sounds terrible - stops, pops, mistimes, machine guns etc.

  • I’ve tried playing with different priority settings, different slice beats (8’s, 16’s etc), all make slight differences but all sound terrible in some way or another. I’ve tried to cut around drum fills so that I’m editing only the basic beats and still does not edit smoothly.

I have tried to watch all of the youtube vids on quantizing drums and they do it step by step exactly as I am and it doesn’t work. Mine still sounds like hell.

I’m so frustrated - what else can I try to do??? Please help someone!!!


Open your eyes and read through the forums is what you can do. I don’t even know why Steinberg offers this stuff when people won’t even read a little before posting long-winded whines.

I’m sorry if I’m asking ignornant beginner-style questions. I’ll admit I’m new at this, but I watched the video you posted and that is the process I’ve done step for step. I’ve watched probably 30 vids on youtube - they all show that process and that’s what I’ve done. I’ve also read forum discussion after forum discussion before coming on here.

Again, sorry to be asking questions that have probably been asked before but I still don’t understand where I’m going wrong.

When new to Cubase it’s easy to dive in and try it all out. Some do hit the wall at times. When you hit that wall then it’s time to reread the manual and see if you’ve missed something as there is a lot to miss and more than a couple are one-shot brick walls that disappear when you try to look at them.
Live triggered drums can be a pain as you can miss the stuff in Cubase and also the setup for the kit itself so also look on any sites that deal with your kit and see if anyone else has run into the same wall.

Cubase, as I found many moons ago, is not a five-minutes and your up and running program. The learning curve is steep.
It is also sometimes very hard to get direct help here, which frustrates many, because of the varying ways Cubase gets used so hang in and “bump” (just type “bump”) the thread every so often as if I haven’t got you an answer someone else might.

What! you mean that some skill is still necessary??? :laughing:

:mrgreen: Alzheimers helps a lot too.

Thanks for trying to help. I really, really appreciate it.
But here is where I’m at. I’ve been on enough forums to know that newbies often get flamed for asking stupid entry level questions that could easily be found with the search button, reading the manual or by referring to others going over similar problems on youtube or other forum sites. So, I wouldn’t have come on here if I didn’t do these things. My wife is so pissed at me because I lay in bed at night reading the cubase manual and hang out in the studio trying one or two things that I think I may have found that would fix my problem. I’ve watched the vids and then re-read the manual again! I just can’t get this problem fixed. Coming on this forum is my final effort, not my first.

Can any one of you seasoned pros take a guess at what I could be doing wrong? Please guys, sense my desperation!

My guess is you’ve been playing around with musical mode!

Yeah, check the pool. Are the audio files in musical mode? If so, do they all have the same BPM? (they most likely should, unless you imported loops or other audio)


The first thing you need to fix is the tempo drift problem you’re having while recording. Could you elaborate more on your setup (audio interface, preamps, clock settings, sample rate, etc) and how everything is connected?

Duh! The Alzheimers did kick in. Forgot “Close mic’ed kit” :blush:

OK So it shouldn’t be drifting that much. Yep. The musical mode suggestions are probably on the right track, cheers men. Are you doing anything fancy with the timeline: Tempo-changes maybe?

Could be sample rate if it’s close mic’ed samples you mean, recorded elsewhere but Cubase usually asks whether you want to match those to the Project when they’re loaded. If you missed that somehow then check the Pool to see the info on the audio tracks. 48kHz to 44.1 is usually the culprit. Some sound card settings can mess around with that one but usually S/Blasters etc. less so a good dedicated DAW card.
If you recorded straight into Cubase then there may be a more fundamental problem going on, mind you, I’d have noticed on the fly. Hm?

Windows sounds? Are they off? They can mess with sample rates momentarily as they’ll switch 44.1 to 48. Unlikely but you never know.

Hi everyone, thanks for the replies today.
I figured out the drifting problem. I had too many effects on the guitars/vox tracks and it was overloading the ASIO time. I think part of the challenge is that I’m recording all tracks truly alone so I am not in the control room when tracking the drums to see that the meter was spiking. Once I turned off the effects it solved that problem. Thanks for your efforts to help as they’re very much appreciated.

I spent a few more hours tonight with the drum editing problem but I didn’t get anywhere. Here are the details of what I’m doing as they were requested: multitracking live acoustic drums into a presonus firestudio project which is connected directly to my DAW via firewire. No external pres, no nothing. As mentioned my setup is on PC Windows 7 on a desktop dedicated to my studio. There is no other software other than those that come with 7. My device setup is the Firestudio project (all default settings), and the only other settings I’ve changed are my mic routing (input and output busses). IQuantize is turnd off, as is music mode. So far I’ve spent most of my efforts on setting hitpoint thresholds and going through the group editing steps (prioritizing, slicing, quantizing and crossfading), but I’ve also attempted advance quantizing to no avail. I just get messy sounding drums, pops, machine guns, just generally unnautural. I’m not performing any tempo changes or anything too crazy. Basic power beats to a straight click with minimal fills.

I take it the drums a fairly close to the click/tempo track?


Have you tried just using the kick and snare tracks for hitpoints?

Also as a side note

You should really sort the drum track first before tracking other stuff or you’ll more than likely end up having to re time everything else.

He recorded the guitars & vocals to a click so should be fine.

A few tips.

As split said try kick & snare hitpoints only.
Work on 4 or 8 bar sections at a time. Get the splits & timing working but don’t crossfade till the whole track is done.
It will obviously sound gappy at this point but you can usually tell if it’s going to work.
When you get to a roll or fill quantise either side but leave the roll as it is. move the whole thing to sit in best position between the quantised hits either side of it…if a hit within the roll is out fix it manually or consider repping with another section entirely.
Don’t be afraid to leave stuff out of the quantisation process if it doesn’t sound good at that point…or find a section elsewhere that you can cut in

When the whole track is done hit the crossfade…try to use a very short crossfade time…between .5 & 10 ticks should do you. Audition the results carefully & go in & manually fix any crossfades that nip the start of hits or just sound odd…you may still end up manually moving a few hits at this stage & re-crossfading just those events.

I just get messy sounding drums, pops, machine guns, just generally unnautural.

Well the advice might help with some of this but not the last one. Your drums were 100% natural before the quantisation… by processing them they can only get less natural :mrgreen:

One last thing…it isn’t easy or quick. If you’re fairly new to it then expect a good couple hours work to make a decent job of it.

Yeah… IF he recorded the other stuff to the click and not the drums? otherwise the “feel” will differ.

Oh and another point, make sure the cuts are ahead of the beats, just a bit more than the crossfade length otherwise the crossfades impact on the attack of the drums.

This is very good advice. Follow it carefully and it’ll start to make sense.


Hey guys,
Wow just returned home from work and there are lots of replies from people trying to help me out. Thank you so much.
A few comments from me:

  • Yes, I recorded the guitars and vocals to the click first for 2 reasons. 1: I tend to hit the kit hard and literally struggle to hear the click in the earphones and 2: I find that when I drum to a click track I have to think. When I drum to music, the best way to describe it is that there is no thinking but rather I feel the music. I’m much more natural than when I drum to a click. I really don’t know how else to describe it better than that - maybe I’m an odd one. Haha!

  • Ok, I think I now have enough to go back into the studio and begin to take another crack at it with your help. Some of the comments that were made I’ll be honest I don’t know how to do (I’ve never edited drums manually) but I do have enough info to go back to the manual with some sort of plan and continue my learning. Last thing I want to do is continue to lean of you folks.

Again, thank you so much for all of your help.

I can understand that.

You sure you got that right? :laughing:

Anyway a good way of manually editing drums is the cut, slide and crossfade method.

This is where you cut around the beats (ahead of them) and slide the tracks using Ctrl/Alt drag. The contents of the container will move but the container stays put. then do any adjustments for start or end mess then crossfade.