Negative Track Delay with VE Pro Sameple Cutoff


I’m experiencing an issue with Cubase 12 Pro and Vienna Ensemble Pro 7 where an audio sample is cutoff too early when using a negative track delay on a Legato Patch. If I use a -230ms negative track delay the sample with not play through correctly, but if I use No track delay it plays back normally.

Is this normal behaviour? Is it something wrong with my settings or setup?

I am sure this is meant to work correctly has many composers have Cubase and VEP working together with negative track delays.

Steps to replicate:

  1. Open VEP with samples
  2. Open Cubase Project
  3. Create tracks and connect to VEP
  4. Draw a midi event
  5. Add CC1 automation curve
  6. Adjust negative track delay from 0 delay to -230 delay and notice the difference.

Any help would be greatly appreciated!

I’ve noticed this issue too. And just did another report, as I think the issue is pretty big and happens even without VEP.