New Midi Remote Controlling Sends - crashes the mapping response

I’ve tried this with 2 controllers. Mapping the sends to a dial works for a short while then crashes the mapping response, unplugging the device and plugging it back in, resolves the issue for a few twiddles.

Anyone else getting the same issue?

I’m not getting the same issue with the EQ etc on the same dials. I’ll try the Cue sends in a bit.

Thank you


What exactly do you mean by this, please?

Did you make the assignments in the Mapping Assistant or did you use a script, please?

I tested for this - and couldn’t replicate – but then again without much detail in the original problem description, maybe my test scenario was totally different.

I will do more testing and add a short video.

I made the assignment in the mapping assistant.

Thank you. I will add more info today

I managed to replicate this issue - unfortunately. It looks like it’s definitely a bug.

I’ve got a BCR2000 controlling different parameters of the mixer (running the amazing BCR script by Giampaolo Gesuale, slightly modified by me.) BCR and Cubase are in relative mode, MIDI feedback works fine, no jitter.

Controlling EQ, volume, pan, mute, solo, etc. works perfectly fine.

When I try to control sends, it will work initially, then after a few tweaks Cubase stops responding to anything coming from the control surface. When I change page on the midi remote or reset it some other way, it will work fine again until I start tweaking the sends.

I found that the issue is more prominent when I use “mixer bank zone” type channels, it happens less frequently when I play with the “selected” channel only.

I had this issue with the external script, but I also built a test script using the built-in editor in Cubase, same result.

1 Like

I’ve been having such issues as @dada_sandor explained above too, presumed it was an error in my script - but perhaps not? It’s quite random for me.

1 Like

Those randomly appearing issues are a pain in the neck to chase down.

I haven’t used sends much in my MIDI Remote adventures - maybe I should add some, in an attempt to help the troubleshooting for this one.

Are you also using bidirectional communication with endless rotary encoders for the sends or is your experience with traditional one-way sliders or knobs? And what controller are you using?

@dada_sandor @skijumptoes

Glad others have stumbled upon this too. It was very strange and started to work for a while in different circumstances. The conditions were too random for me to pin an exact report to it.

It might help to know what kind of controllers you are experiencing this with.

For example, are you using bidirectional communication with endless rotary encoders for the sends or is your experience with traditional one-way sliders or knobs?

If using endless encoders, are you using relative or absolute mode?

And it might be useful to know what operating system and which hardware controllers you’re experiencing this with.

Yes, it would be nice if I knew what all that stuff means. All I know is there’s a glitch. What works as expected on 1 parameter, doing everything the same but for a different parameter (the sends) doesn’t, well it does but it breaks communication after a few twiddles.

It doesn’t happen with any other parameter I’ve tried, on the same knobs, which means it has to be something with the sends in Cubase. I do know the controllers I used, 1 isn’t endless encoders (Virus TI) and the other is endless encoders (Mobi One).

I did try to make a video (as mentioned above) but it started to work fine, I had nothing to report or share. I suspect this one will be a hard 1 to truly locate.

I’ve only ever done bi-directional, so yes. But the particular was with a BCR2000 mapping, so much so that I stopped swapping between the mapping pages as it was so unstable when on the send parameters.

I wonder if there’s an error where nothing is in the send slot or something… As from memory, when I was playing around with it I filled the sends slot up to check all the mapping was correct and can’t recall having an issue at that stage.

Could be wrong though, my mind was more on something I’d done wrong than looking for a bug.

The only other unique part of the BCR mapping is that I was utilising the banking option in the MR… I.e. for the 8 rotaries at the top, which have 4 banks - again, perhaps related? It was the first time I had played with that feature before.

I’m not 100% this is actually Cubase bug, though. As I never got to the bottom of it, or found an easy way to repeat it. If there is a bug, I’m sure someone will find a way to isolate it.

1 Like

I played around with this and the issue comes up when you try to control sends. All other parameters I tried worked absolutely fine.

I’m using a BCR2000 (endless rotary encoders with LED rings), C12.0.40, MacBook Pro M1, MacOS12

I tried a few things, used a .js based remote and tried to create one using the built-in editor. I tried relative and absolute modes. I tried switching off parameter feedback. Every time the script failed when I tried to control sends.

One thing I noticed is that the issue comes up sooner when I’m using “mixer bank zones”. It fails almost instantly. When I’m only controlling the selected channel, it works for longer, but the issue did come up in this mode too.


Could you please provide step by step repro?

Hi all, I can reproduce that. It has to do with (important) performance optimizations which set internal processes to sleep too early. Sorry for that, I’m on it!



FWIW, while experimenting with the MIDI remote API and switching between send values, sends on/off , sends pre/post and changing their values, the sends pre/post switch became unresponsive. When trying to reload the script, Cubase crashes. Crash dump is attached.

Cubase 64bit 2022.8.29 (774.2 KB)

Hi @tannoy71, thanks for sharing!

Hi Jochen,
Many thanks for your response, I’m glad you found the cause of the problem. Hopefully you’ll manage to fit the fix in the next maintenance update :wink:

Hi @tannoy71, could you please provide the midi remote script you’ve been using? You can use the export function in the MIDI Remote Manager to create a “.midiremote” file. That’ll be very helpful!

Hey @Jochen_Trappe ,

unfortunately the script that caused the weird send on/off behaviour isn’t existent anymore in its crash - causing state. I checked the crash dump file and the memory access failure lead me to the conclusion that I might have messed up something with the declaration and value allocation of some custom value variables. So I checked that, changed some things and after that the issue didn’t occur anymore.

I can’t do any more tests, since my Cubase 12 trial got deactivated the other day.