New product Installation and updates failing installation (iMac)

For the last few months (ever since the attempt to install the Navia Harp), my Download Assistant has been failing to install new products and updates. I first get the message telling me to go and manually install the .dmg files, which I have done, no problem… but the new products such as the Navia Harp and now also the X-Stream are failing to install inside of the Library Manager and the Halion 7.1 is not installing correctly either. I get a message says that my version of the Library Manager is not the right version, however I have indeed re-installed the latest version of all of these managers individually at least 10 times and I keep getting the same issues. This issue began a few months ago when I was on Mac OS Monterey and I even updated to Sonoma and the issue still persists. I called the Steinberg/Yamaha phone tech help and the support agent was very nice, but also was unable to solve the issue. Last night I even went into my Mac recovery mode and re-installed the Sonoma OS and still the issue persists. Something is blocking my install managers for Steinberg and my Native Access for NI from installing updates and new products. All of my other install managers are working fine… Arturia Center, SSL, Waves, UA… all working fine. Is there anyone here with Mac directory knowledge that could possibly have and idea as to what is blocking these installer? The Native Access tells me a message that I need to give full disk access permissions, but of course I have granted full disk access to NA as well as Steinberg. See pics for the error messages that I keep getting. Any helpful insight would be greatly appreciated.

I think you need to update the Download Assistant.
And the additional tools get updated through the Download Assistant. Give it time to finish the needed installations.

The latest version!

I have re-installed the latest Download Assistant like 10 times already… that is not what it is. There is something deeper in the Mac stopping the installs.

Can you list the version information of the components?

Exact same as yours. I have re-downloaded the newest version several times.

If both are blocked, I would guess there is a problem in the OS.
Shouldn’t the Apple support be an option?

I called Apple Support yesterday but the woman was from India or something and I could barely understand her poor English. I might have to contact an Apple support tech here locally. I just thought perhaps if anyone here knows Apple tech, they might have an idea. I have re-installed my OS twice, but I guess I have not done a total clean erase… scared to do that.

Thanks for trying to help anyhow. I appreciate it!

I’m not using Apple products anymore, but this “privileged helper” issue showed up a couple of times here and, as far as I can see, it has to do with the MacOS start objects.

The link below had the same problem with the Library Manager and it looks like he solved it by modifying these start objects.

No don’t do that. Reinstalling the OS doesn’t help in about 99% of problems, it just takes a lot of time and, as you see, it gives you nothing.


Wow!!! That fixed it!!! THANK YOU SO MUCH!!! Crazy that that was all that it was! I went into my Mac Cleaner Pro app login manager and those helper tools were uncheckmarked, so I checkermarked them and now it works fine!! I seriously was thinking something was terribly wrong with my iMac! It is also crazy that the Steinberg Tech Support guy could not figure it out! Anyhow, thank you so much! It works!!

I now have X-Stream!

1 Like

Could you mark the post from @JuergenP as the solution, please?

How do you do that?

I don’t have a spot to mark as solution… :-/