No audio when I physically play on my MIDI keyboard

Hey everyone,

Cubase is no longer playing a sound when I’m using my MIDI keyboard.
I’m using Cubase 13 Pro, on Windows 11 with an Impact LX25+. I’m using virtual instrument tracks.
Everything used to work fine except my pitchbend wheel, and when I tried to fix it, I somehow lost audio from my MIDI.

What’s working:

  • I get audio from tracks already in the project
  • I get audio when I use my mouse to play the keyboard in the Key Editor, in chord pads and the VST Instrument plugins.
  • The meter in the bottom right-hand corner shows midi activity

What’s not working:

  • I don’t get any audio when I physically play on my MIDI on the tracks, or when loading a new virtual instrument.
  • I don’t get any audio from my MIDI when I try to load a new virtual instrument.

Things I’ve already tried:

  • Record is enabled.
  • MIDI Input and Outputs seem correct.
  • Studio Setup < Audio System - the right driver is selected
  • Studio Setup < Driver < Control Panel - the correct speakers are selected
  • Ports are Active
  • Edit < Preferences < Editing < Project & MixConsole - “Enable Record on Selected MIDI Track” checked.

I’m pretty frustrated and can’t find a solution. Your suggestions would be really appreciated!
Thanks

Maybe check the transpose buttons on your Impact LX25+.

Does it show activity for MIDI INPUT? Hover with the mouse over the activity field, the tool tip will show you which one is for midi in and which one is for midi out.

I made sure that I was always playing inside the instrument’s range. No difference, though.

Screenshot 2024-03-02 121347

for forums
Yes, the meter shows the MIDI input but not the output.

That is good, Midi output activity is not required.

In Cubase 13 each midi or instrument track has an midi input channel; kindly make sure this is on the same value as your Impact’s midi output channel (the latter you define in the midi keyboard itself).

Thanks for you great suggestion! I’ve made sure that both the MIDI output channel is set to 1 and the instrument tracks are set to receive channel 1. Still nothing’s working, though. Got any other ideas?

Just for testing, can you create an empty MIDI track (not instrument, just midi) and record some midi onto it?
Can you post the result shown the Cubase’s List Editor with a screenshot?

I had the same problem with Axiom-61 MIDI kbd.
Drove me nuts.
Go to preferences MIDI. Check MIDI Thru Active
I think this may have changed or gets reset in the prefs.
Also, make sure the midi channel monitor is enabled.

edit:
Here is the orig post…

1 Like

I’ve never used a MIDI track for anything before, but I did it anyway. It’s the one highlighted in the purple.
You can see in the bottom right I’ve circled the MIDI input but even so nothing was happening in the MIDI track. It looked the same in the Editors too.

I guess you need to read a few more topics and posts to be allowed to attach screenshots to your message.

Sorry, hopefully screenshot now attached. Really appreciate your help.

Can you please post a picture of the MIDI input/output settings in the Inspector?
I just recreated this behaviour by setting the input to not connected.

Please just try this. I’m 90 % sure this will fix it.
Go to MAIN MENU | PREFERENCES | MIDI
Check “MIDI Thru Active” box.

Okay. Unfortunately, that didn’t fix it; MIDI Thru Active was ticked the whole time. But I really appreciate it. Please keep those suggestions coming. Eventually somethings gotta work, right?

Here are my settings…

Maybe try setting it to All MIDI Inputs?.
Also, maybe try rebooting your computer, creating a fresh project and adding one MIDI channel to see if you can get some activity on the channel activity meter.

Hm, that doesn’t change anything.

Even though record enable is on for the MIDI track shown above, try also clicking the monitor button right next to it.