No Bug, 10.0.30 midi reset on stop Bazil vst3 issue

Edit! It is an issue with Bazil vst3, see post at bottom.

Since the .30 update I had to disable reset on stop in the midi preferences. It leads to all kinds of issues, ranging from silent tracks (when locating with the mouse while in play) to sequences parts not starting on the first note but on the next midi note when using locators without stopping first. I have read about other problems too, when arming tracks, sustained notes stop, which I have too. Here simply disabling rest on stop fixed it (afaics after some testing/working).
Seems like reset is send on more occasions the stop with reset on stop enabled.
Hope Steiny can take a look at it!


Could you please describe step by step the first two issues you mentioned to be able to reproduce it here on my side?

Have a sequence running on a soft synth with it’s own sequencer, which is started by a note on, on beat one of measure one. Note is one bar long. Repeat that one bar a few times. Start and let it run. When using the left locator to go to bar one while playing the sequence only starts at bar2. If pressing stop and the left locator it plays from bar one. If I disable rest on stop (midi prefs) the problem is gone.
Sounds more complicated then it is.

Issue 2 is t random. I am working on a part with sustained notes. I locate somewhere and there is no sound. Maybe it happens with the editor open. It looks like a reset is send after the notes on. Which makes it appear silent.

Probably related to this:

Sorry Martin, after some more testing (which I had time for today…) It is a bug just with Bazil vst3, even replacing it with the VST 2 version cures it.
Also the same happens in Cubase 10.0.15 so it was not related to .30. Sorry I jumped the gun.
Changed the title


Very interesting. And thank you for the update.

Could you inform the plug-in vendor, please?