No Midi out, no midi thru

This is driving me totally nuts
Cubase elements 10, Win 10 64 bits
Simply want to record a midi track to be played back by an analog synth, the simplest thing really
I can record the midi data OK but …

No midi out.
Midi data is present in a track.
But this does not get output thru midi to an external analog synth
Same for Midi thru when recording. All output thru midi does not work

Tried with 2 different keyboards connected via USB, Arturia Keystep and AKAI MPK49, same behavior. Also with a third Midi Interface, MAUDIO UNO USB.
Ports show up nice and dandy and active but nothing comes out of them

The very same scenario works fine with other sequencers (Cakewalk, Sojuku) and from within windows itself. Works with MidiOX also

Spent 3 useless hours clicking all clickable Midi related stuff, no way. It shouldn’t be that hard, really.

Did anyone experience the same ?

So are you saying that you have a MIDI Track (not Instrument Track) that you are able to assign MIDI out to a physical MIDI Port but when you play the track no data is coming out of that physical port? If so could you post a screen grab of that Track’s Inspector showing the MIDI Out assignment and also an image of Studio/Studio Setup/MIDI Port Setup.

Have you tried putting a MIDI Monitor on the Track’s Insert to see what is being sent.

MIDI through active? MIDI filters deactivated…?

Midi thru active, monitoring active when needed, no midi filters, bases have been covered. It’s a pure midi track, not an instrument one. See attached screen capture of track inspector and midi port setup. Again this happens only in Cubase and within Cubase with all of the Midi interface i tried (3 of them).

Thanks if you can help.

Mark


Midi out is set to keystep, shouldn’t that be set to your external synth ?

I believe that is the port for the external synth. The OP isn’t trying to create an External Instrument in Audio Connections, just talk to a synth at the end of a MIDI Port.

Could the MIDI being sent be on a different MIDI Channel than the synth is listening to?

Could be, need more information :slight_smile:

NO
No, it’s all set to channel 1
And Like I said this happens ONLY in Cubase
I also opened a ticket with Steinberg
Next thing I am going to re install all, usual thing when we don’t really know what to do.
Thanks for all the suggestins but they were all basic stuff already covered
I am asking if anyone has had similar Midi related problems

Well elements doesn’t have External instrument.
There is no audio track, that is set to monitor the synths audio output.
It could be monitored using the soundcard interface, we don’t know.
Is the synth visually receiving any midi input, or is it the sound that is missing ?
Where is it connected both midi and audio ?
And no, midi works fine if you set it up correctly. There always could be the odd chance of a dodgy driver or the user letting the computer go to sleep with a project open. Well it is computers so many things could cause it, but it is mostly something simple that Cubase does different, that new users get wrong.

The synth is receiving no input
The track shows midi activity when playing back, but it just doesn’t get out of the box
The drivers with arturia keystep are OK since it all works in any other application
I don’t need to monitor or anything in Cubase, I just need the midi to be sent out and it doesn’t happen
Computer going to sleep, please spare me
The analog synth goes direct to headphones no problem there
Arturia keystep should work as a USB midi interface and it does so from any other application but cubase

Question. Does steinberg offer trial versions of the higher cubases? I might try that route
Thanks all

Yes but I hey need a eLicenser dongle.
Not that it would make any difference really. There is more functionality, but basic midi recording and playback is not different.
I would trouble shoot some more, try different combinations of midi input and output, just to eliminate that.
Double check midi filters, that nothing is ticked.
Start Cubase in safe mode, hold ctrl shift alt while Cubase is loading, and you will get some options.
Could be a corrupt preferences file, start up with default settings and try if it works then.

IT WORKS !!!
Thanks you thank you thank you ! Afret for 4 days of headache thak you a bundle !
By starting in safe mode and disabling the prefernces it all works !!!
Thank you SO MUCH peakae for your suggetsion and your knowledge, I was not even aware such an option was available.
Having said that this is clearly a bug in Cubase. A hidden prefernce, unknow of, that overrides whatever you have in your project. Bah . . .
Luckily we have sage people that help . . .

Glad I could help.
Cubase writes preferences when closing down and not when you apply or ok them.
If there is a crash while closing, the preferences might get corrupt.
It might be a good idea to make a backup, of the preference files. Here is a list:
https://helpcenter.steinberg.de/hc/en-us/articles/115000245510-Preferences-of-Cubase-and-Nuendo

Back to square one.
Does not work anymore ! Totally annoying.
It worked just once and the on reopening Cubase same behavior, Midi in OK but no Midi out, no Midi through.

So I wanted to have a clean situation and I uninstalled Cubase and everything related. (not the SW elincenser, shall I try that also ?)

Then I got the latest Elements 64 bits 10.30 and reinstalled.

Again I checked that:

  • This is a proper Midi track and not and instrument track
  • Output is routed to Keystep
  • There’s midi data in the track
  • Studio Setup -> Midi Port setup shows Keystep in and out visible and active
  • There’s no Midi filtering
  • Edit -> Preferences -> Midi shows Midi thru active properly on
  • Edit -> Editing -> Projects and MixConsole shows Enable record on selected Midi tracks on
  • Tried all combinations of Record / Monitor On and OFF

No joy.

Finally I also tried with a simple Open source Midi sequencer and all works as it should, so this cannot be a system issue, but has to be a Cubase one.

I have also tested with another Midi interface and within Cubase the result is the same, no Midi Out out, no Midi trough.

I am really lost. Anyone has ever experienced this ?

Thanks,

Mark.
2019-08-24 12_21_18-Cubase Elements Project - midi test.png

Bump. Anyone ?

One more (rather desperate) try - raise the MIDI volume fader…?

Midi fader raised, no luck. Actually the midi fader does move up, showing Midi activity.

I have also engaged Steinberg support, after some really preposterous answer (we only support Yamaha synths (?!?!?!?!?) eventually they suggested I renamed the preference file as to hide it.

Did that to non avail; this would be equivalent of launching Cubase in safe mode; also done that as kindly suggested by another member, worked just once (?).

Also used the 2 files they suggested, in the midi enabler folder: enableemulated and ignoreportfilter; again no luck.

All this really driving me nuts, spending hours on IT issues instead of making music. Next thing I’ll do is switching sequencer. Any suggestion ?

My suggestion would be to try Cubase 10 PRO. More people can help you. I have MIDI devices connected via USB and MIDI Cables. Everything works fine. Was very easy to set the devices up as Cubase External Instruments, a very important feature for Cubase Pro.