No playback on interface (MOTU M4)

Hoping I can get a resolution here. Pretty sure I’ve tried relevant things in the 17 minute video (Edit Device etc).
Diagnostics attached.

No playback on MOTU M4. Other apps play fine.
Playback on internal speaker works.

I’ve reinstalled Dorico 3 after removing the files as described here

/Applications/Dorico 3.app
/Users/your-username/Application Support/Steinberg/Dorico 3
/Users/your-username/Library/Preferences/VSTAudioEngine3
/Library/Application Support/SMuFL/

Haven’t reinstalled Noteperformer yet.
No luck so far.
Thanks in advance.
Dorico Diagnostics.zip (325 KB)

Welcome to the forum and thanks for the data.

To be honest, looking at the data, I don’t see where the problem is.
The M4 driver can be selected and the audio engine seems to accept it, and there is nothing unusual to be seen in the logs.

I have a couple of questions:
Does MIDI input via the M4 work in Dorico?
Dorico tries to wire it’s audio output to the M4’s Out 1/2 ports, is that where you expect audio to come through?
When the M4 is selected in Dorico and you start playback, when you open the HALion Sonic SE editor window, is there any metering activity going on in that window? Especially have a look at the top middle of the window, as that shows the metering of HALion’s main output.
What if you open Dorico’s mixer window, is there any metering going, especially on the right most, the master channel?

Thanks Ulf.
Yes, MIDI from the M4 works in Dorico.
No, I don’t see any metering in the Dorico or Halion SE mixers.
Yes, my monitors our plugged into outputs 1 and 2.

One (related) observation for you. When I adjust volume on my menu bar or touch bar, I must make sure the appropriate output (built-in or M4) is selected. There’s a part at the end of the troubleshooting video that recommends unchecking that attenuation check box. But I suspect many users are just adjusting the wrong volume. Anyway, that’s a separate issue - just thought I’d point it out.

Strange, strange.
Do you have the latest M4 driver? According to the website less than one month ago Motu released version v4.0+84479a
Please try with that, if you don’t already have it.

If still same issue, please create a new project from piano template and then create a new diagnostics report. Thanks

Hi Ulf
I did not have that updated driver - “improved support for Cubase” - but do now.
No change. Diagnostics attached.
One thing I notice is that in the Device Setup… dialog, when I switch to Built-in I get a brief spinning beachball as though CoreAudio is thinking, and the Stereo Output dropdown then reads “1,” but when I change to M4, there is no beachball and the drop down changes immediately to “Out 1, Out 2”.

Thanks.
Dorico Diagnostics.zip (362 KB)

Thanks again for the data. Odd enough though, the logs look all totally fine and there is nothing that suggests that it would not work properly, so - honestly - I’m running out of steam.
May I ask you to download the Cubase Elements 30 day trial (https://new.steinberg.net/cubase/trial/) and see how that goes?
Otherwise I can only offer doing a remote session via TeamViewer, VNC or Zoom so that you can share your screen and we can have a look together.

Hi Ulf
I cleaned off some space and installed Cubase Elements. I was able to get it to play through my M4 and monitors.
I’ve attached screen shots of the Studio Setup dialog.
If that doesn’t trigger additional ideas, I’m open to a Zoom session. I’m in Seattle.
Thanks,
Richard.


Hi Richard,
at least good to hear that it works with Cubase. But strange enough, then it should also do with Dorico, because Dorico’s audio engine is derived from Cubase.
Let’s have a Zoom session then. I’m an early bird and get up at 6, so we could start 6:30am, which is 9:30pm in Seattle, if that suits you.
Please send mail to ‘u dot stoermer at steinberg dot de’ and we’ll arrange for the details.

Hi! I had the same problem earlier and it was caused by the driver software downloaded from motu’s webpage. When I removed this software the sound started working again with dorico and motu M4.

If you figure out how to make it work with the driver, could you post the solution here?

I’m still in direct contact with Richard and still trying to figure out what is going on. But once we have a result, I will post here again.

Good to know I’m not alone :slight_smile:
I’d rather not remove the driver (it provides loopback and lower latency) but good to know that Dorico works in class-compliant mode.

I had this same problem with my M4. Audio in all other apps (including Cubase) worked fine, only Dorico had a problem. The only way I could find to resolve it (on Mac) was to use an aggregate device. See this thread:

https://www.steinberg.net/forums/viewtopic.php?f=246&t=129479

Thanks for that @jwimble. The Aggregate Device workaround works for me too.

The latest M-Series driver (v2.0.84610), released 2020-04-15, seems to have fixed this problem!

Many thanks for sharing this info. For Richard it works now as well.

New driver works for me too!