No presets for new plugins in cubase 13

Did you read the posts from @Joerg ?
He is one of the developers. And he already confirmed that there is a flaw with the handling of that presets inside the Library Manager.

Looks like Im in catch up mode here.
Did just see Joerg comments.
That will teach me for following the Steinberg Info about how to use the Steinberg Library App. There are no warnings about this flaw in their official guide (at the moment).
Looks like I may have a bit of a mess to tidy.
Why can’t we just be given a list of the paths so we can see what really intended.

Clearly the Cubase 13 install did not register its own VSTsound files as the presets were missing.

Trying Ito learn how to pick up all the information re issues on this forum isn’t intuitive, at least to me, either.

Thanks
David

2 Likes

I’m struggling on two fronts here.
1: Use of the forum to get my message to the right place.
2: identifying what the default file locations for all the vstsound files should be and which ones correlate to which instrument. There is no common naming between the data collections seen in the Library App and the files on the computer. Also no clarity between what are vstsound files (private) which should remain static and vstsound files (movable) so you can keep them where you choose. The computer end just sees them all as one file type. I understand paths and their importance but not some of the automatic program nuances.

If you can tell me what "common: location is on a Mac it would assist. Clearly I have a mess to tidy caused by using the Library app expecting it to take care of the nuances of vstsound files.

Thanks
David

We, the community, and @Joerg found this bug together on Friday afternoon.
So what do you expect?
And, btw, Joerg already announced a fix for it.

It might need more time for explanations, but I feel I can’t sleep without a little clarification on “common” …: VST Sound files located inside the Cubase / Nuendo program folders / bundles are NOT common, I called them “private”, because they are only seen by the specific application. They get modified per Cubase / Nuendo version, because they fit exactly for the program and plugin set.

Those VST Sounds: FCP_SMT_00x_Cubase / Nuendo must not be copied or linked anywhere… the Library Manager does it and that is a bug, there needs to be a warning, but there isn’t.

Unfortunately double-clicking them, the Library Manager will open and copy or link them to these “common” locations, “common” because all our apps know this paths:

C:/Program Data/Steinberg/Content/VST Sound (win)

/Library/Application Support/Steinberg/Content/VST Sound (mac)

which is the source of evil … they don’t belong there!

I’ll check back during my official working hours … now AFK :wave:

5 Likes

@Joerg, thanks again for clarification.

1 Like

Thanks Joerg


Having now examined the files in the VSTSounds “common” location on the Mac which you pointed me to. (/Library/Application Support/Steinberg/Content/VST Sound)
I notice it contained Alias links to private files for Cubase 11 - FCP_SMT_008_Cubase.vstsound. as well as to Cubase 12 - (SMT_001, SMT_002, SMT_004,SMT_005 and SMT_009).

Despite there being a separate folder for Halion there were also some HSSE links along with the new VSTSounds from Cubase 13 and some empty folders which appear to relate to Demo projects which came with Cubase. I attach a screen shot of my content.

Further to this I see the private files VSTSound in Cubase 12 app appear to have been replaced with those from the Cubase 13 app.

I assume reinstalling 12 (or recovering from backup) will correct the private VSTSound files in the Cubase 12 app.

So what I don’t know is why the common file links were there for Cubase 11 and 12 private files which appear to work OK.

I assume why I and some others couldn’t see the Cubase 13 preset was that the common files errors were overriding the apps VSTSound private files as they had the same name and pointed to Cubase 12 private files.

The incorrect registration via the Library fixed the missing presets because it actually replaced the the private files in the Cubase 12 app with those from the Cubase 13 app.

I believe I choose the Steinberg Library registration option of default rather than register in place when it popped up in the Library and now assume this is the difference between those two options.

Not seen any documentation on the Steinberg Library app which actually advises what those options did.

Would appreciate your comments on my observations and how I should fix.
Not sure whether the Library app XML files need rebuilding as well as Cubase 12 private files.

Cheers
David

Please delete those links, I don’t think they are cleaned up by the Library Manager.

That’s all fine, there are product specific folders under Content, the content of those will appear in the related products.

Cubase 12 and Cubase 13 have files of the same name, but they contain different content. Cubase 13 should be installed next to Cubase 12 … I need to check with our QA, maybe @Axel_Sandig (Hi! :slight_smile: ) can help me with this task.

Yes, I would expect that.

Yes, exactly!

It replaced the links in the common location, I don’t think it replaced them in the the Cubase12.app … but I did not write the Library Manager, I will ask if that is possible.

Need to check that.

Will ask if there is anything.

Also needs to be checked.

Thanks a lot for your efforts, careful observations and the report! I will go through it with my colleagues here and I am confident that we can improve the situation.

Cheers,
Jörg

Thanks Joerg.
I believe I’ve now fixed and corrected my problem.
I think I would have avoided getting into this mess with a better documentation of the Steinberg Library app and its registration options.

I’m certain it did actually replace my Static Cubase 12 files with those from Cubase 12 when I chose the default registering option. I fixed that by restoring my vstsound static content files from my Time Machine backup although I suspect a reinstall of Cubase 12 would have fixed as well (but might have introduced other issues)

I’m pretty old school having worked on both PC and Mac manually with path corrections so not too keen on all this time saving automatic stuff. Probably why I get into a few messes with a hybrid solution lol.

I deleted the links in the common library and all appears ok now.

The Halion issue is a new one for me as a side effect of trying so sort the vstsound missing preset problem in the way I did created a new error on launching Cubase 12. The error alludes to not finding a licence for Halion Sonic SE.

Now I don’t think that’s really a licence issue as I use the new Auth system and have a licence for both Cubase 13 and Halion 7 which should, by being backwards compatible, not create any licence issues for the use of Halion SE VST sounds. So I believe that is something to do with the vstsound files added over time as I’ve owned every version of Halion since it was introduced.

What I’d need to root this one out is a complete list of the vstsound files which should now exist for Halion after all the updates and consolidation. Certain files such as those with the letters MP and SP in them are not fully documented in anything I’ve been able to find so it makes tidying up old files and their correct locations difficult so you have to hope the Library does its job, but as we have seen it’s not necessarily the case. I can’t see why we have dedicated Halion Vstsound folders in the common location then install links or files outside of that in the vstsound folder. It seems as if that was some sort of patch fix during Halion upgrades and consolidations which Steinberg used.
A manual list of files and locations would be very useful.
Any observations on that one would assist.

Cheers
David

1 Like

To accomplish this I would create a clean installation (of the available licensed stuff in recent version) via SDA (Steinberg Download Assistant) and diff an empty system (e.g. in a virtual machine) against the complete installation. Manually compiling file lists and keeping them up to date would eat up time we could invest better.

I’ll discuss this pain with developers and planners. That’s what I can promise. I have to move on with development tasks now, fixing some loose ends and start optimising as soon as possible.

Thanks for pointers. I feel some of the complexities of maintaining a clean system over time are often overlooked. For years I never had any issues with Cubase or installs. My last 3 issues however have all been about issues caused by upgrades which left a few loose ends affecting the next upgrade. One was case differences in file names used which left duplicate plists affecting upgrade installs on the AXR4 as an example. I think Steinberg developers such as yourself do a great job but in large companies no one can ever get the full picture. I’m guessing from your posts your developer area is around the media bay something I’ve yet to fully appreciate and utilise. Thanks for help it’s fully appreciated.

Cheers
David

1 Like

The problem of missing presets in 13 is still an issue for me. I don’t want to risk overwriting all my Cubase 12 content. Is there a simple workaround for a non-technical user that will help me get the presets back, or should I wait for a patch to be released?

Thanks,
Rudi
Win 11

2 Likes

Rudi.
Post a screenshot of the files held in this folder
C:/Program Data/Steinberg/Content/VST Sound (win)
and it may assist rectifying the issue.

Im not a PC user now but used to be so a little rusty on the PC paths but that path is what I believe is the shared path for cubase versions to look at on a PC. Should hold files and links to VSTSound files common to all versions of Cubase.

Each version of Cubase has its plugins and presets held in its unique VSTSound folder which should not be cross linked. ie it could be 13 presets are not showing up because a shortcut exists in the “shared content folder” which I believe is the folder path above, that points to Cubase 12 preset location and not those in Cubase 13. Therefore when you run C13 the computer only ever looks at the Cubase 12 unique vstsound folder and never sees the Cubase 13 folder where they exist. If you ran C12 you would see no issues. On a Mac the link / shortcut pointer file is called an alias I think its called shortcut on a PC but can’t remember the file type suffix name. If you find shortcuts to the specific files below existing in the shared folder then that’s likely to be your problem.

On a Mac the vstsound file names and size unique to Cubase 12 are :

FCP_SMT_001_Cubase.vstsound 85.2MB
FCP_SMT_002_Cubase.vstsound 1.6MB
FCP_SMT_004_Cubase.vstsound 58.2MB
FCP_SMT_005_Cubase.vstsound 42.8MB
FCP_SMT_009_Cubase.vstsound 26.3MB

For Cubase 13 they are

FCP_SMT_001_Cubase.vstsound. 85MB
FCP_SMT_002_Cubase.vstsound 1.6MB
FCP_SMT_003_Cubase.vstsound 26.3MB
FCP_SMT_004_Cubase.vstsound 59.7MB
FCP_SMT_005_Cubase.vstsound 43MB

I can’t imagine the names will differ between Macs and PC.

The solution here being delete the erroneous shortcut and the problem should be solved.

Content files themselves are not touched, only the shortcut pointer file to their location.

Hope this assists in explaining the most likely reason for not seeing the new Cubase 13 presets.

Cheers
David

2 Likes

Hi! Where is this “shared content folder”? Is it same place as “common” location on the Mac? /Library/Application Support/Steinberg/Content/VST Sound. <—this?

Seems like all Steinberg sound content is missing in my system. Also Halion content is missing.
Already reinstalled everything.

Edit:
I got sound content working by updating Mediabay database.
New plugins factory presets still missing.

Hey, Unfortunately I am also a victim of this flaw. Just started on 13 didn’t come from 12.
Am I just deleting all these files?





Just want to make sure I’m not about to brick my entire system :confused:

I didn’t even realise loopsmash had presets till I saw this…

Exactly the same for me. Media bay now ok. But all the presets are out of whack

1 Like

I’ve recently upgraded Cubase 12 to 13 and Halion to v7. Since the upgrade, certain VST instruments stopped working. For example, when I select “Model C”, all sounds have an error sign. When Click on any of them, I get an error message (see a screenshot).

Hey there. Hope this helps. Run into this numerous times. Please restart your machine and let me know how you go.

Hi,

  • Quit Cubase.
  • Locate the Steinberg MediaBay Server folder in your preferences folder and rename/remove it.
  • Start Cubase

The Preferences folders are:
Mac: ~/Library/Preferences/
Win: %appData% Steinberg/

Hope this helps.

Nop, not working