No sound after using bluetooth headset

I was entering music in Dorico on MacBook Pro and I decided to use my Parrot ZIK3 headphone to listen to what I have entered. But after connecting the bluetooth headphone and re-launching the Dorico a few times (including re-starting my Mac, shut-down and cold boot, etc.), I just can’t hear any sound (while the Parrot headphone works well with other sound apps on my Mac).

Then I disconnected the Parrot bluetooth connection and discovered that the Dorico file just can’t play any sound any more, even if I add new instrument! However, all other Dorico files work fine, they can play sound as usual.

I attach my ‘corrupted’ file here, please take a look.

I have managed to work around by retrieving a previously saved file from Time Machine and simply copied over all my new edits from the corrupted file to the earlier file and I didn’t lose any new entries.

(BTW, just some more background info… this Parrot bluetooth headphone also doesn’t work smoothly on Sibelius 7.5. From trail and error, I discovered that I need to shut down Sibelius, connect Parrot bluetooth, then launch Sibelius, access the “Audio Engine Options” and set the “Interface” to Parrot ZIK 3, then Sibelius can play sound on Parrot headphone. Also, if I didn’t re-select the Built-in-Output in the “Interface” option before I shut down Sibelius, it will crash upon next launch.)

JM.
xMozart Presto bad.dorico.zip (1.78 MB)

The issue with BT headsets has been already discussed in this thread: https://www.steinberg.net/forums/viewtopic.php?f=246&t=109251
Please read that first. If you still got questions, please ask.

I’ve attached a new version of your project. Load that into Dorico, then go to Play Mode and choose Play > Apply Default Playback Template. You should then be able to continue working with it.
xMozart Presto bad 2.zip (184 KB)

Thanks Ulf, the file works!
How is it that the file size is reduced by so much!

I’ve deleted parts of the project data, namely that what configures the audio engine. Once you load it again, it will get recreated with default values. That’s also why you had to do the ‘default template’ thing in order to get the right sounds back. Now that it is working again, have a look at the project’s file size, it will be equally sized as before.

Dear Ulf,
I followed the instructions in your earlier post on Jan 26 on the other related thread, i.e. by creating an aggregated device as described by dbudde for my AirPods and I could listen to my work in Dorico on AirPods. I also switched back to listen on the speaker on my Macbook Pro from time to time and this went on fine for many days. But 2 days ago, after I disconnected AirPods and switched to speaker on MBP, there is no more sound from Dorico. Switch back to AirPods, re-start, shut down, Apply default playback template, etc… still no more sound from Dorico, only for this particular file that I’m working on. My other Dorico files are sounding fine.

Also, I notice that there is a new option “Instant On Sound Effects” appearing in the Audio Device Setup/ASIO Driver in the Preferences of Dorico. This option does not appear in MacOS’ sound preference, so it must have been generated within Dorico.

How do I delete the audio engine part of my Dorico file to get back the sound? (I do not want to send my file over as it contains my work in progress)

Okay, pretty easy. First, though there is low risk but still, I’d suggest you make a backup copy of your project.
Then take your Dorico project file and unzip it. Yes, despite the ending ‘.dorico’, it is actually a zip archive.
After unzipping you will see 2 files and 2 folders. Then delete the file \supplementary_data\vstaudioengine\enginedata , but just that, nothing else.
Almost done, now you only need to zip the whole thing up again; the only thing you have to watch out for: zip it up from the 2 files/2 folders level. E.g. using my favourite 7zip utility, I select the 2 files and 2 folders and then choose “Add to archive”. Needless to say that you then have to change the ending from ‘.zip’ to ‘.dorico’ again.
That’s it, load in Dorico and ‘Apply Default Playback Template’ and you shall have sound again.

For what it’s worth, ‘Instant On Sound Effects’ has nothing to do with Dorico, but is part of the packages made by a developer called Rogue Amoeba, whose products are things like Audio Hijack, Loopback, and Piezo.

Thanks Ulf, it works! I now have the sound back. What a relief to me!

To Daniel, thanks for telling me about ‘Instant On Sound Effects’. I have something from Rogue Amoeba installed on my Mac though I seldom use it.

Thanks again!
JM.

sorry Ulf, the relevant information in the referenced thread is so scattered along a winding and hard to parse road that it would be nice if you could make a point-to-point tutorial about how to get bluetooth headphones to work (for both windows and mac). at least until this is sorted out in some Dorico update.

thanks for your help.

Dear Ulf,
Another related issue, my VST plug-in (HALion Sonic SE2) still has no sound when I click on the piano keyboard at the bottom of its window. This happens to all my Dorico files even though they can play sound on my computer speaker. How do I get its sound back?
Screen Shot 2017-03-18 at 11.01.16 AM.png
Also, please refer to the attached screen capture, how do I delete the extra instruments (the 3rd and 4th piano lines), i.e. I’m only using 2 pianos, but there are 4 piano lines under piano player1 (should be only 2 pianos). I think the 2 extra piano lines came out after I changed the VST plug-in between ‘HALion Sonic SE2’ and ‘Symphonic Orchestra’ several times.

so, after following the directions and creating an aggregate sound device in the Audio/Midi set-up panel so that my bluetooth headphones are producing the output - 44.1 kHz - and no microphone input @ 8 kHz, i STILL don’t get sound output from Dorico. Sibelius and Finale output are fine. is there a solution for me? - unclear at this point. i guess i will have to wait for an update that corrects this mysterious behavior.
Screen Shot 2017-03-19 at 06.23.55.png

You haven’t given the device a unique name. The 2 regular devices have the name “SoundBuds Slim” and your new agro device has the same name. That is the trouble in first place, two devices with the exact same name. Now you have even 3, doesn’t get any better. Double click on the name and rename it to whatever you want, e.g. “SoundBuds Fat”. Then start Dorico and in Device Setup choose the ‘fat’ device :wink:

If you open your Preferences, scroll all the way down to the Play options, do you have the option “Suspend audio device in background” ticked? If so, please untick and try again.

Sorry, I don’t know on this one. Someone from the London team needs to step in…

Those extra two ‘lines’ are voices. In the next update this view may change to not show separate voices by default, which would mean that you would see all voices in the same view, but differentiated by colour.

I tried this, it still doesn’t restore the sound from the VST plug-in keyboard.

Very strange…Have you really applied the change? Please restart Dorico and check for the settings again. Really no sound when you play the on-screen keyboard of the HALion window?

If sound does come out during normal playback, then definitely also sound shall come out when playing on the on-screen keyboard. But for some of the instruments you have to turn up the modulation wheel, as the mod wheel then controls the volume. Try with a piano sound, that shall come out straight away.

Hi Ulf,
No luck, I tried the ‘Suspend audio device in background’ a few times (on/off), and I also tried fiddling with all the dials and settings on the VST plug-in, still can’t get any sound from the keyboard. I set VST instrument to ‘Symphonic Orhcestra’, also no sound from its on-screen keyboard. BTW in ‘Symphonic Orhcestra’, there isn’t any piano, is this correct?

Anyway, my Dorico still plays out the sound, so this VST keyboard is not a show-stopper for me. I can wait until next update to reset it.

BTW, the VST plug in looks very formidable to me, is there any user manual or instruction about it?

Very strange…for the moment I have no clue anymore, have to think more about it.

In the meantime, you can access the HALion Sonic manual here: http://support.steinberg.de/downloads_software/VSTi_HALion_Sonic_2/Operation_Manual.pdf

I’ll be back…

I’ve still no clue…
It is so weird that sound does come out when you hit play, but nothing when you click on the on-screen keyboard. I’ve never heard of something like this before. It should simply do.

Could you please post a simple piano project which you think exposes the problem?
And also, please take a screenshot of the HALion window while on the MIDI page (press F8 to get there).
Sorry, just poking around.

Here’s a simple Dorico project of mine … but I discover that all my Dorico project files can play sound but not the VST on-screen keyboard, so I think it is more likely a problem with the setting of my Dorico…
Rondo alla turca practice.dorico.zip (254 KB)
the screen shot of the HALion window is here:
Screen Shot 2017-03-23 at 9.50.22 PM.jpg