no sound again

Things I’ve done: apply default playback template; device setup is set to generic low latency asio driver, tried a new short piano piece, but none of these has worked. It worked fine for months. I did do a monthly windows rollup update but don’t think that would have affected playback.

What to do next?

Thanks, RIchard

Please post that piano piece.
Also, please zip up the folder
Win: C:\Users<yourname>\AppData\Roaming\Steinberg\VSTAudioEngine_64
or
Mac: /Users//Library/Preferences/VSTAudioEngine

here it is
piano ex1.zip (199 KB)

From the project data I can see that you have the Generic Low Latency Driver selected, but that driver can’t see any output ports, thus doesn’t know where to put the sound actually out to.

Please go to Edit > Device Setup and push the button “Device Control Panel”, a new little window with driver settings will appear. In the middle is a box where all the found output ports are listed. Is it empty with you? I suppose so. What then at the top of the window, is the option “Allow ASIO host application to take exclusive control of selected port configuration” ticked with you? If you do tick it, does then at least one output port become available?

The output box is empty. I do have “Allow ASIO…” checked but there is no output device listed.

And if you untick it, does then an output port show up?

If there is no output port, you will never get sound out.

If I untick it no output device appears, and if I close it and re open it it’s ticked itself again. I’m downloading real tek audio codecs now to see if that helps. As mentioned, it was working fine.

On your Windows toolbar, on the right, normally there is a little speaker icon. If you right click on that and choose “Playback Devices” a new window appears. Is there any playback device listed? At least the Realtek device should be there. What is the status of it, ready or disabled?
If that window is empty, do a right click in that window and make sure that the submenu for “Show Disabled Devices” and “Show Disconnected Devices” is ticked. Still no Realtek device?

I have IDT high definition audio codec and it tells me that the device is working properly. I haven’t installed realtek yet as it has just finished downloading.

I don’t seem to be able to get a playback device to show up.

And what does the Device Manager say?
In the left bottom corner of your screen, right click on the Windows icon and choose “Device Manager”. Then look for the item “Sound, video and game controllers” and unfold. Does there your Realtek device appear, what is the status?

Under sound, video and game controllers I have: IDT High Definition Audio CODEC and NVIDIA High definition audio.
Windows tells me they are both up to date and functioning.

And through what device did you previously play out sound from Dorico? From what you are writing, it seems that you had a Realtek device and somehow uninstalled or disabled it from your computer.
I don’t know the IDT or NVIDIA devices and whether it should be possible to get sound through them or not.
But since they don’t turn up with output ports in the Generic driver’s device panel, it seems like not.

That’s the odd thing, I seem to remember it being Realtek but I sure didn’t do anything intentional to make it disappear. Odd.

Very odd and I’m also running out of steam…

Once more back to the Device Manager. Instead of the “Sound, video and game controllers”-item, do you have at the top of the list an item “Audio inputs and outputs”? Is there any output listed?

I don’t have that category in my device manager

In that case I also don’t know further anymore. The problem then is not Dorico or the generic low latency driver but your hardware.
Try searching the web for similar issue. Here are e.g. 3 Google results, maybe one of them can help you:

https://www.drivereasy.com/knowledge/easy-to-fix-error-no-audio-output-device-is-installed/
http://www.techspot.com/community/topics/cannot-find-realtek-in-my-device-manager.188563/
https://www.sevenforums.com/sound-audio/261806-no-sound-video-game-controller-device-manager-no-audio-full-stop.html

Tap your ‘Windows Key’ on your computer keyboard and hold it down, then tap r.

In the run prompt that pops up just over your start icon type:

dxdiag

Click OK.

After a few seconds you should get a window for the Direct X Diagnostics Tool.

Click “Save All Information”. You’ll get a prompt asking where you want to save the resulting report. Save it to your desktop (or anywhere that’s easy for you to find). Zip it, and post it here.

Perhaps with that report, some of us can take a look to see what audio drivers are really installed in your system.

If you’ve got a pretty old motherboard, sometimes we need to either find new Reference drivers for your sound chipset, OR, go back and reinstall the ones that came with XP/Vista/Whatever, and perhaps set things to enable ‘unsigned drivers’. Why? Occasionally people who upgraded from XP, Vista, Windows 7, etc. had things working fine until some Windows 10 auto update (The big Annual Windows 10 Update that came down sometime in September) decided to clean out all the ‘unsigned drivers’.

I’ve had something similar happen on my older rig before…had to go through the process of enabling unsigned drivers, then reinstall quite a few of them. In my case, I needed newer reference drivers for my onboard audio chipset. I also had a bunch of older stuff that while it was properly signed for Vista, for whatever reasons, Windows 10 rejected them based on the digital signature.

Of course, all of that can be avoided by simply purchasing a modern USB Audio interface well vetted in Windows 10 and plugging it in :slight_smile:
Examples:
https://www.steinberg.net/en/products/audio_interfaces/ur_serie/start.html

It’s also worth rebooting if you haven’t already, as that can cure many problems, especially with hardware.

Thanks for all the suggestions and effort. Before I get into that I will note that I was looking at the windows speakers icon and the box for “allow applications to take exclusive control of this device” was unchecked, so I checked it and rechecked the Dorico device setup and noticed I had the generic ASIO device under playback. Still not getting any playback sound after resetting sounds in Halion but it must be progress.