no sound on imported midi file

I have downloaded a midi file which plays on media player. I have imported it into an empty project in Cubase LE 4 and all the tr acks show. When I play it I can hear the click (metronome) but not anything else. The meters do not show any signal. Do I have to set up any Midi devices? Audio tracks and Addictive drums VST both work.

Vista
Alesis io-2

What VSTi are you using to play back the file?

Thanks for the reply. How can I find out?

What’s selected as the output of the track and what kind of track is it?

There are 13 midi instrument tracks, named as different instruments

If i choose the first track and use Halione I get an output. When I saw a midi file imported on youtube it was just imported and then played. All the individual tracks did not need to be allocated an instrument for the music to play.
Sorry, I’m new to all this!

Doesn’t work that way. MIDI is data, not audio. In LE4 you have to use Instrument Tracks, select a VSTi as the output and then select the desired preset for the desired instrument/ sound.

You can download a General MIDI VSTi from Steiny’s FTP site called Universal Sound Module or go to kvraudio and download a free one there that will make selecting sounds a little easier. You get to the FTP site via the downloads page at steinberg.net.

Halion One should have a GM bank too though, and I think there is a preference somewhere where you can select which VST to use when importing GM files. Don’t know if that’s in your version though.

Sorry for some reason I got locked out of this forum yesterday. What I would like to do is shown in this clip:
http://www.youtube.com/watch?v=OaD4J9-VJkk
He just imports it and it works!

I’m having exactly the same problem with LE 5. Hope somebody can give us a useful answer. Getting very frustrated. Already had enough problems just getting e licenser to work properly.

Is it importing to MIDI or Instrument tracks?

I have a midi file on my desktop. I open a new empty project in Cubase 4 LE. I drag the midi file from the desktop onto the project. The file loads all the instrument tracks with the names of the instruments. I click on play and I can hear the metronome but none of the channel level meters show anything and I hear no music. If I set an output on one track to Halione and select a preset I can hear that track when I play. On the above YouTube the file is imported and plays without having to set each channel. This is how I would like it to work for me.

So what is selected as output for the instrument track after importing the file? No VST instrument at all? Or does it select HalionOne but it just doesn’t play?

The output is blank - no VST

There’s your issue then.

Hmm, been digging a bit, it appears HalionOne is not really reliable for this. I seem to remember I used it a couple of times without problems, but you are not the only one reporting it doesn’t automatically select instruments. Try USM from the link Mashedmitten posted.

Something tells me there is an option in the preferences somewhere where you can select the default VST to use when importing GM midi files, have a look for that and see which VSTi you can select there, then try importing again.

Thank you for the advice. When I installed Cubase from the CD HalionOne was installed at the same time. I then installed Addictive Drums. Could you tell me how to change from HalionOne to the one you suggested?

I have the following “Devices” connected if this helps anybody solving my problem. In Midi Port Setup, I have “Microsoft Wavetable SW Synth” as my output. In “VST Audio System” I have ASIO DirectX full duplex driver with SoundMAX Digital Audio 1 & 2 as output ports and for “VST System Link” I have SoundMAX Digital Audio - 1 for ASIO Input & ASIO Output. If anyone can solve my problem it would be much appreciated or I might have to give up trying to use Midi and just play “Live”. (Heaven forbid) Kind Regards to all.

I have looked on Steinberg’s site and found the USM but it is for MAC not Windows!

It’s also for PC, see here: click.

I think you can just download both files there, go to where you installed Cubase, open the VSTplugins folder (there is probably another VST plugins folder inside the first, open both.) Now create a folder called USM and put both files in there. Restart Cubase and you should be able to select it as instrument track output.

I’ll have a look on my own system when I get the chance concerning the automatic selection of the output VST, will get back to you on that.

@Lotney: You don’t need VST system link, doesn’t hurt but that’s for linking multiple PC’s together and streaming audio between them. You should also download and install asio4all and use that instead of the DirextX driver. Will not solve your problem but it’ll save you trouble later :wink: