Non-existant Notes Triggering Sampler Track

I have an Audio File of a drum-loop which you can see on the Track named “DLoop” in the animation below. Notice that it is not Tempo aligned. Below that I created a Sampler Track (SLoop) to Slice the drums so the individual hits could be triggered by MIDI. When I dragged the MIDI out of the Sampler it snapped to bar 58 and I had to move the MIDI Part to align it with the audio drum-loop.

Now the weird thing is when I playback the Track the drum hits get triggered starting at bar 58 exactly like the SLoop MIDI Part was still located there instead of its current location. In the animation I’ve also Muted the MIDI Part so the only thing happening is the unwanted stealth Notes playing. The SLoop MIDI Part plays as expected if moved elsewhere on the timeline. A MIDI Monitor doesn’t show any Note on/off messages when this occurs.

Sampler Track notes misaligned


This just got much stranger.

I duplicated the Sampler Track and Muted the original version. Even while Muted the Track is playing back the stealth Notes. On the plus the duplicated Track seems normal.


I cant tell, is it possible that you have a chord track set to play monitored tracks?

I’m going throw a silly one in here.
Have you tried to use the eraser tool in the original location where you dropped the files?

1 Like

That’s not it, although that was one of my first suspects too.

That’s clever, wish I’d tried it.

After making the duplicate Sampler Track it seemed to be behaving normally, so I eventually just Disabled the problem Track, but not until it got a bit stranger. My ‘theory’ was that some internal buffer hadn’t been cleared when it should have been. So I shutdown Cubase and then reopened the Project. This actually did get rid of the stealth Notes. But now none of the unmuted MIDI Parts on the Track would play although if opened in the Key Editor & I clicked on the Notes on the keyboard they played fine. That’s when the Track got Disabled.

1 Like

Yeh , there was a method in my madness, Midi has had a few strange behaviours that i couldn’t explain over the years and couple of them were cured by simply using the eraser tool in the empty spot where the files were before, which does make your suggestion more probable about some sort of buffer handling.
Glad it sorted itself thou :+1: