(not a Dorico issue) Any experience of all audio devices often disappearing when using MacOS?

I had experienced this problem less frequently with other MacOS, but with MacOS 12.6.9 and 12.7.1, this problem occurs too often and it is hard to work.

It happens frequently and erratically, but waking the laptop from sleep when the lid is opened again seems to be related to this problem.

This is related to the following thread:

An employee at Apple Korea said that this problem hadn’t been reported yet, and that they wouldn’t check the system log files unless I reinstalled MacOS after deleting all the data to reduce Apple’s workload.
I specifically asked him to have the engineers check the system log files, and he will look into it and get back to me tomorrow.

(Please contact Apple and report the problem directly to Apple if you have experienced a similar problem.)

Has anyone experienced this problem?

Well, that sounds like nonsense. The Operating System itself is a read-only disk image on a secure, signed volume. If it has been altered in any way, it won’t boot.
There’s almost never a need to reinstall it. At best, it’s a complex way of deleting some cache files.

If you delete all the user data, then there’s no log files at all. Or anything else. So, I agree, there will be nothing for Apple staff to do. :rofl:

Is there any reason you’re still on macOS 12? I have an M1 Pro MBP, and not had any problems, but I have been following the system updates promptly.

It’s possible that there’s a bug in those versions of the OS; there have been some reports of “no sound on Monterey”: though of course someone, somewhere is always having a problem with something.

One post I have seen suggests delete the audio preference files in the user Library/Preferences folder. com.apple.audio.DeviceSettings.plist com.apple.audio.SystemSettings.plist

Then restart.

Your other thread shows a lot of audio outputs, and any one of them could be a contributing factor, if not the cause. You may need to test whether the problem occurs without any one of them. Remove them all, then test the problem. Then add one back at a time, testing as you go.

2 Likes

Thank you for your kind reply.
I will try the solutions you suggested.

The reason I do not use Ventura is that my audio interfaces are old:

  • UltraLite-mk3 Hybrid
  • RME FireFace 800
    Now I checked that these two interfaces are compatible with Ventura.
    I will update my the OS if this problem persists. Thanks again!

I’d recommend updating to Ventura regardless. (It’s actually now a bit difficult to find the OS installer for previous OS versions, but they are there somewhere! )

1 Like

There are also others that report similar problems, for example in this thread or in this thread. Unfortunately for both of them we still don’t have a solution, yet, though I’m still in private conversation with user Eetu. Progress is really slow and I don’t know if in the end we will be able to solve the issue, although I still have hope.

1 Like

I’ve had a similar problem with the same OS versions. My Steinberg UR824 was no longer recognized by the Mac. Its software console could see it, and it worked in USB-compliant mode, but couldn’t be used by the OS with its driver.

I can’t know if this also happens with other devices, since my other audio interface (from Universal Audio) doesn’t require a driver, and is simply USB-compliant.

MacOS 12.6.9 lasted just ten days, before being supplanted by 12.7 and making my audio interface appear again. So, I suspected my audio driver issue was due to some bugs in the OS. But then the audio interface disappeared again when upgrading to MacOS 12.7.1, and the Yamaha driver of the UR824 to v3.1.6.

Downgrading the Yamaha audio driver to v3.1.4 made the audio interface appear again. So, I wonder if it is the driver, or a combination of the OS and the driver. I wonder if @Ulf can be interested in this issue. I describe my tribulations here:

Audio interface no longer recognized

@benwiggy asks why the OP doesn’t upgrade to a system after Monterey. I can offer my example: my Mac is no longer supported, at least officially. It’s not an obsolete system: a 12-core 2013 Mac Pro is still a powerful machine, with a full orchestra rendering not taking more than one third of the available CPU time.

And it is compatible with a lot of things with no need of adapters. Plus, running other OSs (older MacOSs, Windows 10) is only possible with an Intel Mac. I’m personally still forced to use these systems, and a new Mac would mean also keeping an older one to run those things.

Monterey will be supported for another year. After that date, security concerns (assuming a third-party antivirus is not considered a viable solution) will become an important consideration, and either one will upgrade to non-supported OSs via OpenCore, or buy a new Mac.

Paolo

2 Likes

I have just installed the Yamaha Steinberg USB Driver v3.1.6 on macOS Monterey 12.7.4 on Mac Pro 5,1 (mid 2010). I followed the instructions to the letter, and then connected the USB cable to my Yamaha CP88 piano and the computer. When this did not work, I performed a reboot of the Mac Pro. Still nothing. The macOS does not see the CP88 as a source. It is not seen in the Sound Preferences Panel, and is not seen in any other application.
I have found another user who solved this problem by disabling SIP. I have already done this, which is already standard this computer. This is necessary to run OpenCore Legacy Patcher.
If you can help, it would be much apprecited.
For those in the know, here is the technical setup of my Mac Pro:
Computer: Mac Pro 5,1 (Mid 2010);
Processors: 2 x 3.46 GHz 6-Core Intel Xeon 5690;
Memory: 96 GB 1333 MHz DDR3 (2 x 3 cards);
Monitor: Dell G3223Q Gamers Monitor 4K 32 inch, 144Hz, AMD Free Sync Premium Pro;
Optical Drive bay 1: Standard CD/DVD player;
Optical Drive bay 2: Blu-ray player;
SATA bay 1: SSD 255 MB SSD, OpenCore in EFI partition (OCLP v.1.4.3) and macOS Big Sur v.11.7.10 (Golden Gate);
SATA bay 2: SSD 2 TB SSD, Time Machine;
SATA bay 3: SSD 4 TB HDD, Western Digital, Archive;
SATA bay 4: Empty;
PCIe slot 1: AMD Radeon RX 6800 16 GB (Flashed: Syncretic fix, injected GOP), Pixlas modification power supply;
PCIe slot 2: Lycom card NVMe SSD Boot 1: 1 TB Samsung 970 EVO Plus with heatsink, macOS Monterey, v. 12.7.4 (Star);
PCIe slot 2: Lycom card NVMe SSD Boot 2: 1 TB Samsung 970 EVO Plus with heatsink, Windows 11 Pro (License Key registered);
PCIe slot 3: Empty, with open mesh cover for ventilation;
PCIe slot 4: Yeeliya USB 3.2 Gen 2/3.1 2 x type-C and 3 x type-A;
Additional fan fitted to front; Noctua Chromax NF-S12A PWM;
Fitted to MB: Broadcom BCM94360CD 802.11ac WiFi & Bluetooth combination card: Chipset BCM4360 1.0, with external BT antenna;
Ethernet in: Internet cable to KPN glassfibre modem, one hop to Internet backbone Amsterdam;
Digital Optical out: Optical cable to NAD C388 150 Watt RMS amplifier to Jamo S628 Floor-standing speakers with Jamo C912 subwoofer;
Rear MB USB Type-A socket 1: RAZER Death Adder Essential gamer’s mouse;
Rear MB USB Type-A socket 2: Schiit MODI DAC, to Schiit MAGNI preamplifier, to reference headphone Senheiser HD650 / 2 x Tannoy Gold 7 reference speakers;
Rear MB USB Type-A socket 3: Brother Printer MFC 7460 DN;
USB Type A socket 1: 6 TB WD external HDD, Backup of the Archive files, and CD music copied from physical media;
USB Type A socket 2: to USB Type-A on Yamaha CP88 Stage Piano.
USB Type A socket 3: Empty;
USB Type C socket 4: to lightening connector, Black Magic Keyboard / iPhone;
USB Type C socket 5: to USB Type-C, Audient iD 4 MKII, audio input, to RODE N-1 large diaphragm condenser microphone.

You won’t see a MIDI input in the Sound Preference panel. That’s for audio input and output only.

You should see MIDI devices in Audio MIDI Setup.app. (MIDI Studio window).

MacOS should recognise most USB-MIDI devices without the need for drivers, so uninstall the drivers and see if that is any different.

Apps like Dorico, Logic, and others will often have a settings dialog where you need to enable MIDI input from the available devices; so make sure that the app is configured to receive input from your keyboard.

Also: try another USB cable!

Hello Benwiggy,
Thanks for the suggestion. I do not want to use the MIDI. I want to use direct digital audio to Audacity or Garage Band. Nevertheless, my son who uses MIDI on his Mac Pro 5,1 (somewhat different setup) with a Roland keybaord tried this, and made no progress. Apparently, the MIDI is also not seen on this Mac Pro. We encountered another problem: The CP88 would not switch off while the USB cable was connected. An attempt to switch off the CP88 caused the Yamaha speakers to generate a very loud thumping plop, and the system refused to turn off.
The USB cable was an expensive long cable purchased for this purpose. I do not have another, and don’t intend to spend another €60 for a second one, as I am pretty sure this is not the problem.

So why are you posting this on the Dorico forum if you don’t want to use this to enter information into Dorico?

Perhaps I have misunderstood.

I’m not convinced that you can send the audio output of your keyboard into a computer directly via USB.

I may be wrong. You should check the manual. You’ll also get more help on a dedicated Yamaha keyboard forum, or by contacting Yamaha support.

The heading states: “(not a Dorico issue) Any experience of all audio devices often disappearing when using MacOS?” So, you see, it is about macOS and not Dorico.

I think the question is now clear, but the answer is as Ben said above. Audio devices are relevant to Dorico only for sounding the output which has already been converted to analog by the computer. Dorico doesn’t take audio inputs.