NotePerformer fp

Dear all,

I’m working with NotePerformer and would like to know what the easiest way to achieve a fortepiano playback without messing up the appearance of the score would be.

Greetings from the Swiss Quarantine… :slight_smile:

Enter a forte. Turn on note input. Navigate to the next rhythmic location (8th note maybe). Input a piano. Then hide it in the properties panel.

You mean hide the f and the p and the write a fp?

I’m struggling with a long pedal note (bassoon) that goes through various bars. When I write f and then shortly afterwards p playback sounds piano for the whole note.

Provided you’re using Dorico 3.1 or later, it should be sufficient to enter “fp” into the Shift+D popover. You can see how Dorico will render that dynamic by opening the dynamics lane in Play mode for that instrument. You can boost the forte part of the combined dynamic if need be by editing the points in the lane. Check this video.

Thank you! That looks very promising. I think I don’t have Dorico 3.1 because I don’t see the dynamics lane in play mode. (Only “note velocity”, “automation” and “playing techniques”) How do I check which version I have and how do I upgrade?

Help > About Dorico tells you the version.
Help > Check for Updates takes you to a list of downloads.

Thank you! I now installed the latest version and the dynamics lane has appeared! Wonderful tool! Thank you so much! (fp is also played back automatically. Great!)

Until now I always had to add a hidden “nat.” before the “arco” because otherwise the strings would continue pizzicato do I still need to this with this version?

You should not in general need “nat.” between “pizz.” and “arco”, but if you are using other techniques as well, it might be necessary. I suggest you try removing the potentially redundant “nat.” markings to see what happens. If you need further advice, please post a specific, minimal example in the form of an attached Dorico project and we will be happy to advise you further.

Make sure you have the latest update for NotePerformer (version 3.3.1) and your project is using the latest version of the NotePerformer expression map.

In Preferences / Play, there is an option to automatically update expression maps when you open a project.

I made sure that the “automatically update expression maps” for NotePerfomer as the standard playback template is checked in preferences / play.

I created a tiny demonstration file and have suddenly encountered an additional issue: When I click on the notes I can hear them but when I let them play I don’t hear anything at all…

However in the real document I tried to delete the hidden “nat.” but still the playback ignores the “arco” indication.

When I try to attach the .dorico file I get a notification saying “Invalid file extension: NotePerformer Dorico Pizzicato issue.dorico”.

I now put the document on my google drive. Hopefully you can open this ink:

https://drive.google.com/open?id=1hjM2uy65ruiRoSl-BxN9Kt_pRyHgkpTg

You can attach here if you zip the .dorico file.

Hi Felix, when I load your project it also does not play back. The reason is, there is no Expression Map chosen in the Endpoint Setup dialog. When you switch to Noteperformer Expression Map, then it does sound during playback.
To invoke the Endpoint Setup dialog, go to Play Mode and left to the Noteperformer instrument is a little button with a cog wheel. Just click on that. Alternatively, you could choose from the menu Play > Playback Template and apply the Noteperformer template again, that has the same effect.

Thank you Peter, next time I will try to zip the file.

Thank you so much for your help, Ulf!

Should I see “NotePerformer Expression Map” in the list of expression maps in the Endpoint Setup? It only suggests many HSO instruments… I tried both your suggestions. It still won’t play back…

The strange thing for me is that this aspect works just fine in other projects. Originally I was only struggling with the pizz. to arco issue… Is there a link between these problems?

If your instrument/sound and Expression Map are not compatible, it can cause difficulties with dynamics, articulations,playback techniques, and a bunch of other things.

I don’t think that there’s a compatability problem because NotePerformer is meant to work with Dorico or am I wrong?

But more importantly it works well in other projects. (Appart from the original pizz. arco issue.) Here’s a document that works just fine: (You will find fp that playback automatically and that I could fumble around with thanks to the update you guys told me about. :slight_smile: Around bar 75 you will see a very clear example of the “nat.” that I have to use.) This is mainly so you can see that in one project it works and in another one it doesn’t…

Hmmm I tried to attach the zip folder but I cannot see it here… One problem leads to the other… How do I attach it properly?

If NotePerformer is installed properly you should see it, as in the first screen shot.

The easy way to set everything up for NotePerformer is go to Play / Playback Template and select NotePerformer from the list.
Endpoint setup.png
Apply Playback Template.png

Anyways here’s a google drive link: https://drive.google.com/open?id=1zMlSjGg6PYAeaxi4qbqJkkVmnaEg0G7t

Thank you Rob. I did go to Play / Playback Template and selected NotePerformer several times.

Here you will find three pictures of my screen:

https://drive.google.com/open?id=1vQmeT3WGdcKSiueilZlGOldae_4jOG8z