Noteperformer setup with Iconica Sketch

Hey there,

I could use some guidance with getting Iconica sounds added to my Note performer set up within my new project. When I go to PLay, VST and Midi, click add instrument, I don’t see Halion SE or Iconica listed here. Am I in the wrong place to add the synths?


I wanted to add a bit more context to this project by showing where things stand and where I still need help. I did realize that I had to add the new sample libraries through (Add Playback Template). I wish the sounds would automatically load as they would with my DAW, but can understand why this option may be there for those with slower PC’s or just the need to have more control. Anyhoo, I have my original TAM-Tam part the was originally assigned to Noteperformers Percussion. I have now assigned it to Iconia Sketch Percussion Map. Do I have to change my single line stave to 5 lines to get this to work correctly? As of now, I just here a cymbal sound and can see that the mapping of the new Tam-Tam is triggered by E3. The only reason I’m messing around with these new sounds is in hopes to get the choked tam sound in my demo. No luck yet. Am I doing this the correct way?

Screenshot 2024-02-06 at 3.56.03 PM

For a start, you need to download the Noteperformer Playback Engine App for Iconica Sketch (it’s free).

You run the NPPE app and load your Iconica instruments there. Then, when you apply the NP Playback template in your Dorico project, NP will load Iconica sounds if it can (non-Iconica sounds will come from the normal NP sounds) and you are good to go.

1 Like

Process is all the same as using Noteperformer

You go
Play > VST and MIDI

Hit the ‘+’
In the drop down select “Wallander Instruments” > “Noteperformer”

[To use the Iconica Sketch libary with NP, you need to make sure you’ve got the “NotePerformer Playback Engines” application installed on your computer, along with the “Iconica Sketch” libary (which you install via “Steinberg Download Assistant” - It’s in the Dorico section).]

Then to use Iconica Sketch with NP in Dorico, you open the “Noteperformer Playback Engines” app as a separate program. You should see an icon for “Iconica Sketch”. Click it then click “Add Instruments” in the bottom right.
Then you add the instruments you want, and Noteperformer will now use those sounds for playback in Dorico.

Hope that helps!

There’s been a whole episode of Discover Dorico last month about Iconica sketch… Wouldn’t that be a good place to start?

“How to use Iconica Sketch in NotePerformer”. Discover Dorico. (John Barron).

1 Like

Here’s a direct link to the video:


Thanks for everyone’s help. Here’s where things stand.

Ok, so, I’ve opened and installed several instruments from Iconica Sketch into my nppbe. I’ve opened my project and can see that a couple of instruments have now replaced the default NP instruments. Like Xylo, Marimba. However, when i added the Tam-Tam, nothing changed in my score. I’m still getting a cymbal sound from the original NP instrument play back. Do I have to force this new path? I can’t seem to get this right and not sure if this particular aux percussion instrument might be a bug? I know the other instruments are working correctly because the faders are now surrounded by a white border.

See if adding a gong helps; there was an earlier post about this.

1 Like

Add Gong, not Tam-Tam?



Thanks for that. I think what messed me up was that I didn’t actually (initially) open the NPPE before opening Dorico. I have tons of large sample libraries, too bad I can’t just open Kontakt up within Dorico and load one of those.

Thanks for your help .

What is stopping you from doing that?

Meaning, is there a way to open Kontakt up within Dorico or going through the NPPE? For one, will there be a lag difference and has anyone successfully achieved this? I’m wishing there was a smoother way to modify the playback controls and have it only in one location. I feel (personally) there’s way too many areas to get hung up on with Dorico. Playback templates, Playback options, PLayback techniques, Stage and space templates, setup modes, track inspectors… In mean… How but just everything under PLayback options. Period!

Yes. Just load an instance of Kontakt in the VST Rack, load into it any instrument you want (I use it for Cremona String Quartet amongst others) and route a Dorico instrument to it. You can freely mix and match VSTs without timing issues.


You can perfectly open Kontakt as a VSTi in Play mode (left panel, pressing VST rack button and then the + button)
Some Spitfire libraries I own need this (Perussion Joby Burgess, solo strings…)
Edit: Ninja’d by Janus



Thank you for your response.

I did load Kontakt 7 and was able to load one of my Tam-Tam samples from my TRue Strike sample library. My stave is a single line. There are several samples that can be triggered on the keyboard. If I wanted a specific note to sound, like Db 2 (for instance) how would I achieve this? This is paramount considering the use of many percussion samples and colors I would like to add in my orchestrations. Is there simply a way to cycle up and down the single stave to locate the appropriate sound? I’m on a MAc btw. I have tried using the up and down arrow keys to no avail.

You would need to create a Percussion Map for that instrument. (There are numerous tutorials around on how to do this)

1 Like


Thank you for the link. I have seen this before and now remember why I had difficulty with it. What I’m needing to do is create a new percussion map for my True Strike sound used through Kontakt. Sounds easy enough, right?

I have added a new data file named : Tam-Tam True strike. Next? I’ve located my library to import, but no way to do so. Is this the wrong step or am I missing something?

I guess I’m wondering, why can’t I just add a midi note, or several all at once and assign them? For instance, here’s the HSO Tam. It has two midi notes. I would like to add several midi notes that correspond with each sample. Now, once I figure this out, how do I utilize these with a single stave percussion line?


Here’s my latest. I figured out how to import the Percussion Map, (or so I thought) for my Tam-Tam. Again, I’m running this through Kontakt,port 1 and using Truestrike Tam/gong sample. After everything was set up, no sound at all on playback. We can deal with getting the multiple samples being heard on the single stave after I can get the bloody note to trigger the sound sample. Here are some snapshots of the setup . Thank you for your help. I must be missing a step?