Noteperformer Timeout on Dorico 4.2 - Windows

On a fresh install of Windows 11 Dorico displays the following error message on startup the first time after NotePerformer has been installed:

Scanning
C:\Program Files\Common Files\VST2\NotePerformer64.dll
A timeout may have occurred. Check if the plug-in is displaying a message or click ‘Cancel’ to put the plug-in on the blacklist.

Following this no playback functions with the NotePerformer templates set.

Both Dorico and NotePerformer are installed to the C Drive.

Please start Dorico and choose from the menu Help > Create Diagnostics Report and post the corresponding zip file here. Thanks

Dorico Diagnostics.zip (382.8 KB)

Thanks for the data. Did you click that ‘Cancel’ button, because NotePerformer is blacklisted with you. And what version of NotePerformer do you have? I can’t see that from the logs.

I did click the cancel button after leaving it scanning for a few minutes. The version I have is Noteperformer 3.3.2.

Hm, that should normally work well.

Then, please do the following: Press the Windows key and then type cmd and press enter.
In the upcoming Command Prompt window copy and paste "C:\Program Files\Steinberg\Dorico4\VSTAudioEngine\Components\vst2xscanner.exe" -p "C:\Program Files\Common Files\VST2\NotePerformer64.dll"
Copying everything in bold, also the quotation marks. When you then press enter, what does it spit out?

I’ve had the above command running for about 5 minutes and so far it’s just hung without producing any output.

Hm, that’s strange. Can you please run that Command Prompt again, but instead run it as an administrator? To do that type again the Windows key, then cmd but don’t press the enter key. Under Best Match you’ll see ‘Command Prompt’. Do a right click on that and choose ‘Run as administrator’.
With that in place try again with that copy and paste. Thanks

Even as an administrator it’s seemed to just hang again.

In that case I would try reinstalling NotePerformer.

I was in contact via private message with AragornK and it turned out to be a graphics driver problem. The vst2xscanner would not work, because it was endlessly hanging while trying to unload the NotePerformer.dll.
So the FreeLibrary Win API function was hanging while making a call into the graphics driver atio6axx.dll from AMD and a change of that driver cleared everything. Here is what AragornK wrote me:
“For your information AMD has two main streams for their graphics drivers: Recommended, and Recommended + Optional. I was running the Recommended + Optional stream (version 22.8.2) and downgrading to just Recommended (version 22.5.1) was what resolved the VST scanner issue.”

Hi there, just bought D4 and NP3 today and getting the timeout error. Did the downgrade on the driver resolve the issue with NP3? Currently using AMD driver 22.9.1 and don’t really want to downgrade.

Well, for user Aragon it did solve the problem. You can also try it out. You can still go back to the other driver if it doesn’t work out.

Thanks that has worked, but now unable to use some other software on my PC. I presume as it’s a vst2scanner issue then it’s AMD that need to fix?

Yes, AMD needs to fix it. It is not only with the vstscanner, the same hanging will happen in Dorico’s audio engine as well, it is just that you never get to that point. So it is a good idea to report the problem to AMD in order to make them aware and fix the issue.