Notes being played back exaggeratedly short in Note Performer

In the attached Dorico file, the 4 sax pickup notes are played back exaggeratedly short (as are any other sax lines that lack specific articulation marks). Others had previously suggested that perhaps it was due to a holdover of a previous playing technique, so to be safe (in the attached Dorico file) I’ve inserted a “nat.” playing technique (as others have suggested) at the beginning of the phrase. I’ve also made sure that in Play–>Playback Options–>Timing the note lengths are set as recommended by Arne on his website (though I’ve also tried setting the note durations % for “default notes” to as much as 105% instead of the 85% recommended, and it has no effect on the sound - it’s still extremely staccato). I’ve also selected all and chosen “reset playback overrides” in case it had something to do with errant musicXML data on import, etc. but to no avail.

The one thing that “basically” works is for me to insert a “legato” playing technique at the start of the first appearance of any note that lacks it’s own articulation marking (and then hiding it). But I’m wondering if this is more the equivalent of a “100%” playback vs. Arne’s recommended 85% (so isn’t entirely accurate interpretation-wise), and also why this should be necessary? Thanks for any thoughts:
Note Performer Test.zip (574 KB)
Best -

  • D.D.

I’m not sure why, but I don’t get a Dorico file when I download this, but instead a folder containing 2 more folders and a couple of .dtn files.

Stephen, D.D. hasn’t actually zipped the item, he’s just replaced “.dorico” with “.zip”. Replace “zip” with “dorico” and you should have a working file.

Side-note: I’ve never understood the logic behind people doing this.
A. It causes confusion
B. It’s just as quick on both my Windows machine and my Mac machine to actually compress the file into a zip archive.

Or just type “.zip” after the “.dorico” extension.

Thanks Leo! Got it working. With tenuto markings, the 8th notes sound full value; but as written, yes, they are pretty short.

You mean “.dorico” after the “.zip” extension :sunglasses:

No, not really. :neutral_face:

I mean, you type “.zip” after “.dorico” to send it.
The recipient can then strip off the “.zip” to open it.

Either I’m being exceptionally dense or I’m having a sarcasm failure. I’m going for the latter.
[end O/T - sorry about that!]

edit: entirely misunderstood Derrek’s point. Now he’s revised it I understand.

Is it not permitted to upload .dorico files on this forum? Maybe that forum policy could be re-evaluated.

I also have problems with staccato notes which are not written as such. Note length settings seems to make no difference.

From discussions I’ve had with Arne, my understanding is NP times the delay between note on and note off VST messages (which just encapsulate MIDI messages). It uses this to try to figure out whether the host is trying to play short or long notes. This is why Arne recommends using standard config for note length. In Sib the soundset file makes much of this explicit (e.g. the articulations like staccato, tenuto etc are translated to CCs), but I don’t know if the NP dorico expression maps are as comprehensive as the NP Sib soundset file (which is vast and has thousands of entries).

Finally it needs the 1s delay to know what is coming AFTER the note it’s playing - e.g. if there’s a gap it needs to switch in a release sample etc etc.

I dream of a day when we can do rendering based on the fact that with programmed notation (as opposed to live MIDI keyboard playing) you always know what’s coming next (it’s on the score). If we unshackled ourselves from some of the compromises that come from supporting live keyboard use, we could get next level rendering. It would require a different way of thinking about the interface between a host and the rendering plugins.

Thanks. I’m wondering if - at the least - there might be a playback technique I can invoke (besides “legato”) that gets closer to actually playing back using his recommended note length of 85%? Using “legato” as a workaround eliminates the exaggeratedly short note playback problem but can feel too smooth for passages without any other articulation marks (at least in a jazz context), plus it doesn’t seem to always “stick” the next time Note Performer is called upon to play back notes that LACK any articulations after playing back notes WITH articulations (on the same staff). Of course, I’m hoping there will be a way to avoid having to insert anything for instruments that lack specific articulations and still not have them play back exaggeratedly short (down the line)…
Best!
D.D.

Yeah personally I think the whole percentage thing is the wrong way of looking at the problem.

I guess it’s a hangover from Sibelius days. But I’ve had cases where with a 95% duration set, an entire beat or even more was dropped from a note that was several tied whole notes.

When we play in an orchestra, we don’t get out calculators to calculate proportions of note lengths. If anything, with strings we play the entire note length, less the amount of time it takes to change bow direction. This is pretty much a constant time (and can be pretty short), independent of note length. I would be very interested if some software one day instead of choosing a percentage (or percentage of an equivalent 1/4 note at 120 BPM - how do you work with that?) would allow you to set things like

  • time to allow for bow change in detache
  • time to allow for bow change in legato
  • time to allow for breaths

For some types of music (e.g. classical, by which I mean classical period) it’s common to shorten notes which aren’t marked as shortened. In practice however this tends to end up being a more-or-less constant amount of time deducted from the end of each note. Detache bowing after all is the default unless something else is marked.

I don’t think any playback engine really keeps track of bow changes, but these can be associated with a slight accent, or can be quite smooth.

Staccato is commonly mimiced as 50% written note length, but again this is unrepresentative in many cases. A staccato note in strings is typically the same length no matter what the written note duration is. Sure you don’t often see long notes marked staccato at slow tempi, because well a whole note staccato at 60bpm sounds the same as a 1/4 note at 60bpm followed by 3 1/4 note rests. It’s more like pizz, where you stop putting energy into the string after the initial impulse (with staccato you play the start of the note and lift the bow off, at which point duration can only be affected by damping).

NotePerformer reverse-engineers the 85% shortening. So this setting will yield the appropriate results. For classical music, that is. So NotePerformer actually lengthen the notes to 100%, internally.

If you want to further increase the length of notes to taste, I would recommend doing so from Play mode, on a note-by-note basis.

And possibly send a value of 1 to CC 108 to trigger the permanent tenuto mode.

Thanks Arne. In my case the sound is quite different between Dorico and Sibelius for the same passage, so I presumed it was Dorico, but I guess NP could be behaving differently depending on the host program?

Will the CC work to get steady tremolos also? (Like, think repeated 3 slash whole note string tremolos, as of now they obviously "drop out’ at the end of each bar)

Edit: Tried it - answer: Sort of. It does get a continuous tremolo effect (good!) but now the notes themselves are bit a bit too blurred together for my liking. Still overall an improvement though.

The way I do it is to select the notes in the score, and from the properties panel, set the “End playback offset” to something like 50.

There are 480 units in a quarter note.

Is this to stop clipping notes? Do you need to edit each note for this, or is there a way to do it globally?

Yes. You can select all—Notes in a section and set the values in one shot.

It’s supposed to be identical between programs. Can you possibly attach the .dorico file to support at wallanderinstruments dot com, for me to troubleshoot?

Editing the length works. The actual tremolo speed may be adjusted in Playback Options in Dorico.

NotePerformer unfortunately can’t automatically resolve the fact that slashed noted are shortened to 85% as well. But NotePerformer only sees the individual notes that constitute the tremolo (which are not shortened, I believe) and adjusts those instead.

Shortening the individual notes in the tremolo, rather than the duration of the tremolo, is how I imagine Dorico’s shortening algorithm is supposed to work eventually. This would harmonize playback of a slashed note and explicitly written short notes.

It would be really handy if this were a playback setting, at least for default value.