Novation 61SL MkIII not picked up by MIDI-Remote, even though supported

I have the Novation 61SL MkIII, it has always worked and is working fine in Cubase 12, but the new MIDI Remote Manager will just not see it, even though the exact model is listed as supported, and I see the script there. Anyone have any idea why it wouldn’t detect it? Please refocus me if there’s a better place to ask this, new here. Thanks everyone.

5 Likes

Hi Joe congrats on your first post! Good to see you here :smiley: is it listed in your midi port setup?

Sure is, on a bunch of different ports. I’ve tried disabling some of them, enabling them all, enabling only the input I’m needing, and I’ve tried enabling the "User Device ‘WinRT Midi’ for a bit too. Updated controller drivers from the manufacturer to see if that helped, AND the old reboot a number of times. :slight_smile: Both the Port System Name and Show As both have it listed as “Novation SL MkIII”. Thanks for the assistance, and the kind welcome! :grin:

1 Like

There’s no MIDI Remote scripts for SL MkIII series yet, only the LaunchKey Mk3 series.

1 Like

The following MIDI controllers are currently supported thanks to a dedicated script.

AKAI - MPKmini mkIII

ARTURIA - KeyLab Essential series

ARTURIA - MiniLab mkII

KORG - nanoKONTROL v1, v2

Novation - Launchkey Mini mk3

Novation - Launchkey mk3

Hi @joe_hanish, currently we do not provide a factory script for the SL MkIII keyboard. But that one has a very high priority on our list. We will provide more and more factory scripts over time. We’re just getting started. For the time being please stick with the Surface Editor. And please make sure the use the “In Control” ports, or the MIDIIN2 MIDIOUT2 (on windows) and switch to “In Control” mode on the hardware.

6 Likes

Super,
Faites vite s’il vous plait !!!
J’attends aussi la prise en charge de ce clavier :wink:
Merci !!

Je vais le faire aussi vite que possible. Mais j’ai encore d’autres problèmes à résoudre. (google translator)

1 Like

Morning

  1. I have the same problem with Novation 61 SL MK III
  2. Audio output needs to setup again when sart Cubase 12

Looking forward to see it, cheers

Im also trying to get my sl mk3 mapped. It is set to incontrol and i can get alot of the buttons working but im struggling with the rotary knobs ? They just switch around back and forth when i move them seems to be some problem with the mode . I tried absolute, relative and all options we have there basically but i cant get it to work

man i have the same problem everything else as advertised but the knobs i cant get it right to save my life :exploding_head: :exploding_head: :exploding_head:

1 Like

Hi! I’m also hoping for a factory script for the SL MkIII keyboard. I use Nuendo 12 but am adding my request here. It has a similar layout to the Launchkey so I imagine modifying the script to fit the SL MkIII may not be too difficult.
Thank you in advance for creating this for us!

4 Likes

Not a Cubendo user, but kicking the tyres from afar. Did you ever get this sorted? The idea of being able to use something like a Novation SL MK III with MIDI Remote designated ‘AI knobs’ ala the discontinued CC121 sounds appealing on paper.

3 Likes

Bonjour @bruno_devillers, welcome to the forum! Please switch to English, that way more users can benefit from your contribution. Thanks!

Good morning Jochen
I could understand the forum chart ask to write in English language but why to hide messages when Google can translate it?
Thanks

ce n’était pas moi :thinking:

By the way
I tried several times to do a script for the SL MK III but without success
At the end many controls are missing or not working properly.
I would have expected in one of the updates found, finally, the script for my control keyboard
SL MKIII :disappointed_relieved:

1 Like

hello ,
do we have any news for the 61slmkIII script?
An update of Cubase and made since can, but just the problems on the existing scripts have been made.
Thank you for your reply

Not yet. But is on our list (which is quite long).

1 Like