Now, my patience runs thin. ASIO realtime CPU peaks, dropouts

Ive been going back and forth with Steinberg/Yamaha support for over 2 months now, and it appears this is a dead end with not even a possible solution date or any helpful information at all. Not sure why 10/10.5 is available for purchase if this issue is known and unresolved.

Support advised me to come post in this area because “developers and staff watch it”, so here we go again.

The ASIO dropouts continue, and Ive rebuilt this system TWICE and gone through categorical, item by item analysis until I can rule out ANY other factors other than internal cubase/ASIO performance.

Ive stripped EVERYTHING from this PC, disabled defender and placed exceptions, and removed anything non windows-default software, and tested all audio and MIDI devices exhaustively for signal issues or processing issues. This system is as clean as any you might find. I even bought a newer gen3 focusrite 8i6 to test and improve fidelity, and it changes nothing about the ASIO issue.

–Blank project, 1 instrument, random audio dropouts. Sometimes hours of no dropouts. Yay, it’s solved! SURPRISE, , no it isnt. Nothing in the background. NOTHING. External CPU monitors show 10-25% usage.

–Filled project, 10 tracks with many instruments and FX, same likelyhood of dropouts. No more, no less.

–Other DAWs? NI Maschine2 direct? Every single independent instrument by itself, OUTSIDE the cubase VST environment gives me zero trouble. I can produce inside Maschine2 for days without even hitting 50% CPU using any ASIO or audio interface.

–INSIDE Cubase, any ASIO Guard setting, any CPU priority, any audio config or buffer level Ive tried, results in the same.

And if some… person comes in again here to ask me if I’ve checked my buffer settings, I may react quite badly. Anyone have any… additional details on the ASIO realtime spike issue?

I might add – anyone have any info on the PLATFORM INDEPENDENT ASIO / internal processing / potential mulitmedia multithreading issue?

Have you tried Nvidia Control settings

Power Management set to max

Thread optimisation set to OFF

Hippo

Thank you for trying.

Altering those settings has zero effect. It also has the secondary consequence of limiting multithreading performance via CPU/GPU in graphics applications, windows UI, etc.

This is the context of the issue:
https://helpcenter.steinberg.de/hc/en-us/articles/206103564-Details-on-ASIO-Guard-in-Cubase-and-Nuendo

Although these articles closely cover the issue, they do not precisely cover it, as all the articles to do with ASIO guard and multithreading performance are from OLDER versions of cubase.

There is only one article that addresses Cubase 10 ASIO performance on Windows10, and the article contradicts itself by saying “this is only for versions of CUBASE BEFORE 10”, and then later says “cubase 10 is adapting the number of real-time threads”. Here is that article:

https://helpcenter.steinberg.de/hc/en-us/articles/115000535804-Windows-10-audio-dropouts-on-multi-core-CPU-setups

This is very troubling.

No trouble running latency monitor for 20 minutes or so?

I built a powerful PC for Pro Tools in 2018(a bit like yours), and it would only work properly with Pro Tools if I disabled Turbo Boost, C-State Transition (BIOS) and hyperthreading.

After that(and a NVIDIA driver downgrade) the system worked properly. Oh, and there was trouble with the extra Black Magic videocard. Only one driver version worked.

PC’s can go terribly wrong, and if you don’t buy from a reputable dealer you are left to your own devices.

Good luck
You know more than any one here it seems, even those who have a well optimised running system
Work for days here, never a cubase glitch
I must be doing something wrong

In some weird cases, disabling ethernet(Realtek PCIe GBE Family Controller) when running Cubase removed all the issues, at least for my few friends. It´s easy to enable it back, if you need internet on your DAW. Might be worth to try

Not really a good way to start the topic, IMO. You want them to stop selling Cubase because you, and probably a few others, are having problems when a vast majority of users have no or very rare dropouts?

Can you really say this? Have you tried different motherboards, hard drives, LAN cards, graphics cards, USB controller cards, etc.? I would almost have to say that it is MOST likely some process or device in the system that is occasionally requesting too much attention. Of course, I can’t say for sure…

What was the previous audio device? Was is also Focusrite? Have you tried another brand of audio interface? Have you tried a generic ASIO driver such as ASIO4ALL or the Steinberg Generic driver? It might help isolate the problem to a driver issue.
There was a Windows 10 update about a year or two ago after which a lot of people were getting random dropouts, even when just listening to Media Player or watching videos on YouTube, etc. I have a UR44 and there were a couple of updates to the driver which eventually fixed the problem. Now, I can’t remember the last dropout I had, in Cubase or otherwise. I don’t use really big projects and I usually run 5 - 10 mSec overall latency with no problems.

Anyway, I get that your frustrated and I hope you get it sorted out.

Bios cpu settings is usually the source, could be a problematic mainboard issue, chipset, voltage probably, usb drivers can be a nightmare as well.
Has nothing to do with cubase itself, install 9.5 and see if it does the same, it probably does.

I know it’s frustrating when most people don’t have the problem you’re experiencing. That doesn’t make it any less of a problem for you. But, you have to recognize that means it’s not a systemic problem in Cubase. It’s likely a rare combination of circumstances. Steinberg has many smart people working on Cubase. They write good software that performs well for the vast majority of their customers.

If you go for hours without a problem, then get a dropout, there is a key piece of information you didn’t mention: does your Cubase performance meter show a red overload indicator? That would help pinpoint whether the problem is a processing block underrun, as opposed to a flaw in the audio transmission to your output.

30 year net/sysadmin and custom builder here. I am the OEM, friend. =P

I build render farms, Ive supported pro audio and production environments, and even live stage shows by major networks at pro S&E venues, where I was responsible for the network and streaming buffer handoff for shows such as Not So Silent Night in Norcal. Ive used cubase on and off since 2001, and many other VST, tools, etc.

The ONLY thing I have not done to this system to troubleshoot this is to totally disable HT in my BIOS. I have not done this for 2 reasons: 1) that will handicap many other things, and once again… lead to a single purpose PC. No. Not going to do that now. 2) if I disable the 6 virtual cores, iLok and eLicense will probably freak out, among other things. Further, I am not entirely confident this will work, as evidenced by other users’ comments around these forums.

I promise you I will try ANYTHING you suggest that I have not tried if you bring it up. Turbo boost is off. This system is defaulted now, without even the basic intel XTU tuner app to boost it from 3.5 to 4.1ghz. (the simple factory OC they allow, which just bumps mutipliers and does auto-voltages)

I rebuilt this PC again yesterday with a new (1909) image from microsoft. Even bluetooth is disabled, lol.

Disabling Realtek ethernet, leaving me without a network interface?

I… I really cant do that right now, as you might expect. If this is a troubleshooting step that has an actual impact on the issue, then I expect that steinberg or somebody will create a patch that can work around this.

Cubase is not for you it seems, then use something else.
This is a Cubase user forum not support
What is the cubase feature you need that you can not find elsewhere?

I recommend NOT trying to tone police my anger. Ill start threads however I please, based on my current state of anger, thanks. Why is this being sold if this bug exists? Answer: to continue an essential revenue stream under an economic system that forces it. I get it, friend. MANY people have these dropouts, and you would see the threads… and threads… to do with them if you checked. Shall I catalog them all for you, to show you how very NOT alone I am in this issue?

Ahhh, yes. The impossible, unreasonable scenario: “but have you tried a new computer! How about you build a whole QA bench, document your repro attempts, and see if you can push a fix to github…” wait, I thought I was a user and not a QA engineer? lol

You seriously claim I cannot claim it is an internal cubase/ASIO issue, despite ALL of the documentation that suggests it is, despite what support has told me directly, and what many, many others have experienced. Ok. Maybe I add you to that, what is it, “foes” list soon because you are NOT helping.

No. I have not lmao swapped motherboards, and I am not going to because that is irrational and beyond the scope of what is reasonable for non-compensated CUSTOMER to do.

Previous audio device? Fosurite. Currently, I have a maschine mk3, and a focusrite gen3 8i6, as I said I did, and there is no difference between any of them, nor between full system rebuilds. Hope this helps. Where on the net do you see info that claims the ASIO internal processing issues on, lol, the audio interface? I hadnt see that one yet.

That windows update? Oh yes, I know all about it, as it began the post-production issues that took away my ability to play back 4k HDR BluRays on my internal UHD R/W drive. I understand some multimedia multithreading changes… may have occurred back then that affected cubase, yes. I wouldnt know, as I was using cubase 5 at the time, which did not experience any issues. I thought I would upgrade to 10, lol, and when I searched the forums I did not immediately see all the people complaining about ASIO spikes.

Oh, Im frustrated, yes. I waited a DECADE to buy this license, and did so while my family and I were trapped in our house for a couple months. Its been a fun… couple months.

You arent helpful. Go away. Only comments that take seriously the issue, please.

Sounds like stepping in to customer service issues FOR vendors you like is a poor choice, for you. I like cubase, too, and have… evangelized it for 20 years, lol. The words I have for you would probably get me censored on this page.

Joined: 17 Apr 2020 04:02

Stock x299 Taichi from ASRock. Intel i7 7800x CPU, stock. Can you show me your suggestion for what voltages or settings you feel might be misconfigured in my BIOS? Do they come stock, misconfigured do you think?

Ah, nice. You believe my account register date on these forums is somehow, lmao, discrediting of my issue? Explain yourself, before I block you or whatever this will do.

Didnt see this comment.

–Many people DO have the issue. You can find their posts here, and there are a few with many, many pages.

I have used cubase for 20 years, was trained in it by a sound engineer friend from germany I met online, and I have been explaining to others… for a long time, about how sensitive the audio signal path really can be on windows or on any PC platform. I help others understand how to get the most out of their hobby and professional computing environments, and I understand.

I get it very well, and have passed on my cubase knowledge to 3 people so far, only I expected to be able to manage any issues from cubase that I might encounter, and therein was my mistake.

Ive already mentioned the “red” overload indicator in other posts to do with this, and others have, too.
Yes. The meter inside cubase hits red, meanwhile any external meter shows CPU never going beyond 25ish%. The INTERNAL ASIO processing is what peaks, and causes the dropout, indicating my issue is related to the known issues regarding multithreading and multimedia threading introduced years ago.

Yes. I made an error – I did not know what questions to ask the internet when I decided to buy this license, and the issue was hidden from me. Now I see it, yes.

Hi milkman,

you say you’ll try anything, but you won’t try disabling hyperthreading or disabling your ethernet chip? Why not?

Steve.