Now, my patience runs thin. ASIO realtime CPU peaks, dropouts

Hello. Thanks for replying.

As my last comment about that reads, I will try anything, yes. However if disabling virtual cores is what works, do you think that might be an issue for the long term? From your own perspective?

Let me rephrase – if disabling all virtual cores works to solve this ASIO issue inside cubase, the love I have… for my damn production environment, my love and passion for music, and my nature as a tireless systems administrator will lead me to disabling those cores for sessions, and re-enabling them when done. Yes. This is not a long term workaround, however.

One thing that would help is if steinberg CONFIRMS this, and RECOMMENDS this, instead of the OPPOSITE, which can be found here>

“Enabling SMT/“Hyperthreading” while ASIO Guard is active usually has a positive effect on the overall system performance and is the recommended combination. Only in rare cases - e.g. with projects using many “live” tracks - SMT can still lead to performance issues. Again, please refer to the dedicated ASIO Guard article for details.”

Do you see my problem? I want OFFICIAL recommendations from steinberg that can AT LEAST allow me to work around this issue without major issues. I dont use “many live tracks”, and have been testing ONE TRACK and seeing issues sometimes.

And the hash iLok and eLicenser generate based on my hardware config? That will become invalid when CPU/core count changes. I would like to hear this from Steinberg. I am trying to get steinberg to do actual troubleshooting with me, via email, or here, or somewhere, but they so far have not.

And Im really not going to get into why “disabling my ethernet chip”, lol, is not a reasonable approach. I dont think I need to go further with that here?

Not trying to police you just thought you might get more help with a different attitude.
Of course, you can’t realistically change motherboards. My point was that is exactly why you can’t claim to have definitively narrowed it down to a Cubase code problem. Your logic is flawed, if it was a Cubase internal problem, wouldn’t everyone have these problems?
Ethernet cards are common culprits for interrupting the audio stream.
Add me to foes if you want but I won’t reply anymore.
I really do hope you figure it out. I mean that sincerely.

So you wont turn off HT because it will impact other things. No! turn it off. If the problem goes away you’ve just figured out your issue and saved all those hours. Now you come up with a new solution, no longer use Cubase, leave the other things impacted because Cubase is a priority or build a different PC.

Same goes for “disabling my ethernet chip”, the reason you do it is to find the source of your problem, not as the desired way of running a system. This is standard procedure in finding faults.

Why cant you disable network adapter from Windows to try out, why is internet needed in your creative process, it only takes seconds to disable and enable it back. At least you could carve out one of the possible issues

Thanks. Been doing this a looooong time, I have a house full of kids and stress and chaos, and this isnt helping me at all. Hope you understand.

There is COPIOUS evidence, including which can be found at the numerous links Ive posted above, confirming this issue in cubase and nuendo going back years and many versions, so please… that’s enough of this. Support confirms it vaguely, as well, and says, quote, “we are waiting for microsoft on this.” I was seeking more information here, as support indicated I should, despite that conversation. Do you understand?

But so many folks want to present me with very unlikely scenarios, lol, such as disabling a realtek network controller, or “merely” getting a new motherboard. To test real quick. No. Im tired of this, and I am angry at myself for not reading more about the current issues in cubase before buying.

You focus on this problematic and unacceptable workaround because of… what? Why would you favor such an unfriendly situation for use in a hardware and software environment like this, on behalf of an organization that should do better damage control on the issue ASAP? Are you a developer? Would you prefer this “solution”? I wouldnt.

You can place yourself in front of that bullet for them if you like, but Im fairly angry about this and I dont recommend it. Ill uninstall my NIC over my dead body, and perhaps over a dead-end to 20 years of working in cubase. Im starting to like this idea, some of you present me with. You win!

I don’t understand why you keep writing ‘lol’ when mentioning one of the troubleshooting suggestions to disable your ethernet controller. There is something deeply illogical going on here. You say Steinberg suggested you come to the forum to get other users’ advice and experiences, and yet your responses are dismissive and, to me, appear stubbornly set against finding ANY solution that might suggest there is an inherent problem with the hardware and software matrix you have chosen for your build. Respectfully, there seems little point in any further exchange of views here. I won’t ‘tone Police’ you (great phrase) but neither will I provide you with material to rage against because you need some relief from your stressful home environment.

Good luck and I hope you and your family remain safe and well.


Bios cpu settings, disable the c-states, power saving, cpu throttling disable those. I have had HT disabled since day one. On my rig with HT enabled the asio meter becomes unstable it acts erratically.
I test every rig with big-busy projects 200+ tracks and lotsof processing and always get more stability and general more plugins with HT disabled.
Stock is not optimal for cubase.

Im not sure what you can do with asrock bios.
On asus you have:
CPU Core Ratio. Do you have in Sync All Cores?
Do you have enabled Intel SpeedShift?

You probably havent had my years of experience, nor are you as sick and tired of folks trying to derail the nature of this problem on these forums as I am. ‘LOL’ is probably better, for you anyway, than the anger it replaces. Ill wait for steinberg to recommend disabling my NIC. They have already shared with me enough about the problem to have an idea of what Im facing here - as I have continued to mention - but go ahead. Keep ignoring that, and making whatever comments you please. Thanks for your input. Good luck to you and yours, yadda yadda.

ASrock (Phoenix BIOS) is fully configurable, and I dont plan to modify anything beyond stock until I hear from Steinberg/yamaha that this is even a relevant step. If Steinberg wants me to document categorical mainboard modifications on voltages, ratios, or states, this is something I will certainly wait for an engineer to work with me on, if necessary.

CPU core ratio is stock. No such thing as “sync all cores” in x299 chipset/phoenix BIOS on ASrock. And I dont use any UEFI stuff from inside my OS. ‘Speedshift’? No. This has “TurboBoost”, which is disabled from the start.

Are you suggesting you have info or any testing results of your own that suggest modifying default processor/cache/boost/transition configs can benefit the issue? I would love to pursue this, if so.
I plan to attempt to disable my… virtual cores later, once I do some other work first. I will do this as a test, but if this resolves the cubase issue and leaves my system handicapped, this cannot be a long term solution or workaround. Hopefully this makes sense.

Ok. Finished up my other work, and disabled all virtual cores/HT from the BIOS. SpeedStep is disabled. TurboBoost disabled. Everything is auto, stock, for intel x299/ASrock.

As this usually takes hours to prove, I will come back later. So far CPU looks, frankly, about 15% better than before. This is not a full result, though. I will be back after a few hours of heavy testing.

FYI iLok and eLicenser do NOT care about CPU core changes. Perhaps they are virtual-core vs physical-core aware. This was a relief.

Almost 2 hours in. Results:

Heavily loaded project. 2x Halion, 2x GrooveAgent, 3x Maschine2 connected VST instruments being triggered by maschine mk3. Secondary bus, rendering audio, etc etc. 1 FX group, inserted into 3 tracks, reverb.

Cubase internal meter shows average load of 20%, almost never even peaking to 50%. Not one dropout. Nothing is red. This is 30-40% LOWER average load than before I turned off HT.

Circling back around to what Ive been saying since the beginning:
If disabling all virtual cores (hyperthreading) resolves this issue on Intel(I have no data on AMD), and if ALL the articles posted on steinberg are correct, and the comments from support “we are waiting for help from miscrosoft” are true, then… this leads me back to what I was saying originally.

Hyperthreading doesnt work on many versions of cubase, like it has not since sx2 way back in the day. I did not expect my core2duo to work back then, and I no longer expect my i7 7800x to work today, 20 years later, and for similar reasons. That’s all the honest info I was looking for.

Having worked for developers for decades, I understand the extremely sensitive signal pathways found in audio processing of this type, and understand the challenges of working in a software ecosystem that is not always helpful to each vendor inside that ecosystem. I get it. I just look for honesty, which helps me be more clear-minded in my decisions and in my comments.

No, disabling the NIC isnt the solution.
No, buying a new mainboard and/or new PC just to “prove” I did not stumble into building a lemon isnt the solution.
No, altering voltages, ratios, caches, transitions, or clocks beyond stock is not a solution, for me anyway, with my stock config.

DISABLING hyperthreading, like the other user told me to over a month ago, is the solution. For MANY people anyway. For everyone? Who knows which chipsets and processors this works on, and does not. That’s for QA to figure out.

If anything else changes, and the internal ASIO processing overload comes back EVEN THOUGH my HT is disabled, I will update this thread with that info ASAP. As I speak, I keep adding more instruments and playing them realtime… and I dont see any issues at all. Yeah.

Interesting, hyperthreading off okay. good to know.

IS this Win10 only or Win7 as well?

I am on win10 pro, x64. I have no AMD system to test, nor do I have any other intel chipsets or processors handy to do this with. I have a windows7 pro license somewhere, but I just dont have the resources to install and test that.

Fortunately NO high security licensing/DRM components have freaked out and made me re-authorize, so this is good. Windows10 desktop performance is acceptable with 6 cores instead of 12. However… I have NOTHING else installed on my main PC now. We have no other PCs in this house currently, so if I want to play games or do anything else with this, Ill be switching cores on/off via BIOS or UEFI runtime, if it lets me gracefully do that.

3.5 hours in, and I am multitasking on this box as I use chrome to post and read, and chrome has like 8 tabs and 2GB of RAM, lol, of course. No audio pops in cubase though… no red internal meter… and no problems.

Now I have a multi loaded into Halion, with 7 sounds triggering from each MIDI note, all sent through a long reverb FX group, just working it hard. No spikes. Hardly ever even goes to 50%, no matter what I do. While multitasking outside cubase.

FWIW, I run a couple of workstations, both Win & MacOS. The mac specs are in the sig, the PC specs are: Dell T7190 Workstation, dual 12 core Xeon 3.0 Ghz, 64GB ram, RME UFX+, RTX 2080Ti, UAD Quad PCIe, etc.

Both workstations run pretty much identical software, plugs, VIs etc. Not Cubase but Nuendo; also Pro Tools, Ableton Live etc as well as NLEs. In general these days I do film work on the PC and music production on the mac.

Re. Nuendo, in my experience, one of the main bugbears has been (not exactly ‘drop outs’ or ‘latency’ issues per se) - ‘screen pauses’. So it appears that Nuendo locks up - mouse doesn’t work, screen doesn’t update etc for a few seconds - but the sound keeps playing. Have documented this issue many times & have gone down the rabbit hole in quite similar ways to what the OP has described.

Bottom line: tweaking win bios for hyperthreading, speedstep etc made no difference I could detect. Elsewhere across the board, everything else had been maintained, preferenced and made as ‘clean’ as possible. What did make the single largest impact however, was upgrading to Windows 10 for Workstations (now running 1909). I’m sure you can check out the lit. on that elsewhere re. multithreading, optimisations etc.

Still, much as I hate to say it: for audio applications the Mac way outperforms the PC. None of these issues mentioned apply at all. Fast, excellent overheads, no latency issues etc etc. The downside is MacOS Catalina (which I am forced to accept with a new mac) and most of those problems relate to security, non-compatibility with even recent software etc. Still, Nuendo runs like a dream on the mac w/ many 3rd party plugs & VIs, Steinberg Absolute 4, NI Komplete Ultimate etc.

These days then: the mac for music and the pc for film (which btw, still far outperforms the mac, in part because of Nvidia support).

My cents anyways. Good luck.

Thank you for that lengthy reply, and for sharing your experience! Being a 30 year net/sysadmin who has built, supported, and maintained production environments, including live broadcast events with streaming components at pro S&E venues, I feel your pain, and your pleasure!! :wink: I work on win, mac, *nix in my career.

Thanks for the info on win10 for workstations! I had not considered that flavor, and I had not begun to even research it for this. Going to read up on that. That had an impact on your ‘screen lagging/locking’ issue, due to better multithreading, it seems.

Macs have tended to, in average hands, do better than windows in pro audio for a while, since roughly 2006 I think it was? Just after the iPod generated Jobs 999 billion dollars, bailed them out of bankruptcy, and allowed him to build a better mac? lol but in an experienced admin’s hands, windows machines fare pretty well, and are also rock solid in many cases. Currently the gap is much smaller, even in pro audio, especially since everyone runs the same hardware from the same vendors.

I understand what you mean, though, but it is out of the question for my family and I to buy any other machines for this right now, and I dont think the mac pro would solve this particular issue anyway. : /

8 hours of tinkering and playing now, and not ONE audio dropout or realtime ASIO peak after disabling all 6 virtual cores.

Now its on to… learning and troubleshooting this maschine2 / MK3 controller package I bought. Not playing nicely… with cubase at all, lol.

i do share a fair load of the anger and the frustration, mostly on macos, with random asio peaks, the asio meter pecking randomly etc.
furthermore i believe software should just run “fine” on every system, even the ones that are custom made.
however, if there is one, and i mean only one, that has a similar system and does not have to disable HT you should just switch systems, because basically you have 2 options:

  1. use a similar or even identical system to people that have zero asio issues and never have to complain again (at least about this horrendous workaround)

  2. try to fix your problem by forcing cubase to work fine on your system, which, and i’m refering to your experience with building systems, might never happen, because hardware sometimes doesn’t work they way we want it to work. even if it’s steinbergs fault and it SHOULD work on your system, there simply is no other option than changing your system.

as much as i can sympathize with option 2, if i really had to do actual work i would always go for option 1. If your situation doesn’t allow a quick system swap, thats a bummer, but it will eventually be the ONLY solution you have.

much luck to you