Nuendo 10.3 Multiprocesses- Bug?

If I open Nuendo 10.3 than close, than open again, 4 times,
I get 4 processes called Nuendo 10.3 in Windows Task Manager.

Should these 4 processes not terminate as you close Nuendo,
or is this a bug?

I opened and closed Nuendo 10 times, and I then have 10 instances
of Nuendo 10.3 in Windows processes.

I thought that closing Nuendo before opening another project was a good thing to prevent crashes,
but RAM memory just leaks and entangles.

I don’t get that here so it seems to me that Nuendo isn’t exiting correctly on your PC. Hard to know what is wrong with so little information

My system details are in my signature, and all I am doing is a simple Start Nuendo, and then Exit, repeatedly
just for testing purposes.

When you exit N10.3 and look at Windows processes, your Nuendo 10.3 process also terminates
and disappears from your list?


(and your signature is really not enough information)

have you tried safe mode - or deleting your preferences (after backing them up obviously) ?

and BTW windows 7 isn’t supported and neither is the midex 8 especially under 64 bit

Yes I know it isn’t supported, but I can’t upgrade now because of the hardware cost,
and I besides not being the only one here, Nuendo 10.2 is still supported and does the same thing.

The Midex 8 works great, zero problems.

What is missing in my signature?
What system are you using?

I’m pretty sure that your issue is due to you still using Windows-7.

I’ve tested both N10.3 and N8.1.0 on Windows-10 and they both do the same thing:

After launching and exiting Nuendo the first time, the Nuendo entry in Resource Monitor remains there (greyed out). When Nuendo is launched the second time, the first entry remains there until the second Nuendo has fully loaded, then the first (greyed out) entry is removed. No matter how many time I do this, only one instance of Nuendo remains present.

windows 10

have you tried a safe start or deleted your preferences as I suggested ?

I’m willing to bet your issue is that nuendo isn’t closing properly…anything in the event log ?

It’s probably not the (unoffficial !!) midex 64 bit drriver but how do you know 100% that it’s not ? Maybe that’s what’s not allowing you to quit nuendo successfully.

If you want to fix the issue then you are going to have to work back to a fully working (exiting !) system and then add stuff back in.

hi Chris - I’m not convinced the issue is windows 7 but very little information to go on obvs… I get no lingering processes when I quit nuendo or cubase, first time, second time…any time . If you do then there is something adrift in your system…you may not care of course :slight_smile:.

Hard to know what could be causing it but (IMO) you have something (a driver for some hardware possibly) that is not allowing nuendo to shut down. As per the other post you could try a safe start or (temp) delete your preferences.

The problem with some kinds of “crash on exit” issues is that they sometimes mean that some global settings don’t get updated properly (control room - VST connections)…again your issue may be different but it’s probably worth a few mins taking a look ?

My configuration is as per my sig below. When I close either Nuendo 10.3 or Cubase 10.5, there are no remaining orphan processes in Task Manager. I’m in the habit of closing the current open project then waiting 10 seconds or so before closing Nuendo / Cubase.
The last time I had the hang on close problem was around version 7 or 8.

I tend to agree because it is also happening to Nuendo 10.2.20 which is Win 7 compatible, but
it’s not happening with the earlier Nuendo 4 with also Windows 7.

Same Windows 7, the only difference is Nuendo 10.xx, and Steinberg has mentioned fixing exiting crashes before,
as recent as N10.3.

JDDStudios - have you tried safe start or deleting preferences as I’ve suggested (twice!) - or learn to live with it !

Unfortunately in this case, safe mode has nothing to do with the multiple TSR lingering in memory.
I start in safe mode often after Nuendo crashes, and it makes no difference.

Are you sure ? (it only takes a minute or two to check - quicker than typing this reply) - there is obviously something different about your system (windows 7 ? midex 8 ?) that means Nuendo doesn’t exit cleanly. Might be a hardware controller, possibly a plugin - something odd in vst connections etc etc. Deleting preferences is a quick way to potentially help track it down…bearing in mind you posted to this forum for help.

FWIW Nuendo leaving processes behind isn’t something that is ‘by design’ - I have several systems here (6) and none of them exhibit this behaviour.

Looking at your task manager the ‘lingering’ processes are taking up system resources so if it were me I’d want to fix it…

dr Thanks for trying to help.
I did try Safe Mode again, with both 10.2.20 and 10.3.

I chose to delete Preferences and 3rd party plugins,
I started Nuendo 10.3 after a Reboot, and when the Hub came up, the Task Manager showed the Nuendo 10.3 Process at just over 259KB.
It can go above 1MB, depending on the size of the project.
I canceled and exited Nuendo without loading any project.
The Process in the Task Manager decreased to around 90KB and remained in the system.

After about 2 minutes or so, I started Nuendo 10.3 again, and a new Nuendo 10.3 Process started,
while the first one remained resident, just like the picture I first posted above.
So now I have 2 processes named Nuendo 10.3.
New Process goes up to 259KB, and I cancel and Exit Nuendo without loading any project.
Now the Task Manager shows 2 Processes that decrease to around the same 90Kb size.

This goes on, up to ten repeated Processes named Nuendo 10.3, just like the few you see in the picture above.
The same result goes for Nuendo 10.2.20, which is supposed to be compatible with Win 7 according to Steinberg.

It may be something wrong with my system, but no other program I have becomes a stuck TSR like Nuendo,
so it may certainly be a Nuendo bug, that acts in particular systems.

If you have a stable system(s), could you please tell me what CPU, Motherboard and Sound Interface are you using?

Yes but Nuendo 10.2.20 is compatible with Win 7 according to Steinberg, and it
does exactly the same thing here.

I’m using a 8086K i7 - and some random asus MB. RME raydat…but I think you’re barking up the wrong tree (just MO obviously).

Your problem is 100% software - albeit that covers plugins/drivers etc. “IF” I wanted to fix it then I’d be uninstalling hardware devices that Nuendo uses (midex etc)…it seems to me there is something there that doesn’t exit cleanly when you quit Nuendo. Worth a look in the windows event log too. The RME card you are using is pretty old - check for firmware/driver updates.

dr no barking here and you may not be that much of a tree. :slight_smile:
My system has been reinstalled several times, I don’t miss a single driver, and the Waves plugins are stable but
it would be difficult for me to say it is 100% software.
It would still be interesting to know which motherboard you are using, unless you don’t know.
Mine is an Asus P877-V LX and it was stable since 2011.

This almost always happened to me too. But recently everything goes as it should. Not sure if it is since I switched to win 10 or earlier (I guess so).
But are those leftover nuendos not easy to force quit from task manager? That is what I always did. Easier then searching for the cause. This was so in my system/habbit that I am still always surprised when I see it disappear.