NUENDO RENDER IN PLACE vs PRO TOOLS CONSOLIDATE

Can someone, who’s familiar with Pro Tools’ consolidate features, explain me how I can RenderInPlace audio-events in Nuendo 11 in a same way as Pro Tools does it when “consolidating”?

For instance, how can I RIP 10 (or so) dialogue-clips in a track on which I’ve got a noise-reduction plugin inserted like Cedar DNS One?
When I use RIP with “Separate Events” and “Channel Settings” selected, it takes ages (>20 minutes!!) before Nuendo returns its results, and most of the time it returns 1 clip while I thought I asked for separate clips?

Why is it taking so long and why does it return 1 long clip instead of multiple clips?

Select with the range tool and then bounce selection is the same as consolidate clips in pro tools. Any offline processing will be committed but fx on inserts and sends won’t. I use this like in pro tools as a quick way to send individual (Dry) wavs from beginning to end for someone else to do the mix in whatever daw they use. It’s probably taking long because you are bouncing with the noise reduction plugin on insert instead of using offline processing first, then consolidating and bouncing out.

Thanks OnBeat, great tip.
Though; I think Nuendo’s RenderInPlace is designed like the “consolidate”-feature in ProTools, and Nuendo’s “bounce” is designed as PT’s “commit”?
Consolidate/RIP is some kind of exporting the clips like how they would sound through the output of the track they sit on, including all of its automation, and commit/bounce is rendering the clips with only the clip’s parameters like gain, envelope and fades, pitch, clip-effects (=offline processing), right?

When I use a noise-reduction plugin like “Cedar DNS One” in an insert in PT and then “Consolidate” a couple of clips from that track, PT returns these clips on a new track with the noise reduction applied , in just a couple of seconds…
…Why does this same procedure in Nuendo take insanely long (more than 20 minutes)?

And; why does Nuendo return 1 long clip instead of separate clips?
Is there something I’m not getting here, especially in my “expectation” (explained above) from the RIP-features?

I would love to have a workflow where I could actually USE the RIP-feature in order to share my clips with other people, just like you do, without using the bounce-workaround, which wouldn’t work for me since I’m using plugins with a learn-function, and I’m using plugins’ automation.
Thanks, Niek/ Amsterdam.

I must be going insane here… This is what I recall:

PT “Consolidate” only consolidates selected clips into one larger clip. No track effects or aux effects are included. Audio only. Also no automation.

Nuendo “Bounce” = PT “Consolidate”

Nuendo “RIP” renders new media according to the preferences set for that. You can open a dialog box and select what part of the processing should apply as well as what happens after.

Did I get that wrong?

1 Like

No, that’s how it is but you explained it better. Audio terms aside, maybe he has mix down to one file checked in the RIP options. I just tested and RIP works as intended and rendered separate clips. I always check RIP settings before i use it just in case.

I am mistaken, sorry for the confusion I created.
You are totally right by mentioning the opposite of what I was saying.

So,
Nuendo’s “Bounce” = Pro Tools’ “Consolidate”
Nuendo’s “RenderInPlace” = Pro Tools’ “Commit”

Though, my 2 questions not answered yet… :thinking: :grinning:
How come that committing multiple clips in a track which includes learning plugins and automation in Pro Tools takes just a couple of seconds and renders the result also in multiple clips, while Nuendo’s RenderInPlace-feature takes more than 20 minutes and renders the result in 1 large clip?
Has it got to do with the learn-features in my plugins? Or with plugin-automation? I can confirm that “mix down to one file” is off…

I would really appreciate it to get a step-by step explanation of how to mimic Pro Tools’ “Commit”-feature in Nuendo, including the “quick and satisfying results”, and which includes learning plugins in the tracks’ inserts slots and also includes automation.

I must say that my bus-structure in my projects is quite complex, and I know that Nuendo’s RIP renders all buses through which a track feeds, so maybe that’s the culprit and the big difference in efficiency between Nuendo and PT In the case of “rendering in place” ? I think PT only renders the tracks’ output and not all of the buses it feeds into?

Since the introduction of the RenderInPlace-feature in Nuendo, I have not been able to achieve satisfying results unfortunately, but it seems that I’ve been doing something wrong all that time?

Thanks, Niek/ Amsterdam.

I agree that Pro Tools is quite a bit faster with this. Avid was so late to this game, that by the time they implemented it, they must have found a really clever way to do it.

But you might have it even slower than necessary because your render settings are probably set to render “As One Event”. If you use the Render Selection Dialog, you have multiple options of how to perform the render. I often choose “block events”. This way, events that are lined up against each other, render as one event, but pauses with no events are skipped, saving both time and disk space. The render tail option is useful if you want to render with effects like reverb.

If you later choose Render In Place but without going through the Render Settings dialogue, the last used settings will be applied. I would therefore recommend setting up one key command for Render In Place, and another key command for Render Settings. :slight_smile:

Thanks for your explanation here.
Though I can say I am 99,9 % certain that “As one event” and “Mix down to one event” are off in my RIP-settings, I’ll give it another try tomorrow or Friday, when I’m back at the studio, and I’ll report back with the results. Fingers crossed.

thanks.
Niek/ Amsterdam.

Unfortunately, after I tried again, RIP seems not to work as expected to me. Again, it took ages before RIP rendered my clips.

In both Nuendo and Pro Tools I took an empty, mono dialogue track in my template and inserted a 1 minute 1Khz-clip. I cut it in 60 pieces of 1 second, and spaced them with 1 second between each other. Then, I created some automation in the Cedar DNS One plugin. After that I pressed “commit” in Pro Tools and “Render In Place” in Nuendo.

Again; Pro Tools took about 25 seconds to render the 60 clips, and Nuendo took 2,5 minutes to render only the first of these 60 clips, so I aborted the RIP, which also didn’t work properly… :face_with_raised_eyebrow: :face_with_raised_eyebrow:

I made a video of this which you can download from my Dropbox:

Any proper help still welcome.

Thanks, Niek/ Amsterdam.

This and similar issues are known (and unaddressed) problems in Nuendo since many, many years: → Can we PLEASE finally get a true, instantaneous "ABORT" for Export Audio Mixdown?
The official explanation is that a 3rd-party plug-in is the culprit.

For the sake of figuring it out, could you try to take one of those clips and a) try to RIP only one without selecting the rest, and b) try to bounce the clip first so it’s its own audio file, and then try to RIP it?

Just to narrow down if it makes a difference what the size of the audio file or selection ranges are.

(perhaps you did this already)

I just tried your suggestion, and unfortunately, also “only 1 clip” takes about 2 minutes to RIP…

Unfortunately this also takes about 2 minutes to RIP…

  • Also, when I remove “my complex routing” by selecting “No Bus” on the tracks’ output, Nuendo still takes about 2 minutes to RIP only this sole clip.
  • Even when I remove all automation (only 1 parameter) from this track, it won’t speed up the RIP-process…
  • Even when I de-activate this “DNS One”-plugin, so that there are zero plugins active in the track, it still takes 2 minutes to RIP this bounced clip. So I can not really confirm that 3rd-party plugins (even the serious ones) are the culprit…

At this stage I can not say that Render In Place is a feature that works as expected.
I’m gonna send a bug report to Steinberg.

Thanks for all the help.
Niek/ Amsterdam

You should probably also try then to take out third party plugins and leave simple ones like a stock EQ and compressor. After all, it’s possible that if a 3rd party plugin causes a problem it could be (?) that “deactivating” or “bypassing” doesn’t work properly. So eliminating the plugin completely might be best.

Also make sure that you only have the track signal chain set and not bus and master. I can’t remember the correct words for it right now.

Thanks Erik, your insight much appreciated but (quote) :
** Also, when I remove “my complex routing” by selecting “No Bus” on the tracks’ output, Nuendo still takes about 2 minutes to RIP only this sole clip.*

Thanks for the kind tip Mattias, but when I’d need to remove all plugins from my inserts-chain in order to let RIP function properly, then what is RIP’s functionality worth?
For me RIP has never worked properly, and I use it in the same working method as I do in Pro Tools’ Commit which works flawlessly…Just to emphasise there is a difference in approach between the two DAWS.

I sent in a bug report to Steinberg. Unfortunately I’ve never seen a bug reported solved but I’ll give it a go anyway. Fingers crossed. :thinking:

Thanks.
Niek/ Amsterdam

1 Like

Of course it’s useless if you exclude plugins. I just meant that if you remove specific plugins, or add specific ones one at a time, it’ll be easier to see if the problem is one or several specific plugins.

At least if you try to remove DNS One and it then works as it should then you know where the problem is. If you don’t do that and instead assume it’s all broken then you’d think there may be no alternative, right? Perhaps DNS One won’t work but C-Suite (UAD-2) will…(?)

So I only suggested it for the purpose of troubleshooting to find the problem(s).

PS: Sorry if you did this before and I missed it. I’ll try this on my end in a bit…

Thanks again Mattias, you’re right: I should not “depreciate” Nuendo’s features which don’t work as expected before I checked if there are workarounds or identifiable culprits…will check your suggestions someday in the next weekend, and I’ll report back.

Thanks again.
Niek/ Amsterdam.