Nvidia + Cubase 8 Issue

I pulled out my Nvidia GTX680 graphics card last night because I’ve been getting some really annoying ~graphical~ latency when using it with Cubase 8 (the card works flawlessly for other applications).

This problem is noticeable even with very few plugins loaded. Last night, I was working on a single track with two instances of a graphical EQ plugin (pro-q 2) and the graphic issue would occur. The issue is hard to explain, but the easiest way to see it is, while you are playing back audio, if you click & drag pretty much anything- a new EQ point, any VST window, etc, and move the mouse around with it, the framerate seems to take a significant dip.

This problem occurs with the newest Nvidia Driver, the Oldest driver, and I also tested several drivers in between. I know this is a graphics issue because I pulled the card out and went on-board and now I am not having the issue at all.

Is there a solution to this problem? Is this simply a driver incompatibility issue? What can I do about this!? I pulled the card out and am considering selling it, but I honestly would like to keep it :frowning:


System specs:
64 bit windows 7
Intel i7 4770k
16gb gskill ram, 1tb hard drive
Z87 gigabyte mobo

Obviously, without knowing the specifics of your setup it is very difficult to ascertain what the issue would be. However, I would say that often it isn’t just about one piece of hardware “not working” it is the relationship between multiple pieces of hardware and software that is creating some conflict. I’d take a breathe and re-evaluate all of the changes you have made to your computer recently - hardware or software. Unless the card is actually at the point of failure the 680GTX is still a pretty decent and worth hanging to especially if you do any graphics or gaming. I’m running a GTX680 on a 2010 “vintage” PC with C8 64bit and the latest Nvidia driver without any issues.

I have the same gfx card and do not get the glitches you describe

@keith99 what graphics driver version are you using? What version of cubase as well? What are the other specs of your computer?

@racer apologies, I will update the OP. Didn’t think of it though because the problem doesn’t occur without a graphics card. The ~only~ thing I changed in this computer in the year that I’ve built it has been the graphics card (recent, like a month ago)

There are two mainstream solutions to this well known issue (if you have any Waves plugins in the product, which I’ll assume you do):

  1. roll back to March 2014 Nvidia drivers (version 335.24)

or…

  1. use Waves’ “no context sharing” fix. Which is to create a blank text file named the following, in the following location:
    “c:\ProgramData\Waves Audio\no_context_sharing.txt”

Waves is working on an official solution (that will not require their “no context sharing” workaround). I predict it will arrive when their WUP-invoking version 10.x gets released. :unamused:

Yay!

@jalcide I actually don’t have any waves plugins. And as far as I know the oldest driver they have for the gtx680 is September 2014

Those older drivers are in the Nvidia Archive section, but if you don’t have a single Waves plugin instantiated in the project (all it would take), then it’s not the issue.

I’ve heard some chatter that it’s also seen with FabFilter plugings, because they also use OpenGL (the thing Nvidia changed with the new drivers), but I haven’t seen the issue on two different DAWs, one Cubase, one Reaper (that both saw the issue with Waves plugins).

It definitely sounds like a video driver issue.

347.88 which I believe is the latest. Latest Cubase 8 in 64 bit and running on a O/C i5-3570 at 4.4 with 16GB ram

Note to self: need to put this in my sig!

It seems the march 2014 driver solved the problem. Will continue to do work with this driver and see if the problem returns or not.

Definitely there’s some kind of issue with Nvidia drivers.
I used to have drop outs,spikes and audible noises on recording and was condemned to use 512 or above buffer settings with occasional drops spikes but after park my quad core i5 and replace latest Nvidia drivers (3.41.44) with 320.49 and adjust my power scheme to high performance I’m running a rock solid system now.
Absolutely zero audio drops,spikes and no noises at all and my ASIO meter is super low with 64 buffer in my RME.

ASIO Guard on at normal settings btw.

My system was so solid that I even enabled the turbo option in my bios and despite my i5 is 2.9 it’s running now at 3.5
No EIST,C or speedstep enabled.

Cheers

Great news!

Yeah, I’m using this solution for a second DAW (for a real-time mastering chain). The alternative solution is to use Nvidia’s “no_context_sharing” workaround, which works, but lowers the framerate on my Dorrough meters more than I’m comfortable with.

It will be interesting to see how long the March 2014 drivers can last without needing to be updated. It’s a little worrisome. Hopefully Waves will properly fix the issue soon (they claim they’re working on it – over a year now).

Great to hear!

I think you could bump the version up to at least 335.23. In the testing I did, those were the last drivers to not exibit the problem.

But, if it aint broke…

That said, at least Nvidia’s “clean install” option during installation seems to allow upgrading and downgrading the video drivers easily and without any weird stuff left behind, or errors about installing an older version, etc.

So experimenting with different versions isn’t too risky, as it’s easy to get back to where you were.

Hi, Windows Audio quality guy here.
http://blogs.msdn.com/b/matthew_van_eerde/

If you want to block a particular driver from being pulled down via Windows Update, you can use this tool:
https://support.microsoft.com/en-us/kb/3073930

I would be interested in seeing some audio glitch traces for people experiencing glitches. Sometimes the traces are useful in narrowing things down to a particular root cause:
http://blogs.msdn.com/b/matthew_van_eerde/archive/2015/08/11/taking-audio-glitch-traces-on-windows-10-desktop-edition.aspx

Hey guys - anyone know how I can get this for the GeForce 740m? It doesn’t appear anywhere in the driver archives. Thanks!

Yes! You are not the only one I use Cubase 6 and it is glitchy as heck!!!

Thank you very, very much for chiming in.

Just want to inform, that I also experience Cubase 8.5 crashing after updating my GTX980 to the latest driver, so I am staying with the old driver making no problems at all. Does anyone have any recommendations for a graphic card working better with DAWs other than Nvidia?

Thank you so much for this post, I removed the driver installed by windows. :slight_smile:

Hey rumlee,

Maybe this is what was in the links (I didn’t look)…

I was having some slight issues with my GTX960 graphics card until I used the installer from Nvidia to do a custom clean install. It seems like it was the HD audio driver that Nvidia installs with it’s graphic driver that was bothering Cubase.

I’m not a gamer so I chose the “Clean Install” option and the “Custom” option. Then I only checked the graphic card driver (the top one) and unchecked all of the others like the 3d driver, experience (or something like that), the HD audio driver, and whatever else was listed. Since then (almost a year ago) no issues. I do keep up with the graphic and mobo drivers on a weekly basis so that Windows never has a chance to install drivers for these.

I want to add that these HD audio drivers can get installed for the mobo too. So keep an eye for them. The one named Realtek HD Audio Driver was the culprit for me.

Regards :sunglasses:

  1. how do you keep up with this?
  2. so do you download the latest driver pack when its released, and the choose a clean install and only select the top driver? or do you stick with one specefic version??