Open Hi-hat playing technique playback not working properly (Dorico 3.5)

Hello,
If I add the open hi-hat symbol from the playing techniques popup, it won’t work.
I noticed that in the popup window there are three “open” techniques but none of those do the trick.

Instead if I add the open hi-hat symbol from “playing techniques” menu on the right it works.

what’s wrong?

Can one customize the popover text to read “open hh” anywhere? It seems like something that is probably available as a user-customizable technique, jump bar, or key shortcut somewhere in the program.

I solved it
For those whom may be interested here’s how:

At least in my case, in the playing technique there were 3 “open” technique, three different techniques with the same name.

Schermata 2022-06-05 alle 09.52.12

by the way I noticed that in the playing technique menu on the right zone, the open symbol for the unpitched percussion category was referred to “open 2” playback technique

Schermata 2022-06-05 alle 15.32.29

I went to the engrave mode>engrave>playing technique

scrolling the categories you’ll find the three “open” techniques: one in the “common category”, one in the “brass category” and the last one in the unpitched percussion category.

despite of the fact that all three appear with the same name in the popover menu, the first two refer to “Open 1” playback technique, the third one refers to “Open 2” playback technique instead.

I changed the popover text for the one in the “unpitched percussion” category to Open Hi-Hat and this solved the issue.

Schermata 2022-06-05 alle 15.30.35

still wondering why this was messed up though

Kudos!

1 Like

Jumping into this thread to share a similar problem and workaround I found. (I am on Dorico 4.0)

I’ve been running into this exact issue and had gave up trying to use the playing technique popup box (thanks for the workaround on that!). This drove me to use the playing technique menu on the right, and I discovered that sometimes the open hi-hat technique would inexplicably not apply correctly. Visually everything is fine, but the playback would not work on some notes.

I’ve played around in a brand new project (default settings + HALion) trying to figure it out, but the best I can come up with is that ~20% of the time, the open high-hat sound would not playback after the technique is applied. It’s consistent between stopping and restarting playback, so it seems to be tied to the specific note that it’s applied to. It also happens no matter if “Note Before Duration” is on or off.

The only workaround I can think of is to copy and paste individual notes that I know playback correctly (or make a cycle of apply the technique, check that it works, undo, then try again until it does). I’m not sure whats going on here, but I thought I would share.

If you write the drum parts recording live with a MIDI keyboard, I know the issue and unfortunately it hasn’t bee fixed yet

Check this thread out:

brief answer:
“There is currently a limitation in Dorico that if a note has custom playback position data (eg if recorded from MIDI or dragged in Play Mode), then it may not have the playing techniques applied if the position is before the notated position.
Unfortunately that’s the trade-off at the moment, until we’re able to offset the instructions necessary to play the playing techniques correctly by exactly the same amount as the offset you played.”

@dspreadbury
Why, when I make the change suggested by Jack above and try to make the new popover text a default, does Dorico 4.1 suddenly quit (without making the revised popover text a default)?

(Windows 10, 64 bit)

I typically use my computer keyboard + mouse for drums, but it seems like we’re ending up with the same issue anyway. Should’ve done more research before posting, but thanks for the share! Unfortunately “Reset Playback Overrides” doesn’t do anything for me, and I don’t want to risk breaking something with the midi playback adjustments. I’ll keep an eye out for the future.