order of symbols, 8va and slur

In the enclosed example the symbols for harmonics are above the 8va. But I want to have them above the notes and under the slur. But where I can change the setting for it? I cannot find it!
Bildschirmfoto 2017-08-24 um 22.24.22.png

I tried this and the same thing happens in my score too; the harmonics are above the 8va. I was able to drag each harmonic symbol down in Engrave mode, but I agree, it would be nice to have access to a setting which can change this default (or maybe have the default position of the 8va line go above playing techniques).

Thank you Stephen for looking at the problem!

I have encountered the same problem. I would also like to be able to have the harmonic symbols below the 8va line.

Yes, this has been discussed on the forum before, and I agree that we need a solution for it. Hopefully this is something we’ll be able to address relatively soon.

Hi Daniel,
Hi everyone,

I have a natural harmonic for the viola in one of my pieces and, as I can see, the problem is not solved in Dorico 1.2 yet.
It’s not that difficult to correct it in the Engrave mode just for one harmonic (in my case). But isn’t it possible to add an item in the properties panel for this playing technique ?

In the same time I find an other lac about harmonics :

  • If diamond head notes are available, I didn’t find how to enter a ghost note in chords (like it is now possible in Dorico 1.2 for the drum set) to indicate the pitch of the sound of the harmonic in an artificial harmonic chord notation.
  • (Not only for harmonics) The properties panel now allow us to select the string we prefer for a defined note (for stings instrument only as I tried), usefull even for harmonics. But I do not see any “sul C”, “sul D”, “sul G”, etc. available in the playing techniques. I wrote it as a text with “Shift + X”.

We could add a sticking plaster that could allow you to set a property to force playing techniques inside or outside all of slurs, tuplets, and octave lines, but I don’t think this is the correct long-term solution to the problem. We have discussed the kind of rework that will be required to solve this kind of issue once and for all, and we will tackle this in the future.

You cannot currently add parentheses around noteheads on pitched staves, but this is also of course planned for the future.

Thanks for your answer. I’ll be patient.
Fortunately harmonics are not so often used and it’s not difficult at all to change this in Engrave Mode. But as I can see, it needs to change it in all layouts concerned.

Just chiming in — glad the team’s got this on their radar! — the same behavior exists in version 2.1 with bowing markings, which look odd outside the 8va line. Perhaps this is so because they, like harmonic markings, belong to individual notes, while an 8va line is more like an umbrella, and seems (to my intuition) like it should “arch above” individual markings.

Hello,

Any progress with this (getting the harmonic circle below 8va and/or slurs)?

I finally figured out how to get the harmonic circle to show above each note in the tie chain by going into the properties panel and choosing harmonic type natural. At first I was trying to just apply the playing technique harmonic circle, but then it only shows on the first note in the tie chain.

I could drag some of the circles down in engraver mode, but the one in the middle wouldn’t move where I need it to, and of course, I’d just like everything to be correct (or according to my preference) to begin with without any dragging.

Thanks for any help.

If you select the circle and use shift-alt-right arrow (the shortcut to lengthen objects, notes, tempo changes, playing techniques…) you might notice that the circles appear above the next notes.
Out of topic but I thought it could help :wink:

Hello again.

So, I did end up dragging and adjusting all these harmonics to be inside the slur…in the score. Now in the parts, I’m finding I have to start over with every part??

If you’re at this point, grab everything (relevant) in the score in Write mode, switch to Engrave mode, go Edit > Propagate Properties.

To save having to do this in future, pay attention to the “Set local properties: Locally/Globally” switch at the top right edge of the properties panel. If you set it to Local, subsequent changes to local properties (including dragging stuff, as that is actually setting offset X and Y properties) will only affect the layout in front of you. If you set it to Global, subsequent changes to local properties will affect all layouts.

Thank much for the info, Leo.

Screenshot 2021-10-07 at 09.40.33
This just came up on facebook and it is a pretty big annoyance in many cases. One can’t really fix this manually in engrave mode either since the o’s on the tied notes cannot be moved individually. I was encouraged by John Barron to post this here to keep this topic alive.

1 Like

One could use a workaround to fix it. First flip the slur and then put it where wanted in Engrave mode.

3 Likes

Thanks a lot! This actually works as long as you manually move the slur like suggested! Will require a lot of manual slur moving in this particular piece but at least it will end up looking right and you don’t have to move every single ‘o’.