OS X: Cubase 7.0.4 performance improvement switch

Having tested this a bit more, I’m sometimes getting brief spikes, both when starting playback and when the project first opens - neither are audible and don’t affect subsequent playback. After this no more spikes so far but I’ll test further this weekend. I’m using a 512 buffer size and only Steinberg VSTi’s while I’m testing. Most of the projects are fairly small using 5 - 10 MIDI tracks but I’ll try an orchestral template later.

Same here :slight_smile:. I was always getting that red light coming on (then staying on)… with this this new switch, not seen it once yet! (2009 single-processor quad-core Mac Pro)… buffer back to 128 samples, ASIO Guard on.
But I have yet to really push it with a very heavy Project.

I did. :slight_smile:

I copied the TXT file they attached to this thread and put it in the proper path. Tried it multiple times.

Can you list your hardware? Also what are your buffers set to?

I’m testing it right now…

Definite improvement here. Thank you!

Processor 2.2 GHz Intel Core i7
Memory 16 GB 1600 MHz DDR3
Buffer 512
Sample rate 48,000

Thanx Steinberg but… I still get the 2-4 seconds drops.

Here’s my specs:

Información del hardware:

Nombre del modelo: MacBook Pro
Identificador del modelo: MacBookPro7,1
Nombre del procesador: Intel Core 2 Duo
Velocidad del procesador: 2,4 GHz
Cantidad de procesadores: 1
Cantidad total de núcleos: 2
Caché de nivel 2: 3 MB
Memoria: 8 GB
Velocidad del bus: 1,07 GHz
Versión de la ROM de arranque: MBP71.0039.B0E
Versión SMC (sistema): 1.62f7

Uninstalling Cubase 6.5…I can FINALLY use Cubase 7. :smiley: :smiley: :smiley: I worked for 7 hours yesterday with no glitches.

I used C7 for a total of 10-12 hours over the weekend with none of the regular spikes I was getting before. The red indicator still lights occasionally when opening a project, starting a new empty project, or when first starting playback. But this isn’t audible or causing a problem, and C7 now seems stable :smiley:

Great to hear about this, going to try it out during the weekend!

This is not working for me.
Thanks for working on it.
I’m switching to a ssd in a week, maybe that will improve something.

Justus

I have a MacBookPro Middle 2009 3.2Ghz Dual Core & 8GB Ram.

On OSX 7.5 works fine but the red light on the transport bar still comes up sometimes, but on OSX 8.3 there is after view minutes still audio breaks, which means Cubase 7 is playing but no output comes out for a view seconds.

For what is ASIO Guard good if it does not work? When I turn in on, it makes thinks just worst. Hope there will be some performance updates for C7 soon!

Concerning ASIO guard:

Quote from the manual:

Only the audio channels with their plug-ins as well as VST instruments support the ASIO-Guard technology. To get an overview of the plug-ins that support it, open the Devices menu and select “Plug-in Information” to open the Plug-in Information window. To activate or deactivate the processing of a plug-in in the ASIO-Guard path, check or uncheck it in the ASIO-Guard column.

The ASIO-Guard cannot be used for:
-Realtime-dependent signals
-VST instruments with more than on e MIDI source > [multitimbral]
-External effects and instruments > [hardware synths etc]
-Plug-ins that have a different bit version than the operating system > [Cubase 64 bit Vst 32 bit]

I suppose that those ASIO guard restrictions and the possibility of deactivating AG for single VST are not known by everyone.

I heard of them yesterday so I have looked them up in the manual.

I hope this helps!

Tried Cubase with the performance switch yesterday (8h) - seems it is not working for me too. I get dropouts as before…

Thanks for working on it - hope it will be fixed for all of us soon!

Seems that this issue on my mac-bp is resolved :open_mouth: :open_mouth: :open_mouth: :open_mouth: :open_mouth: :open_mouth: Yeay!!

I’m baffled… can’t we just have a flawless update?!

Been doing this since '93 on both platforms with six diff DAWs.

IMHO
the answer is no.

But a user can still make a good living doing this.
{’-’}

I tried the patch but I don’t see any improvement. I try to clarify:

For example if I set my buffer size to 128 or 192, with a relative small project, I have that my average performance meter (in VST performance) is less than 20%, which should be good…however, I get some glitches (and red light indicator) during the playback because of the real time meter. This is surprising to me since the average meter is fine.

This new patch does not solve my problem.

The only way to avoid this is to increase the buffer to very high values. With 1024, the average meter displays few % and I don’t get glitches. However, also in this case, there are cases which still trigger the red light: for example opening a project (even empty!).

After several days of usage with only brief spikes, I’ve had real problems again this morning with frequent spikes and sound distortion - this is on the same projects that were trouble free before (both using HALion4 with 6 or 7 instruments loaded). Buffer size has been 512. I can’t see any obvious reason for the sudden change.