OS X: Cubase 7.0.4 performance improvement switch

Dear OS X Cubase 7 Users,

Thanks to your extensive feedback, we are happy to have implemented a new performance mode in Cubase 7.0.4, which eliminates any ASIO performance spiking under OS X. Please note that we are still testing the newly implemented behavior and therefore we’re providing this manual activation switch for the time being. We are looking forward to your feedback which would greatly help us to consider hardcoding the new mode into the next maintenance update.

To manually activate the improved performance mode, please proceed as follows:

  1. Create an empty TXT file and name it “EnableR7832.txt” (or use the TXT file attached to this post).
  2. Locate the preferences folder of Cubase 7 in Finder: /Users/username/Library/Preferences/Cubase 7
  3. Place the created TXT file within the folder.

If you experience any unusual behavior, please remove the TXT file to return to the previous performance mode.

Thanks for choosing Cubase!

Helge Vogt
Team Leader Product Marketing Group
Steinberg Media Technologies GmbH
EnableR7832.txt (27 Bytes)

Thanks Helge and the other developers! I’ve been working with it for hours and not ONE spike! Nice to move my buffers back down to 512 as well. :slight_smile:

I have tried this with no discernible change in performance. Perhaps I was expecting something different then what was stated as being resolved. I can run at a buffer setting of 512 K all day long but I cannot get to the 256 K buffer with this setup.

And, now with the 512 buffer stting any time I stop the transport, I get the red ero on the performance tab.

Thanks, CS.

Isn’t this just for the specific problem of users having asio spikes, and not an overall, general performance improvement?

I have not had the spikes, so I haven’t used this fix.

Correct. Has nothing to do with overall performance. (at least that was not my understanding). This is for the 2 to 3 second spikes Mac users would experience regardless of CPU load or the size of a project. I’ve been testing it for a week now and haven’t had ONE spike. I’m so confident in this release I’ll be using it this weekend for all my shows AND I finally was able to uninstall 6.5.

So far, so good. I’m getting odd spikes with high CPU load on my ageing iMac, but not the random spike at low load.

I can’t find the folder I’m meant to put the .txt file in…

I go to Users/Username… and in that folder I can’t find a Library folder.
There are other Library folders but they don’t contain the right folders either.

Any ideas, please? Would love to try out this performance boost as i’m still having problems after the update.

Too bad the studio is booked this weekend. Otherwise I might have tried it. Or I could do it secretly in the night :ugeek: :ugeek:

In the finder press “alt” and klick on “goto” in the menu. There you will find the library.

At the top of your screen click on “Go”. Then hold down your “option” key and you will see the Library unhidden.

http://mac.tutsplus.com/tutorials/productivity/how-to-reveal-your-library-folder-in-lion-or-mountain-lion/

Instructions for revealing the user\library

You are a legend! Thank you very much.

Now let’s see if this works :slight_smile:

Am i the only one with a Mac (Mac Pro 2008 model 8-core) not having any cpu problems at all ?

No spikes on my system ! Can do 128 buffers easily with a bunch of VST-i’s .

Is it because i have an 8-core and an rme fireface 400 ?

I know that my 2008 mac pro has a Texas Instruments firewire interface where my fireface 400 is connected to. On the RME forum I’ve read lots of firewire problems. Never had any on this 2008 mac pro.

Or is it maybe hyperthreading on newer macs ?

This performance fix results in my asio meter getting like 1-2% higher usage.

On the other hand, it feels as if Cubase is starting up faster…

Probably lack of hyperthreading.

It didn’t effect all the Macs … my guess is something to do with the different chipsets. I’ve been testing with them now about a couple of months and at first they couldn’t duplicate the problem. Then they went out and found the same model and year as my MacBook and were able to duplicate the spike in their lab. So not sure what the common issue was. I know it had nothing to do with Firewire because one of the first tests we did was to use the internal sound on the Mac and it would happen using those settings. It would also happen without ANY plugins installed. They would happen if if you were just playing a wave file or letting it run with just the metronome on.

Just glad it’s fixed!!! :slight_smile: I’ve been on 6.5 all this time! :slight_smile:

Preliminarily, the red “clip” indicator on the transport Performance Load meters has not showed up yet. Whereas before it would constantly be appearing. Put a session through the ringer (hundreds of Kontakt voices simultaneous, plus processing plugs) and not a single ASIO/CPU clip yet.

Sessions seem more stable on first test run at 256 sample buffer. If I drop it to 128 I start getting major ASIO overruns. (Which may be related to Kontakt’s disk streaming hitting a bandwidth bottleneck or just overburdening the audio engine in general)

Very promising so far! Definitely an improvement.

(ASIO Guard off, 256 sample buffer, 12-core NON-Hyperthreading Mac Pro, C7.0.4 64-bit, 40 instances of Kontakt5 loaded plus processing plug-ins)

Aloha H,
and thanks for the info.

I too have had NO real performance issues with C7 compared to C6.5.
Either with OSX.7.5 or OSX.8.3

I track at buffer setting 128 using a Steinberg/Yamaha n12. No probs.

BTW
A major TANX to Steiny for all this Mac specific work recently done by you guys.

Was not too long ago when many Mac users thought that Steiny
might be dropping the Mac platform completely
but you guys kept telling us that was not true and I now see, you were right.

Love Cubase

You guys rock!
{’-’}

It’s really encouraging to see this issue being worked on. Much appreciated!

However, the fix seems to result in higher CPU use for me, and I still get spikes.

So you copied the TXT file they attached to this thread and put it in the proper path? Without that txt file or if it is in the incorrect place, the switch will not activate.

I installed 7.0.4 today and opened up a few projects. With the performance switch it seems that some of them use slightly less CPU-power at lower sample rates. I normally work with 256…

Haven’t had the time to check if my 5-10min spikes disappeared, but I realized two things:

  • When I start playback some of my projects still cause one non-audible ASIO-real-spike. That disappears sometimes when setting buffer size to at least 384. And it doesn’t matter which size. I have to say all of them where originally created with 6.5 or 6.0 - May this be the problem?


  • Size - I have one large project with 88 tracks and 15 plugs and it uses 25% ASIO-load, and one with 9 tracks and 2 plug-ins that uses nearly 30%. Even when I unload all plugs it uses more than it should (same sample rate/bit depth). Didn’t have this with 7.0.1 on OS-X and performance switch did not change this…