PC shuts down instead of sleeping with Dorico/Nuendo

Odd problem, I seem to get them … on this new PC build for Dorico everything is straightened out except, only when an audio app is running (Dorico & Nuendo tested) the computer will hang for about ten minutes with everything off except a flashing hard disk light, then it seems to give up and just shut down. I’ll guess there’s some issue with accessing the sound cards which is preventing sleep, and after a timer expires Windows throws in the towel.

Any idea? I have three interfaces, the build in one, a Thunderbolt RED4PRE and a USB Focusrite Clarett 8pre. All my drivers are up to date, nothing with a question mark in Device Manager, new computer and install and have tried everything I could find via a search (note people who have had this issue did so in general use, I didn’t find anything related to audio)

So you’re saying that if you leave Dorico or Nuendo running past the point at which the computer should go to sleep, the computer instead shuts down? Dorico and Nuendo will actively prevent the computer from sleeping if they are running, so I think something else must be going on.

I mean I have Dorico and/or Nuendo running, I’m doing work, then at the end of the day I put the computer to sleep (Windows menu/Power/Sleep) with the one or both apps passively open with documents/project, Windows will try to sleep but seemingly fail and then shut down. Just normal computer work, like leaving a Word document open when you hit sleep.

[quote=“dspreadbury, post:2, topic:702355”]
Dorico and Nuendo will actively prevent the computer from sleeping if they are running[/quote]

Did you say that right? You have to quit Dorico and Nuendo before sleeping the computer? Or did you mean to say the opposite? On Mac OS I could leave Dorico/Nuendo running and the OS would happily sleep, as it normally does with any other app left running (Firefox, etc).

If you did say that correctly then I’m surprised you aren’t allowed to sleep with these applications open, but glad to know that’s what’s going on.

Edit: Oh ho! I did tons of searching before posting, but now armed with some different terms I found the following

Yeah I’m trying to actively let the computer sleep with open applications. Also these are the Focuswrite Pro line so top drawer drivers, or they should be.

Right, you can still tell your computer to sleep, but Dorico/Nuendo/Cubase will prevent your computer from falling asleep because it’s been left idle – because your computer isn’t idle while the real-time audio engines in these audio applications are running.

But if you explicitly choose to sleep, then the computer should sleep. You’ll need to do a bit of detective work to figure out what’s going on, I fear. Would it be a huge inconvenience to disconnect your external audio interfaces to see whether the computer sleeps correctly if you put it to sleep when, say, Dorico is running? (I imagine it’s less work to change the device setup in Dorico than it is in Nuendo.) This would at least give us a clue whether perhaps the device drivers are playing a part (which I suspect they are).

this is a pretty common problem which I’ve had myself on occasion in the past. If you’re still unsure of the cause after selectively disabling the audio devices, you might try an article like Fix Windows 10 Sleep Mode Not Working [Solved] which may well help.

1 Like

I did various experiments with audio interfaces but with your encouragement I unplugged both Focusrite interfaces (USB and TB) and used Dorico with the built in Realtek audio (the most common interface on the planet) - same problem. So I looked at any other things I could try, and unplugged my MOTU Midi XT MIDI interface, with the Realtek only. It sleeps!

Encouraged by this I plugged the Focusrites back in - still sleeps! Finally I had Dorico actually use the Focusrite TB - and it still sleeps. Oh my god what a relief!

So Daniel I assume you are using the same MIDI backend as Nuendo, it looks like it just doesn’t like the MOTU MIDI Express, which is a pity as there are few MIDI interfaces anymore like this. Any thoughts?

Dorico/Cubase just uses the MIDI driver of the system, so I think it’ll be down to whether the driver’s power settings allow sleep. The page that dko22 links to has some useful diagnostics, and may allow you to change the driver’s setting. Dorico has no control over that at all though.

1 Like

Putting your system to sleep with music apps open is on all the lists I’ve seen of things not to do…

1 Like

Yes going back to the old days that’s the general advice, but in the modern era that should be obsolete. I’m doing some beta for Nuendo and chatted with Thorsten about the issue, he indicates that Nuendo should sleep with the computer just fine, and Daniel says same here. The only issue we should expect is that the computer won’t sleep by itself which is expected do to the audio engine running, but a forced sleep should not be a problem.

I have big projects, so big I need to use VEP as it takes up to 5-10 minutes to load and initialize the VST’s (and this computer only has NVMe drives and 128G RAM!), and I’m doing sound design and mixing in Nuendo, bouncing all this every day is too much time.

At any rate this looks like a problematic MOTU driver issue and I submitted a ticket. Thanks for the help everybody!

1 Like

Wow, MOTU tech support has already gotten back to me that they were able to replicate the issue :+1:

1 Like