Pianoteq 6 vst3 plugin

Anyone else tried this on macOS? I get audio feedback like there is some ungrounded microphone enabled or something. Neither Pianoteq nor Dorico has an audio input so I have no idea what is going on here. The vst2 version works fine as has every prior version. This is their first vst3 product so I suspect some vst3 incompatibility.

I’m using this on a laptop with just the built-in audio interface.

Attached file demonstrates the noise.
pianoteq vst3 feedback.zip (566 KB)

I can second this, and, for me, it’s only happening in Dorico.

I don’t have any other vst3 host to try.

Yup, happening for me too. Horrific noise.

This is really weird, never heard of a case like this.

Please do me a favour, in Dorico, from the menu choose Help > Create Diagnostics Report. That will create a zip file on your desktop, please send to u dot stoermer at steinberg dot de. I doubt that I will be able to see something from the log files, but anyhow, this will give me at least a starting point to look at.

Secondly, you could get a Cubase trial version and see if that also produces the noise. Have a look here: https://www.steinberg.net/en/products/steinberg_trial_versions/cubase.html
If you have a USB eLicenser you could get the trial for Cubase Pro, if not get Cubase Elements, that will also do for the test.

And also, could this have something to do with the fact that you are on 10.13 beta? I just recently had the issue that a MOTU audio interface would not work at all with the beta, completely crashing the system as soon as I chose it for sound output.

I have the same problem with Pianoteq 6 in Dorico, and I don’t have any other vst3 hosts to try it with.

HI Ulf,

I’ll send you two files. One before selecting Pianoteq 6 as an instrument and one after selecting it.

Cubase Pro 9.0.2: Even though Pianoteq 6 (VST Version 3.6.7) is listed under the VST Instruments in the Plug In Manager, it doesn’t appear in the list of VST instruments for either Track or Rack selection.

I’m on 10.12.6.

Thanks, I’ve received files from Ulrik and David.
Unfortunately - as I already assumed - from the log files I can not see anything suspicious.

Only thing that I wonder, you both have Pianoteq 5 and Pianoteq 6 installed. Apparently P5 comes only as VST2 and P6 as VST3 plug-in. Why do you still have P5 whitelisted in Dorico? Does P5 do something better that P6 can not do? But that just as a side question.

And David says that P6 does not get listed in Cubase Pro. Does P5 get listed and can be chosen?

How about in general with the noise? Does it only start when you select P6 and stop immediately when throwing it out again?
What is with P5? Same thing?

  1. I’m still whitelisting Pianoteq 5 because I’m used to the program (Pianoteq 6 is very new and I haven’t got to grips with it yet) and also because until this issue gets solved I wouldn’t be able to use Pianoteq in Dorico (or Cubase)
  2. Pianoteq 5 is listed and works in Cubase

The noise starts immediately after you select Pianoteq 6 as a VST instrument. However, it’s not fully consistent. I have, on two occasions, been able to make Pianoteq 6 function in Dorico. The first time was after I switched the selection from Pianoteq 5 to Pianoteq 6, heard the noise and deselected the instrument instance completely, opened a new instance and was able to load Pianoteq 6 without any noise. Intrigued, I repeated it step by step but wasn’t able to achieve the same result. The second time was after I restarted my Mac. I was able to load Pianoteq 6 with no noise. Switching back to Pianoteq 5 and then reselecting Pianoteq 6 brought the noise back.

I would stress that after selecting Pianoteq 6 successfully, I haven’t used the instrument for an extended period. For all I know there are other faults with it.

BTW - you can download a test file of Pianoteq. IIRC it’s only about 40-50 meg.

Thanks, I just found out myself that there is the trial version of P6 and I installed it.

In first instance it did work well for me in Dorico, then I swapped instruments back and forth and then suddenly P6 started the same noise.
It’s good that I can reproduce the issue, so I can make further investigations.

By the way, I’m on Win10 here, so it is a general issue.

Will report soon what I can find out…

I’m having the same experience as David and I have Pianoteq 5 listed because I just upgraded to v.6 and I’m glad I still have it on the whitelist now :slight_smile:

I just upgraded, fearing this feedback noise, applied the vsti in Dorico… and works nice ! I hope I won’t have to edit that post !

Okay, I was not familiar with Pianoteq and did not know that P6 was pretty new, so I just wondered.
Good that you still have P5 so you can work around this issue for the moment.

As for my further investigations:

P6 works for me very well in Cubase Pro 9. @David: Take a second look, it’s listed under sub category Synth.
But I never get that noise issue in Cubase no matter how often I swap instruments.

In Dorico I do get the noise, but quite irregularly. Sometimes it happens only after the 10th or 20th swap, sometimes immediately. Also the noise does change sometimes. Might go from just a clicking sound to full scale digital noise.

So this suggests it is a problem of the Dorico audio engine and not of P6. However, we have a small tool called VSTTestHost that we deliver together with the SDK to the plug-in developers. With this test tool I can also reproduce the noise issue, so this more suggests that it is a problem in P6.

Anyway, I’ve now filed this issue in our bug tracking system. We will get in touch with the guys from Pianoteq to sort this out, no matter on who’s side it is.

So stay tuned, I will report back as soon as I have more news. Might take some time, but we’ll get it…

Thanks Ulf - as you say, it’s under synth.

So I downloaded Cubase Elements trial and also he VST3 SDK Plugin Test Host. Can’t get either of these to exhibit the problem when instantiating vst3 version of Pianoteq 6. But still exhibits the problem in Dorico if I use there vst3 plugin. vst2 plugin always works in Dorico.

BTW, I noticed when running the SDK VST3 plugin app, there are audio inputs and outputs that are assignable separate from the plugin. Is it possible these aren’t getting initialized correctly in Dorico? It sounds like a feedback loop and this seems like a suspicious source of that. Is there an xml file somewhere that one can manipulate these?

With the VSTTestHost one has to try really really hard to run into that problem, but I managed to get the noise there twice.

I’m already in contact with the Pianoteq makers and they say they are already on the case, so let’s see…

Well, I guess I had been lucky for some hours… When trying to launch Dorico, it would not even start, I had to restart my mac. Then Dorico would open, with a buzz like a 0dB square signal, until I change my vsti pianoteq 6 to pianoteq 5 (or anything else).
I think, for the sake of my loudspeakers, I will wait until the issue has been resolved before I use Pianoteq 6 again !

Pianoteq just updated version 6.0 for me and it seems to solve this problem. New version number is: 6.0.0/20170908

I also just got a direct message from them. They say they are not 100% sure if it fixes the issue, but please try it out.
I will do more tests on Monday.
Let’s keep fingers crossed that the issue is gone…