Playback jitters and cuts out

When I play a moderately large score (20 staves) through Noteperformer, I’m experiencing glitches in playback. The sound will suddenly drop out for a second or so, and the cursor will jump around. This is new behavior. Computer restart did not fix it.

What’s strange is that it only does this when playing back choral parts. Playback is fine when choir is tacet. But even if I solo the choir, same glitch.

Playback continues, with the audio engine re-syncing every couple bars or so. The program doesn’t hang or crash. CPU is running at a lazy 14%.

Searched the forum but didn’t see anything similar (unless I missed it).

EDIT: It’s not consistent. Sometimes it works fine.

Perhaps try increasing the buffer size a little bit via Edit > Device Setup to see if that helps.

The issue continues. Not a big score (full orchestra, but only strings and a horn are playing). Noteperformer plays fine until the choral parts enter - then playback starts jittering and cutting in and out.

Buffer is set as high as I can set it on my sound card - 100 ms. Is this a limitation of my laptop’s audio driver or whatever?

I tried installing ASIO4all and wasn’t able to get it to work, so I returned to my laptop’s default (Realtek audio).

Suggestions welcome, as this renders NP unusable for me whenever choral parts are involved (which is often).

The drivers that ship with these sound chips are notoriously high latency. Not suitable at all. Is there a support forum for ASIO4all? Maybe somewhere out there is some advice to help you out. Only other option is a portable USB audio interface.

This does sound like it could be a soundcard issue. If asio4all isn’t working for you either then that suggests there could be a some problem with it. I can take a look at the project file if you like and check there’s nothing unexpected in it. p dot walmsley at steinberg dot de

I would really recommend using a proper asio soundcard (even the cheap ones are much better than the default motherboard ones). If you ever want to do live MIDI recording (soon!) then being able to get low latency is essential.

[jazz hands]

I am experiencing this same jitter and cutout issue as well. Searching the forum I found this post.

I am not using noteperformer however; the problem exists with the HSSE+HSO Pro or HSSE(elements) templates. It doesn’t matter.
I also see it regardless of driver or soundcard. Using the soundboard in my PC (realtek I think) I see it with the generic IO driver with the latency at maximum, or with the ASIO4ALL driver. I also see the problem using a Presonus studio 24 USB interface with either presonus’s driver or the ASIO4ALL driver. It is always the same. A score of about 20 instruments will sputter/dropout/crackle when there is an entrance of alot of instruments during a quick tempo. If I select only a subset of the instruments, it plays fine; but as soon as I go back to the whole score, the stuttering begins again. I’ve noticed I can exasperate the problem by increasing the metronome rate, but there is so much randomness to this.

It seems to be a “note-density” issue (alot of instruments entering with different rhythms). I never see the problem during solos or light passages, but once the problem occurs, it continues to occur in that same passage. I usually close dorico and reopen it at this point.

Watching the taskmanager, I do not see excessive CPU usage, but the VST engine does consume the most memory and utility. The dorico process very regularly reports “not responding”, even with what appears light CPU and Diskdrive activity. There is nothing running on the machine other than Dorico (no backups, downloads, no virus scanning, no browser, no solitaire game in the background :slight_smile: ; I am watching the taskmanager constantly

Other symptoms.

When dorico first opens, If I immediately hit playback, I get nothing for about 30 seconds. Then alot of audible garbage. Seems the VST process is still loading when dorico opens.

Switching from Write to Play mode takes about 10 seconds to process. Play to write mode is fast.

There are times when no amount of IO buffering will work

Output WAV files are always generated without stuttering.

I am using a i5-4460 processor with 16GB of ram. I never exceed 6GB.
Is this not an adequate system for a 100 measure score of approx 20 instruments ?

What is the Multi Core option in HALion Sonic SE set to on your machine?
You can find it if you open the HALion Sonice SE editor window and in there choose the Options tab. It is then to be found mid right of that page.
If it is switched off, set it to 1 less than the maximum available cores and see how that goes.

Also in the HALion Sonic SE options page, ensure the number of voices is set to a number that’s 300 or more.

Multicore was off, voices was 128.
I changed multicore to 3 and voices to 300. The multicore setting saved, but the voices did not retain the value after closing the window.

Are you supposed to leave the Halion window open while working in Dorico, or does Dorico snapshot the settings when it is invoked ?

I did notice an improvement with the multicore setting and was even able to reduce the iobuffer latency
But I was suspicious when I moved the multicore back to off and it continued to work.

I also noticed that setting num voices made no difference. I set it to 1 and it worked

No, you are not supposed to leave the HALion window open.
The Multi Core option is global for all HALion instances, but Max Voices can be adjusted for each instance. Also, the value shall get retained even after closing the window, and that is exactly what it does here with me.
Also, Max Voices does get regarded here with me. If I load a complex project and set Max Voices to 1, then really only one voice gets reproduced. By slowly increasing the number then more and more can be heard.

So I don’t know, that what you describe makes no sense to me and is not what I experience here.

By the way, especially the HALion Symphonic Library uses several voices to create one sound, it layers them all together. That’s why you should set the number to at least 300, even if you don’t have 300 players in your score.

if I open Halion and change the numproc to 3, and numVoices to 300 and then close the window
it will ask to save this, I say yes and give it a file name.
then it closes.

if I then open Halion again, it shows numproc=3 [good] , but numvoices=128 [?] . It always opens with 128 as numvoices.

If I choose not to save when closing; I get these same results

thx,