Playback Problems Dorico with NotePerformer

Hi everyone,

I’ve got a problem with hearing some instruments in Dorico using Noteperformer.

I got around 20 instruments. When I navigate to “Playback” → VST instruments I created a folder, choosing NotePerformer. Went to settings and created 16 MIDI channels. And I can listen to the first 14 instruments, they playback perfectly.

But for the rest of the instruments - I cannot hear them. I tried it with creating a second port in the NotePerformer folder and rooted (VST inspector)
the last instruments to port 2, channel 1-5.
But the “edit instrument” window only shows the first 16 channels and Double Bass sounds like a trombone or sth.
Also tried to create a second NotePerformer folder and rooted the channels to it, but they are not shown in the NP window.

Seemed to be an error, but I hope that I am doing sth. wrong

The screenshot shows the first way that I tried: Rooting cello to Port 2 Channel 4 of the Noteperformer VST folder (Expression Map NotePerformer of course)

my second try: creating a new NP folder and routing Violin1,2, viola, cello, Double Bass to Port 1 , ch 1-5
Shouldn’t be working, because port 1 should already be occupied by the first channels’ instruments.
But the thing is, the instruments still sound like some brass instruments.

I’d be very thankful for any kind of help,
kind regards

Welcome to the forum, Anton. Are you manually setting up all of the NotePerformer instances? If so, then the recommended way to work is to use the supplied NotePerformer playback template. You could try reapplying that as a first step: go to Play > Playback Template, select NotePerformer, and click Apply and Close.

2 Likes

Good morning Daniel,

yes, I did that before. Afterwards I added some more instruments. They did not play correctly. So I just applied NP again and… it works! Hell yeah, you really couldn’t believe how thankful I am.
I need it for my instrumentation final exams and I already spent around 10 hours trying to fix this.

I wouldn’t have tried this for the next 10 hours for sure, because I already did this.
Thank you Daniel and have a great day!

So for anyone reading this in the future: If you already selected NotePerformer as your Playback Template and added more instruments, just apply NP again and it might work

1 Like