Playback Template: Individual Mixer channels for NotePerformer

Hi all,

I’m attaching a Playback Template that creates separate outputs / mixer channels for all NotePerformer instruments that show up in Dorico’s Project Templates.

To do this without overloading the system, all the endpoints have the Instrument and Master reverb settings set to 0.

Reverb and other effects can then be applied in the Dorico Mixer.

A couple of important caveats:

  • Setting up NotePerformer this way uses a lot more CPU (over 200% instead of under 100%) but about the same RAM.

  • While Dorico is open, the NotePerformer Master reverb sets itself across ALL open NotePerformer VST sessions to the last used Master Reverb setting. The Instrument reverb settings are not affected. Consequently, switching between the two NotePerformer Playback Templates (regular and separate outputs) will require the Master reverb setting to be manually reset. The setting for the regular template is 50%. The (SO) template is 0%.

Also attached is a PDF of all the Endpoints used in the Playback Template and a guide as to how to go about creating further Endpoints in the same template.

Finally, I’d like to thank MarcLarcher, Daniel and John at Dorico for their help for their help and advice while putting together the template and also Wallander Instruments for giving their OK to post this.

NotePerformer (SO).dorico_pt.zip (508.9 KB)
NotePerformer (SO) Playback Template.pdf (124.1 KB)

17 Likes

Thanks for this David Tee. It loads OK - unfortunately the original NP playback template has disappeared. I don’t know why this happened. Perhaps I overwrote it?
Any advice on how to reinstate this so that I can add new endpoints to the SO version…

Regards
Martin Kennedy

Hi Martin,

If I understand you correctly, you’re saying that the NotePerformer Playback Template is missing from the list below. Is that correct?

If so, I also can’t see how it has happened. It’s one of the factory templates and there’s no easy way to delete it. But anyway - something has obviously gone wrong.

I haven’t come across this before but if I had, I’d probably trying reinstalling the latest Dorico update to see if that resets things.

Regards,
David

1 Like

I thought the NotePerformer template was only installed when you downloaded NP but could be mistaken. In any event, you could also try re-installing NP from its website - there is a link there to do this.

PS Thanks, David, for for devising and sharing your NP(SO) template!

1 Like

Dorico itself does not install the NotePerformer playback template. As Mike says, you will need to reinstall NotePerformer itself to reinstate that if you’ve somehow contrived to remove it (though I really don’t know how you might have done so!).

2 Likes

Thanks all - I reinstalled NP and its template came back.
Martin K

1 Like

This (SO) Template works great in Dorico Pro 5.
Thank you for creating this gem!

Ben

2 Likes

It works perfect! The only thing that works not, is an instrumentchange. I mean: the marimbaplayer changes to a big gong…

Is there a workaround?

Hi Oliver,

I suspect the issue here is that a Large Gong is not one of the defined endpoints. If, for example, you attached the Opera Gong to to the Marimba player - that works OK.

If you look at the Note Performer Playback Template pdf you’ll see a list of all the endpoints and also a guide to help you add further endpoints.

To save you some time - here’s the NotePerformer (SO) Playback Template with the Large Gong included…

NotePerformer (SO).dorico_pt.zip (519.3 KB)

Best,
David

2 Likes

Thank you! The problem in Dorico and NO was that I wanted a TamTam, but NP did not find this sound. So after some tryouts l found out that “big Gong “ triggers the TamTam sound. I am conductor and composer for many years and I know that a Gong is a totally different instrument than a TamTam. But this was the only way to get this sound. I read on the Doricoforum that other composers have the same problem with unpitched percussion. By the way: your template SO is great!

2 Likes

This is an updated version of the Noteperformer (SO) Template that rectifies issues with Drumkits in NotePerformer 4.

NotePerformer (SO).dorico_pt.zip (519.5 KB)

4 Likes

This is great David! Thank you for making this.
It works flawlessly with native NP sounds. I tried to use it in conjunction with NPPE but found it often stops outputing separately and become single output instead. If I click reset button in each standalone NP mixer, it might be back again but whenever I stoped playing or move the playhead, it might go back to single combined output. No sure if I described clearly. Just to let you know that the playback template seems not playing well with NPPE. If this can be fixed or it there is a workaround for making it more compatible with NPPE, that would be awesome! Thank you!

NPPE can itself assign separate output channels to send to the Dorico Mixer.

2 Likes

Hi Derrek,

Thank you very much for the tips!
I tried to set each instrument in NPPE to different Stereo Output, but when I playback the score, still see output level only from one channel in Dorico mixer. How do I get more stereo output channel displayed and respond in Dorico mixer? And should I use the separated out playback template by David or simply by using the original Noteperformer playback template things should work? Thank you!

Recently I am trying to use NPPE with Berlin Studio reverb so I need to have separated output to send each group of instruments to different Berlin Studio instances with their own presets.

How do I make use of this function? I seem cannot see more stereo out channel in Dorico mixer after setting each instrument to different output channel. Thus could not have seperate control over each instruments. Hope you can share me some idea how to use it. Any furthur tips would be really appreciated! Thank you!

Hi Roger,

The NotePerformer (SO) Playback Template is only there to provide separate mixer channel outputs for the native NotePerformer sounds.

If you’re using NPPE, make sure you’ve selected the Regular NotePerformer Playback Template in Dorico. As Derek has said, you can then set up separate outputs for each instrument ( go to the Advanced Settings) .

Best regards.
David

Here is a reference on the NP site. Scroll down to see the Advanced Settings section.

There is also a downloadable PDF Users Guide.

2 Likes

Hi David & Derrek,

Thank you for helping me out. I did read through the manual and set the output acccordingly in NPPE following your suggestion. Initially I still could not see separated channels in the mixer of Dorico. But after re-applying the original NP playback template, they finally appear in the mixer and I can now do the things I want. My bad for the dumb question but just want to thank you again and share my experience if anyone wants to do similar mixing inside Dorico.

Cheers,
Roger

2 Likes

Hello @David_Tee,

Thank you for your template for Individual mixer channels. Super helpful!

Recently started composing a wind band work and noticed that the template doesn’t seem to load the instrument patch to Alto Saxophone. All other instruments work great.

Please advise. BTW, the standard NP playback template works fine loading Alto Saxophone. Weird!

Thanks. Please advise.

Hi David,

I can’t replicate the problem . I’ve just added an Alto Sax to a string ensemble and all works as it should.

If you want to message me with the file I’ll take a look and see if I can work out what’s going on.

Best regards,
David