Playback techniques pickle!

Hi folks. I am getting in a pickle with playback. I have created a playback template that routes singers to Olympus and an accompanying organ part to Halion. However, the organ part is somehow picking up Olympus playing techniques - clearly visible in the “Playing Techniques” line on the piano roll view. The result is that these instructions are playing back on the organ, producing unwanted random notes! I am quite sure the problem is of my making, but I’d really appreciate some advice on what I might be doing wrong. An organ part really should be playing back as “Ah, marcato (nat)”. I thought that creating a playback template with Olympus as the default for the ‘singers’ family and HSSO for everything else was all I would need to do but I seem to be mistaken.

If you have manually loaded the Olympus (to get the full version) and/or manually loaded the HALion Organ, then you need to insure that each has the appropriate Expression Map aligned with it. If you are using the modified Olympus included with HALion, then you should reapply the HALion+HSO Playback Template, and it should take care of that for you.

Thanks Derek. First time using multiple VSTs in a project. I think I have figured it out. I had obviously done some manual playing around - clicking the “Reset Playback Overrides” seems to have sorted everything out. Should have realised Dorico would have done it all for me if only I’d let it, instead of fiddling! I now know where to look next time it muck it up!

Spoke too soon. I’ve just checked the end points and the organ part is set to ‘default’, which I am assuming is correct. However, I’m still seeing Olympus entries in the organ part in the piano roll.
Screenshot 2022-10-20 162801

It’s really difficult to help you without seeing the file…

1 Like

I’ve attached an example file.

  • If I use the factory HSSE playback template all is well. A single VST is loaded, it pops the choir into channels 1-5, and the organ into 6, and correctly assigns the routing.
  • If I switch to my custom playback template, which has a voices family override for Olympus Elements, with fallback to HSSE, I get two VST instances, it shoves the organ in channel 1 of one of them, and the choir in the rest (12 in total in each instance). However, assigns seemingly random routing, sending the soprano to the organ, amongst other oddities.

Am I just misunderstanding how this is supposed to work?
I’ve also noticed that assigning the Olympus playback template (or anything including it) sends the file size rocketing, from 600kB to 45MB!
Sample.dorico (598.5 KB)

In your sample, I do not see your Custom Template, which is where the problem seems to lie. Can you include a part of a file that includes it (preferred), or at least show an image of the Playback Template definition?

There might be something wrong with the way the endpoints you use for Olympus choir have been created. When it works as it should, you set your playback template with a manual exception first, Olympus choir, then automatic HSSE (the order in the playback template editor is very important). Dorico will then first deal with what can be allocated to Olympus choir, typically voices, then it will deal with the rest of the instruments, in the order in which they appear in the instrument creation order iirc (which can be misleading, but hey, what happens if you add another player afterwards? You want Dorico to assign the sounds too).
This could explain why all voices aren’t allocated in the order you expect. But certainly not to an organ sound! I 'm afraid I’m away from my computer for three days now so I won’t be able to check your file out, and with a silent template, it’s no real use I’m afraid. I 'll look into it on Monday if it’s not solved by then :wink:

Can’t do that, @Derrek. It bloats the file to a size I cannot upload to this forum!

Thanks @MarcLarcher. I have created the template in exactly the way you describe but I cannot include that template in the file as Olympus causes the file to bloat to an extent I do not comprehend and which this forum will not allow me to upload.
Perhaps someone with Olympus Elements might like to try replicating the creation of such a custom playback template to see if the problem is not specific to me…
I know I can fix all this by manually editing endpoints etc. I am really just trying to establish why that should be necessary - I thought the whole point of being able to combine playback templates in custom ways was to eliminate that faff!

Then can you attach an image of the template definition? Something like

Here you go:

This is exactly as described in the PDF that accompanies the Olympus Elements playback template, which says that no overrides are necessary (I’ve tried it with and without anyway and it makes no difference).

Have you tried setting the HALion override to Organ or Keyboard?

It’s not a solution for daily use, but it might just help you in this case.

I also notice your Olympus is set to Manual. If you set the Olympus to Auto and also did a singer override, would that help?

I have a workaround - that’s not the issue. I just want to know if what I have found is a bug or if it’s supposed to be this complicated!
‘Auto’ is not an option for Olympus - it’s a manually added template, not a factory default one, which I guess is the reason.

I just tried your file on my system, with a kinda different playback template : mine is Olympus Elements+Pianoteq+NotePerformer.
What I get is two instances of HSSE, one for the section choirs, and one for the solo voice. Each instance has 12 slots already filled, ready to work, even if I only need 4+1. Nonetheless, it works flawlessly without me doing anything, which is the point of using playback templates. I don’t know why your solo voice is allocated to the same slot where the organ is. I’ll try with a different playback template…
With the “same” playback template as yours, I get two instances of HALion, the first one is for section choir, and the organ is allocated to slot 3 there, the second instance is for the solo voice. Again, this is working as intended. Here’s the first HSSE instance :

I cannot upload the file, because it weights 44.3Mo. For the record, my biggest Dorico file to date is 41,7Mo, 375 pages of full orchestra score with over 30 instruments. This one should not be that heavy (one four bars flow, five instruments) ! Maybe the devs could have a look at it?

Thanks @MarcLarcher. I am glad I am not the only one who thinks the file size bloat is strange. If it is of interest, the file was built by importing XML files exported from Sibelius by the composer. I then deleted all of the content to make the samle file that you have been using - couldn’t share the actual work for copyright reasons. Perhaps there is a gremlin left by the XML import?

That is interesting… I thought it was the play part that was responsible for such heaviness. But it doesn’t make sense.

The reason for the large increase in file size will be due to saving the state of the HALion plug-in with the Olympus sounds loaded.

But that huge?

1 Like

Without seeing the project I can’t say for sure, but it’s definitely plausible. If you use Iconica, for example, that will similarly greatly increase the size of your Dorico projects because of the saved states of the HALion plug-ins.