Plugin display

Can anyone tell me how to change the plugin display from the generic state to the user friendly display. I’m unable to find any way to do this. Only the generic version opens when I add a plugin
Thanks in advance

You can try this by opening the plugin and on the top righthand side choose the menu and it should be at the bottom to change to plugin view or it could possibly a graphic bug .
Check the plugin list first
Plugins stuck in Generic view – and no “Switch to Plugin Editor” menu item - Cubase - Steinberg Forums

I just switched back to the previous update (Cub. 12.0.52) and the plugins opened as they would normally. I verified the menu and the availability to switch to the generic option was present.
Knowing that removing the latest update worked - I’ll tempt the devil and reload update.60 … then I’ll see what happens. If the the generic problem returns I’ll try your suggestions. It it’s a no go then I’ll just go back to the .52 update,
I’ll let you know either way what happens

OK I reinstalled update .60 and all is well. the plugins opened in the user friendly view along with the option to switch to the generic option in the menu list.
Maybe just a re-install of the update was necessary.
Thanks for your help FilterFreq - Much appreciated. I will however check out the link you provided just to have a better idea of what else is being brought up.
Thanks again
Daniel. :relieved:

The other option would of been disable your preferences and let Cubase reboot and add your preferences back in manually , i don’t know why but with C12 quite a lot of users have had to let Cubase rebuild the preferences after updating

At least your sorted

I read the link you provided - similar problem but with Nuendo. Their solution was to go into the folders and remove stuff… I’m not comfortable messing in the folders. I’m glad the re-install worked.
Happily back to using Cubase.
Thanks muchly

1 Like