Plugin limit problem,slot remains empty upon loading

Hi everyone!

I couldn’t find similar topic and I hope someone having solved this issue can help.
After 80 or so plugins in the busy project when I try to load another plugin instance, the slot remains empty
like there is a limit of plugins that can be used in a project and it’s not vendor related…
UAD,Waves,Brainworks…doesn’t make a difference…
To make things worse when I reload the same project later, some of the plugins I’ve placed in the beginning of my session ,are missing…empty slot remains and when you’re dealing with such complex projects it is hard to
find where the missing plugin used to be.I only hear something doesn’t sound right and spend valuable time
finding where is the problem…
Funny thing is that some plugins from the same vendor still can be loaded when Cubase reaches this “plugin
limit”.
This huge problem prevents me finishing mixes flawlessly without resolving to mix groups and parallel chains and then go back and forth when need to fix something and that is a drag.
Have any of you had similar problem and if you have a solution please help me?
It would be a lifesaver!!!
I’ve tried writing to Steinberg support for help but no reply.
And BTW resources are not an issue,there is still plenty of CPU power and RAM left.

Cubase pro 8.5
intel xeon E5 2697 v2
32 Gb ram
AMD Radeon R9 200
Asus X79 deluxe
SSD Samsung 850

Hi just today I experienced the same issue. Went to load a session to make a change and noticed it sounded different. My slots are missing plugins just like you.

Earlier in the day I was working on a different project can couldn’t load any new ones either. Somehow this issues seems to have affected my old project too.

Did you find a solution?

Do you use Slate plugins by any chance? Just today I installed the new VMR to check out their new modules and this is the same time it started to happen.

I did notice that if I load earlier versions of the project some of the missing plugins load. For instance on my Aux channels they come up fine in the old project but missing in the later versions (possibly due to more plugins being loaded but they were fine when it was created).

EDIT: I think I found something. I noticed on all my last versions of projects I had exactly 130 plugins on them, as if there was a limit that was pushing out the old ones for the new. But just now I tried loading in more than 130 and it seems to save and load fine…

Ok now as I rebuild this project using saves FX settings from the old I see a limitation again. FX chains that have say 4 effects only loaded 3. If I removed some plugs then it loads more.

I also started to see plugins I just saved in this updated project start to go missing again. The limit seems a little arbitrary, right now I have 137.

there is a limit of plugins that can be used in a project and it’s not vendor related…
UAD,Waves,Brainworks…doesn’t make a difference…

Actually it is somewhat vendor related I think.

Regularly see posts where people say I know it’s not cpu related because I can’t even load UAD plugs etc, etc.
The only other plug I’ve seen blamed was Omnisphere (but guess what…that poster said that with Omnisphere open he couldn’t load his UAD plugs)
So as far as I see UAD is the common denominator here…or UAD in combination with Cubase at least.

Medway Studios…UAD on your system??

Hi Grim thanks, yes I do have UAD and that seems to be main one that’s not loading actually (LX480 was another, think a few more too like Excalibur).

I just made a test project where I loaded up my problem project with about 150 instances in Cubase 8.0.4 and saved from there. It reloads in 8.0.4 just fine, load it into 8.5.15 and I start getting missing plugins again. Load back into 8.0.4 (without saving in the previous step) and it’s fine again.

Memory usage in 8.0.4 loaded project is slightly higher than in 8.5.15 so doesn’t seem to be an issue there.

One weird thing I noticed is I swear sometimes VMR wouldn’t show the VCC modules in the list of available effects, everything else was there. Load up a fresh empty project and it was fine though.

I don’t think this issue is due to the recent VMR update as I realized I saved over the project last week with the missing plugins and just didn’t notice it at the time. This was before I even installed the new VMR so probably not due to that.

Next I’ll try creating this on another install of Cubase (laptop) without UAD and see if I can get it to happen with other plugins (plus the older VMR).

exactly the same issue. :confused:

https://www.steinberg.net/forums/viewtopic.php?f=226&t=77564

Thanks, no one there posted missing plugins on project load, however. Seems all related, though.

Is 8.0.40 ok for you?


Btw I compared the two versions today and confirm it’s some UAD plugs (API560, VOG, Cooper Time, Fatso, and Dim D - I have others like the LA2A collection that loaded fine), Soundtoys Echoboy (didn’t test others), Excalibur, and LX480.

Unfortunately, ver. 8.0.40 is not ok I even tried to go back to ver. 7.5.40. and it seems better than 8.0 and 8.5, but after some time I end up with the same issue. I am wondering if its really related to UAD plugs?!

Thanks, yes unfortunately I still have a problem in 8.0.4 but it seems a little better. Now all my UAD plugs are loading but one instance each of Echoboy and Excalibur won’t load. This is with 136 plugins total, I’ll try rendering some tracks to see if it helps.

I might try using VRM more since I assume it only counts as one plugin. Render in place seems to be the best bet to reduce plugin count later on too.

Noticed another related issue with this today. In checking full project I noticed if I added a C1 or Cubase compressor to it and engaged the sidechain that the receive was not available to send to.

Engaging SC on a pre-existing instance of either would work. I had to render some tracks to free up “plugin spots” before it would start working again.

I’ve noticed that mostly ‘heavier’ plugins are causing the issue…
I had the same problem with my last PC and it started with CB 7…As far I can remember 6 was OK. Some windows process must have reached limit even it’s not showing in performance monitor…
When I load enough plugins (80-100 or so) not even offline processing of some plugins are possible.It won’t open plugins GUI.For instance UAD’s EMT, AMS and Soundtoys regularely…
It also doesn’t make a difference VST 2 or 3…
The only plugins always loading and are not lost are Steinbergs…
When I lose plugins after loading the project ,first plugins to disappear are the ones on FX channels…
My friends working in PT say that issue never happens to them so my guess is it has something to do with Cubase-Windows interaction.
Or another food for thought…Any of you have some 32 bit plugs bridged?It probably has nothing to do with this but who knows,I haven’t tried using 64 bit only exclusively.Just want to go through all possibilities.

As medwaystudios brought to our attention there’s similar topic going on
“Insert plugins don’t always load”
viewtopic.php?f=226&t=77564
It doesn’t deal with plugin disappearances so we should merge these two for as much brain power we can get.
Thank you all for responding and trying to find solution.

Just remembered trying to full Cubase when it reaches this plugin limit I’ve loaded a chainer in a slot and loaded a plugin there but to my unpleasant surprise it did nothing but crashing Cubase…

Thanks for the further info. I think I mentioned before but yes it seems my Aux channels are the ones that get removed first. I haven’t had any problems with GUIs loading, however.

I do use around 10+ bridged plugins using jbridge too.

Well the one silver lining to this issue is that it made me check out the built in EQ more seriously. Now using it in place of some other 3rd party ones for general clean up duties so this should help out my overall plugin count.

Had this happen today with only 49 plugins using 8.5.40 unfortunately.

To be rather blunt, I doubt you’re going to progress this any further just posting here about further occurrences without adding any further useful info or evidence to help confirm the cause.

Have you tested without UAD?

Hi Grim, well initially my count problem was happening around 130-140 plugins, 49 is quite a bit lower which is why I added this entry as it seems it’s not even close to a hard number that I initially suspected.

But yes, I will try removing UAD next time and see how many more new slots that will free up. Only issue with that is I’m not really prepare to mix without them but I guess it’s good to at least know either way to perhaps pinpoint the real cause.

Exactly…I’m not asking you to give them up…if you can run test projects with unlimited plugs by not using them then you have evidence they are at fault (or at least in combination with Cubase) and should request that UAD look into it.

Good call Grim. Opened up my test project today and removed one of the UAD plugs. At that point I could keep adding other plugins fine.

I also noticed that if I opened more instances of UAD plugins already loaded this did not affect me being able to load more 3rd party plugins.

Once I added more 3rd party plugins I also lost the ability to load back the UAD plugin I removed.

There seems to be some limit then to where I can either have one more UAD plugin but no more 3rd party ones, or the other way around.

With a fresh project, however, I could add as many plugins as I had DSP for without affecting my 3rd party plugins. So there does seem to be some link between the total number of plugins and how many UAD ones set this off.


I’ll give UAD support a shot and see what they come up with.