Plugin sizing/re-sizing issue in Cubase 12 Pro

Windows 10 - everything up to date
Cubase 12 Pro (NB - exactly the same issue arose in Cubase 11 Pro)

Issue: when I open some plugins (see below for an example) the plugin display is cut off. I can’t then re-size it as the resizing option does not appear.

I’ve posted screenshots of the following:

  1. My Windows display settings. These are not going to be changed as they suit me for all the other things I do on this PC, including in particular my day job.
  2. My Cubase General preferences.
  3. SSL Native FlexVerb plugin screen, showing how the plugin display has been cut off at the bottom and on the right.
  4. No resizing tool available in drop-down menu.

Any idea how I can get to see the full plugin display?

1 Like

Same here.

This might solve your problem. Right click on Cubase 12 icon and select properties. Then follow the highlighted red rectangle boxes in examples below

Hi @CWS and thanks so much for your response - it’s very much appreciated.

Your method does indeed solve the issue of the plugin GUI, but at the expense of screen resolution of the Cubase Window. I’ll try and explain what I mean.

I spent a little time last year trying to get Cubase to display at a resolution which I was happy with. See my post here: (Cubase Pro 11 screen resolution issue following upgrade from Cubase Artist 10.5)

So in my screenshot of the Cubase window in my initial post above, I have good resolution with lots of legible info on the screen.

Having changed the properties as CWS said, I do get a full version of the GUI. So, congrats to CWS, that is a solution.

But I lose the overall screen resolution I had before.

So the issue is now slightly modified - how can I retain my windows scaling and Cubase HiDPI settings and see the full plugin display?

If you can solve that one, @CWS (or anyone else), you will earn my eternal gratitude!

So you can see what I mean, I have re-posted screenshot 3 above, which shows good Cubase window resolution but with the plugin cut off and, for comparison, a screenshot which shows what happens when I did what CWS suggested, ie poor Cubase window resolution but full plugin GUI. (In one of their least helpful service responses, Steinberg denied that there was any difference in resolution, so let me say that the scaling I had was, for me, perfect. You can confirm the difference in resolution by counting the number of bars along the top - all I did was change the properties as CWS suggested.)

Morning, folks - does anyone have any bright ideas about this issue?

Looks like I’m stuck with either my preferred screen resolution OR full-view plugins, but not both.

Which is a shame and/or some form of zen test for me…

I just bought a UHD monitor recently and I didn’t know all these settings, so I tried the same as you did.
The result is very plugin dependent, it seems. There are some plugins that resize and scale perfectly fine, some just stay the same, and some show the behavior that you experienced- scale the content, but not the window.
No further ideas, sorry. Might be possible that it is a problem with the plugins themselves?

1 Like

Hi @fese - thanks very much for replying.

Yes, I think you may well be right about this - it could just be that different plugins behave differently under different conditions. It’s just too bad that I got my screen resolution to exactly where I wanted it!

What happens if you set the “Application Scaling” to “Windows Scaling Setting” in Cubase Preferences?
This will of course make C12 UI appear a bit larger, but could be a way to test if the plugin has a problem with HiDPI…

Thanks for replying @Area52 (great name!) - yes, I will try this - it may take a while to work out which plugins behave in particular ways. I find the larger Cubase UI more of a pain than some I think.

We do not recommend using this trick as it usually brings more problems than originally. Better use the application scaling preference in Cubase’s Preferences.

Thanks for your report!

Have you reported this to the VST manufacturer? This seems like they do not handle HiDPI interfaces provided in VST3 correctly at first sight. Let me know what they answered!


I just tried Armand’s suggestion with no success. I increased scaling to +25% and all that changed was Cubase was larger. I don’t understand why Toontrack and Izotope plugins for example don’t scale properly. The only way I can get these to scale properly is by doing the above setting I mentioned.

I’ve asked SSL and will let you know…



there seems to be a misunderstanding. The trick is the wrong way of forcing the rescaling of Cubase.I mean only you can assess whether this solution is more stable on your system but we do not recommend it.

If your Cubase is either too small or too big you should use the aforementioned preference.
If you are choosing +25% you are asking Cubase to be 25% larger than the scaling factor set in your Windows preference. This is what is expected.