POSSIBLE CAUSE: 'Missing: Input x' when enable disabled track

This seems to be an old issue, apparently ‘solved’ before but still very alive in 9.0.20 (originally reported here, amongst others.

I just found out that the numbering of the VST Instruments changes when you disable or delete VST instrument (tracks). If you have 3 VST instruments, and you delete #1, the system will change #2 into #1 and #3 into #2, in order to keep a consecutive list.

This is not a problem, because the links between midi tracks and VST instruments are also being updated. The problem is this only happens for ENABLED tracks, NOT for disabled tracks. So if VST3 has midi tracks linked and was disabled at the moment I delete VST1, the system changes VST3 into #2, but does not update the links to the VST instrument in the disabled midi tracks. So when enabling them again, the midi tracks linked to VST3 still expect #3, which does not exist at this point.

So I guess the solution would be: every time when the sorting order (numbering) of VST Instruments changes (through disabling or deleting), the system should update NOT only the VST links in ENABLED midi tracks, but also in DISABLED midi tracks.

I’ve made a short video demo, explaining what exactly happens: https://youtu.be/cXfw39TlOF8 Hope this can be fixed asap.

same here!

Clear reproduction. It’s important to fix this so disabled tracks function correctly.

Because this forum is no longer formally monitored, it might be important to send a bug report via MySteinberg technical support.

Thanks for the suggestion. Just entered a BR via technical support.

Great, thanks for confirming that here.

In case someone from Steinberg IS monitoring this forum: I issued a bug report under #46357

Same here! Please let them know it is important they create TWO different tracks, add some MIDI channels to each, and then disable the FIRST track, to correctly reproduce the issue
It’s so terrible having to select multiple MIDI channels with many mouse clicks just to disable a VST… as we’re nearing 2018, everything HAS to be quick and efficient! Hope this gets fixed soon! :arrow_right:

This has been a problem since at least Cubase 8.0.3, so I’ll assume it’s been like this the features inception. See here:

https://www.steinberg.net/forums/viewtopic.php?t=85264

Still affects expression maps as well. At least in 9.0.3.

So despite what I said before it actually works fine here. Disabled MIDI tracks update as they should in 9.0.30.