Possible to change a single line percussion staff to a 5 line staff?

Maybe it’s because I’m on Dorico 4, but I’m having trouble finding a way to change a single line percussion staff to a 5 line staff. Thanks!

It’s in Layout Options—Players—Percussion, IIRC.

Thank you for responding Dan. I have been looking under Layout Options / Players, but in the middle “players” window, I don’t see anything mentioning “percussion”.
Only when I check the “Uses custom player order” do I see percussion listed, but I’m pretty sure that that’s not what I want. Hate to impose, but is it possible for you to send me a screenshot?

I was mistaken, sorry. The Percussion sub-category will only display if you’re viewing the layout that has the percussion, but I think it has to be a percussion kit.

You could add that percussion instrument to a kit, then it’ll show.

Hi Dan,
Thanks for you help. It got me a little closer…but I’m afraid that as a newbie, I’m kind of over my head here. I didn’t realize how complicated it was to just have, let’s say, a concert bass drum on it’s own 5 line staff! But thanks anyway. I appreciate it.

I understand it’s a little bit of fiddling, but it’ll work. And percussion kits are very powerful. And—in my opinion—pretty easy to use.

Forgive me asking, but why would you want just a single drum on 5 lines of score real estate?

1 Like

Fair question. It’s really just because I’m a newbie and getting lost in this creating a percussion map business. It’s not for small minds like the one that I own, apparently!

Don’t be discouraged, Mark. What playback device are you using? If you’re using one of the devices for which a playback template is provided (e.g. Dorico’s built-in sounds, or NotePerformer) then it shouldn’t matter whether you use a single-line staff or a percussion kit shown as a five-line staff: Dorico will still play your bass drum correctly.

The steps to turn a single-line bass drum into a kit should be as follows:

  1. Go to Setup mode, and select the player in the Players panel that has the bass drum assigned.
  2. Right-click and choose Combine Percussion Instruments Into Kit from the context menu.
  3. You’ll notice that the blue label for the bass drum changes from blue (indicating an individual instrument) to green (indicating a kit).
  4. Now open the Layout Options dialog, and on the Players page, choose the Percussion sub-category, and you should now see the name of the player shown there, allowing you to choose the five-line percussion presentation type.

For more help on combining individual percussion instruments into a kit:

For help on changing the way a percussion kit is presented in a layout:

1 Like

Thank you so much for your help here. Very clearly explained, which is very much appreciated.
I’m using BBCSO using the percussion map. It seems to be working except for one thing: I can play in a bass drum part (D2), but I don’t hear any sound. I only hear the sound of the bass drum on playback. Is there a way to hear it on while recording the part?

I’m not sure what might be going on there, as I don’t have or use BBCSO myself, but I’ll ask my colleague John, who created the playback template for BBCSO, what he thinks might be going on.

Excellent! Thanks!!

(I too get lost in percussion maps! That’s probably because I use them so very rarely, and I never really had to learn)

For me it’s like going back to grade 12 chemistry class. Makes my brain hurt.

Hi Mark. I’ve tried on a BBCSO rendered file of mine, and I find that the bass drum part is audible both when clicking a note and when playback is launched. Would you mind sharing your file (or a tiny bit of it) so that we can see what can go wrong? I use BBCSO pro but there’s no reason it should not work on the two other tiers of this instrument library… As far as I know, the expression maps are not so different from one to the others.

Percussion Map test.dorico (1.3 MB)

Hi Marc, thanks so much for looking at this! Just to be clear, I do get sound upon clicking a note, and on playback. It’s just when I play it in on a midi keyboard, I get no sound at all.

Thanks. Opening the file, it tells me it’s been created in Dorico 4.0.30… Is it intentional that you don’t have Dorico 4.2? There are some useful additions and bugs have been solved. Just sayin’…

Now that I’ve tried you file (I had to reapply the Playback template), I see that the only way to use the keyboard (at least with my 5 octaves keyboard) is to use the Preference>Note Input>Percussion Input >Use staff position, because of the way the percussion map is built. Too many instruments share C3 (and you have to add a keyswitch that is not available on my keyboard). When I built the Spitfire percussion library percussion map for Dorico, I made sure that every technique of every instrument was available with one discrete key (except for mallets options or snares options). In any case, I can input the bass drum playing C3 with that option on, but don’t hear the instrument when I input it with the keyboard. I would probably not use that technique to input notes though, I find the caret and the Y key to be fully satisfactory. But I understand you’re wondering why it’s behaving like this, and I share that curiosity!

I’ve had a look at this file too and I’m not sure why it’s not working as I expect. @Mark_Korven1 could you update to v4.2 and then try it in a new project and see if the problem still persists please?

For what it’s worth, I am using 4.2 and couldn’t get the bass drum to sound when inputting it with the keyboard…