Possible to retain midi file names for Parts?

Currently if I drag a MIDI File onto an existing Instrument Track the resulting MIDI Part gets named the same as the Track instead of the filename. Is there anyway to get it to retain the file’s name? I don’t see anything in Preferences (doesn’t mean it’s not there) which is where I’d expect.

As a workaround if I don’t drop the file onto a Track it will create a new Track & Part both using the filename. I’d rather avoid creating a bunch of unneeded Tracks that will only get deleted.

Following!

One advantage of using a rack instrument. Then when you. “As a workaround if I don’t drop the file onto a Track it will create a new Track & Part both using the filename. I’d rather avoid creating a bunch of unneeded Tracks that will only get deleted”. Just output it to the rack instrument.

Except having a MIDI or Instrument Track play the Part is not what I want to do. I just want to get bunch of MIDI Parts into Cubase each with their own unique names so I can tell them apart. But I’m not looking to initially play them once they are in Cubase. That will happen later in the workflow.

Also when a new Track does get created the MIDI Part is put at the very start of the Track - generally not where it is wanted.

Finally i can help you too as you helped me in the past. :smiley:
Preferences>Editing (at the Top)>Parts get Track Names (untick it). Screenshot attached.
Hope that helps. :wink:

Yeah you’d think. But that has been unchecked for ages on my DAW. I tried enabling it and drag and dropping a MIDI Part takes the Track Name. Disabling it again also ended up having the Part take the Track Name. :question:

This is an area where having the program behave the way you want it to is very helpful to workflow, and having it behave opposite from your wishes is a real drag!

I note also that one may want different behavior at different times.

Therefore, I would like to suggest having 3 options (settable in Preferences):

  1. Incoming MIDI parts get Track Name
  2. Incoming MIDI parts get their File Name
  3. Incoming MIDI parts invoke a dialog which allows either 1, 2, or a custom typed name

Strange!!! I did check it and it works on my machine. I will make a video…

That implies there is some other setting that comes into play.

So i did a video about this setting.
If this is the behaviour you want and it don’t work for you @raino, then try to trash preferences or safe start or re-install.
I tried this in Windows and Mac.
Here is the video: https://www.youtube.com/watch?v=ujPsm7D4hCY&feature=youtu.be

Video not available (?).

Likewise.

Sorry i made the video private on mistake.
New link.
https://www.youtube.com/watch?v=ujPsm7D4hCY&list=PL_WvsLtaYP2YsvR6BOQVcNhY0xKS-e7lK&index=6&t=0s

Did you try it on MIDI tracks as well?

No. Let me try now…

edit: OK i did try it on midi tracks and its not working like raino said.
Its for sure a bug.
A good workaround is to drop the midi file on a blank space so it keeps his name.

Interesting. I notice when you have “Parts Get Track Names” checked that when you initially drag the external MIDI file onto a Track it retains its file name. But then when you move it to another Track it changes from the file name to the Track name.

As you can see in the attached it never keeps the file’s name and always changes to use the Track name even though “Parts Get Track Names” is unchecked. This again makes me suspect there is something else that controls the naming when dragging in external files, while “Parts Get Track Names” controls the naming when moving a Part between Tracks.

so it makes no difference whether it’s a midi or instrument track, eh?

I did some extensive tests. I did drag some other midi files and the behaviour was different like on my first video. So i exported my own test midi files and it turns out that the midi file holds its track name from which you are exporting (see video below) when parts get track names is unticked.
So for me the conclusion is: that the type of midi file and the program it was created does play a role to all this but it does not hold the midi file name.
Some of them acted like on the first video.
Some of them kept their name on midi track too.
Some of them took the track name.
Very strange. :confused:

https://www.youtube.com/watch?v=jgDnv4K6Dy4&list=PL_WvsLtaYP2YsvR6BOQVcNhY0xKS-e7lK&index=7&t=4s

Based on the video I’m leaning towards Cubase having Alzheimers - that is totally strange. I literally jumped out of my chair when the Part started getting the name of a totally different Track.

All the midi files I’ve been using were created by dragging a Cubase MIDI Part out into Windows.

The midi file holds his channel/instrument name from where it was exported.
If you look closely MIDI file pliktro1 was exported from channel test1. pliktro2 from test3 and pliktro3 from midi 2.
And then when I imported them back they kept their channel names not midi file name not the part name.
All this is weird.