Printing Booklets

There seems to be a problem with printing booklets. The pages come out in reverse order so that you have to re-shuffle the pages into the correct order afterwards. This is impossible to deal with if you are printing a large run of booklets. I have looked for options that might change this behaviour, but cannot find any that make any difference. Am I missing something? Transferring scores via xml to Sibelius,which handles booklet printing fine is not an option, because xml export from Dorico to Sibelius misses out vast quantities of important information like articulations and many other score markings. Any help or changes possible ?

What kind of printer do you have? Does it have a duplexing feature? I guess not, if you need to shuffle the pages manually. You should find that you can simply take the stack of paper out of the printer, flip it over as appropriate for your specific model, then feed it back in, and Dorico will then print on the other side. If you have e.g. an 8-page booklet, the pages will come out with 8,1 first, then 6,3; the program will already be telling you to flip the paper over and click OK, so flip those pages and then put them back in: you should find that it prints 4,5 and then 2,7.

Thanks for your reply Daniel. I use a Brother HL2130 Laser printer and as you say, flip the pages manually as the program demands. The problem is, that although the pages are all printed correctly, they come out of the printer with the first page at the bottom and the last page at the top, so that you then have to put them in the right order manually to make sense of it all. Booklet printing in Sibelius does this correctly on my printer, which is important as we often have a big run of booklets to produce for a choir. I have been enjoying writing in Dorico and am impressed with what you have done so far, but this printing problem is proving a bit of a stumbling block until I can resolve it. Thanks for your prompt attention.

I’ve done a bit more delving, and I find that Sibelius does it’s booklet printing in the reverse order. For instance a 9 page booklet prints in the following order. 8-5, 0-3, 0-1,6-7,4-9,2-0 which results in the booklet being presented in the correct order. In other words, page 1 should not be printed first in the sequence but last. If you were to print 30 booklets in one go as things stand, it would in an unholy mess ! I wonder if anything can be done?

Daniel, mjhealey is correct. I tried a little experiment with printing the Full score in DoricoOverture demo file and Dorico prints booklets fine using duplex printing (where both sides print automatically). But when I tried to print the same booklet part using the “Both sides manually” option and flipping them, the pages are printed correctly, but sequenced backwards, forcing the user to manually reshuffle all the pages before folding or binding. This would be fixed if the pages were printed in reverse order for non-duplex printing i.e. in the example I am talking about this would work: 12-13, 10-15, 8-17, 6-19, 4-21, 2-0 (flip the pages), then 14-11, 16-9, 18-7, 20-5, 22-3, 0-1.

What Dorico prints is: 0-1, 22-3, 20-5,18-7, 16-9, 14-11 (flip the pages), then 2-0, 4-21, 6-19, 8-17, 10-15, 12-13. The result is a correctly printed booklet that needs to be resequenced before being bound or folded.

Yes, I have been looking into this here today and I agree with your assessment, and that of mjhealey. We’ve fixed the problem now, so a fix will be available in the next update.

:wink: Thanks Daniel! You are so quick! (What kind of coffee do you guys partake in or is it tea on that side of the pond)?

Thanks very much Daniel. Much appreciated.

mjhealey, in the meantime, you’re probably best exporting to PDF and printing your booklets using Acrobat Reader or one of the hundreds of other free PDF printing applications out there. Much simpler than XMLing to Sibelius and doesn’t require any tweaking at all!

Instructions for booklets with Acrobat Reader here: https://helpx.adobe.com/acrobat/kb/print-booklets-acrobat-reader.html

1 Like

Thanks for that pianoleo.

I seem to be having this problem again: booklet prints in reverse order. I’m using an Epson 2100 A3 printer, duplex printing set to “both sides manually”. My score is 24 pages, plus (unnumbered) cover page and a blank. It prints (A3 landscape) in the pair order 14-11,16-9,18-7,20-5,22-3,24-1, blank-cover, 12-13,10-15, 8-17,6-19,4-21,2-23. Obviously I then have to reverse the stack order afterwards. I would have expected it to print in the order blank-cover, 24-1, 22-3 … 14-11, then flip to print the rest, ending with score in correct order. Can’t find any “reverse page order” switch that might have been on by mistake. Am I missing something?

MacPro 2013, MacOS 10.13.6, Dorico 2.

That’s very odd, since we fixed this back in 1.2.10 to make sure that the order would be correct. I’m afraid I’m at a bit of a loss as to what could be going wrong for you.

There is a “Reverse Order” setting in MacOS’s print dialog, under “Paper Handling”. It’s possible that this may have got stuck on in your print preset or default.


Screen Shot 21.png

No, my standard black preset has the page order as “automatic”. Made a new preset with this changed to “normal”, just in case, but it doesn’t seem to make any difference. Although I’m not clear how the Mac print dialogue and the Dorico one interact, as my booklet is clearly printing on to A3 landscape without this showing up in the Mac dialogue. Hmmm…

The reverse print order shows up straightaway, incidentally; it’s clearly visible as soon as I go into Dorico’s Print (Printer) window.

PS Is there any relevant preference file I could edit or trash?

When I try to print a booklet, I notice that the order of pages displayed in Dorico doesn’t change when I change the Duplex options, until I change the job type to Normal and then back to Booklet again. Only then is the page order corrected.

Yes, I’ve tried changing job type to normal (and all the others) and back to booklet, after changing duplex options. Makes no difference; whatever I do, range always starts with pages 14 + 11.

OK, I’ve now tested this with several lengthy files, including the attached garbage test file (20 pages). With job set as “booklet” and duplex set as “print both sides manually”, it always gives me pages paired in reverse: 12-9, 14-7, 16-5, 18-3, 20-1, 10-11, 8-13, 6-15, 4-17, 2-19, resulting in a final stack that needs re-sorting. Does anyone else get anything different?

As said previously, my print preset definitely does not contain a “reverse print”.

I don’t mind being told I’m doing something stupid, I’d just like to know what it is.

Garbage booklet test.dorico.zip (693 KB)
Mac Pro 2013, MacOS 10.13.6, Dorico 2.

I’ll start a new thread on this because the old one isn’t getting any response.

Could someone - anyone - please load the attached file into Dorico and see if booklet printing shows in a sensible order?

When I do it (or load any other multi-page file and set print job to “Booklet”) I get the page pairs in reverse order: 12-9, 14-7, 16-5, 18-3, 20-1, 10-11, 8-13… etc This means the final stack has to be re-sorted into correct order. I’ve set print job to “Booklet” and duplex to “Manual, both sides separately”. My print preset does not contain any reversal.

If the test file gives sensible results for other people, then something is wrong in my system. If not, then the reverse-print bug which was fixed in 1.2 is un-fixed again. Surely I can’t be the only person who finds this important.

Garbage booklet test.dorico.zip (693 KB)
MacPro 2013, MacOS 10.13.6, Dorico 2.1

Starting a new thread because your previous post hasn’t yet yielded responses is seriously frowned upon here. It’s also a breach of point 4 of the Forum Etiquette here: https://www.steinberg.net/forums/ucp.php?mode=terms

Rest assured that at least one person on the development team reads every single post on this forum. That means that a) you will get a response when (as soon as) they’ve got something useful and b) you’re wasting their time as well as your own, and you run the risk of waiting longer for a response.

In the time it’s taken me to write this post, I could’ve taken a look at your problem, but I’m out of time now.