Problem with displaying note helper in VariAudio

Hello everyone and I want to report a new problem again and it is again related to VariAudio, no one solved my first problem and I noticed several people with a similar problem, it is here:

But I also have another problem, it did not appear over time, but was originally and this problem was not solved with updates.
The fact is that the notes assistant does not work in variaudio, the video clearly shows how I switch between notes, change modes and do a new analysis, nothing helps. Tips like “Restart the program” please don’t, I’m a longtime cubase user. I worked for about 5 years in cubase on windows and there is no such problem, as soon as I moved to mac m1 a large number of problems appeared that did not help to solve. I will be very grateful for help

Link to video

The video clearly shows as soon as I turn on the assistant from behind, the musical grid becomes the same color, but it should highlight the notes that are in key and which are not in key

1 Like


What macOS version and what Cubase version do you run, please?

I know, you asked for not providing help like restart, but… Could you try in the Cubase Safe Start Mode [Disable preferences], please?

Or could you try to rename all Cubase preferences folders to get the fa story settings? Cubase Preferences folders are:
Mac: ~/Library/Preferences/Cubase X
Win: %appData% Steinberg/Cubase X_64

The fact is that I literally freaked out a couple of days ago) and completely deleted cubase with all folders and settings and reinstalled, but nothing has changed.
On your advice, I just started in safe mode with disabled settings, but the problem remained, nothing changed


Btw, it works for me here on macOS 13.1, Cubase 12.0.60.

I have Cubase Cubase 12.0.60. macOS 13.1

Do you have the same problem??

If it is solved in such a way as you wrote, then please tell me in more detail how you do everything, but I seem to have done everything as you said.


No, I don’t have the problem. It works as expected on my side.

Vari audio doesn’t work as expected on my Brand new M1 Studio - OS Monterey in Native too.
I also have a different topic which explain clearly the issue. But it never has any reply from mod or admin.
I also figure out some other users, included Obrazcov, are facing the exact issue, so I bet this is not my own problem.
Due to this, I still can not run Cubase on Native mode. All my plugins are M1 Native supported.
On Rosetta 2, Variaudio works perfectly.
My M1 Studio just has Audio and Video software, and all of them are Licensed and up-to-date.
Should I upgrade my OS?
Thank you.


I never use scale assistant as I am a Piano player. However, it’s exactly what you explain, I see no different from the events (highlights ect…) when trying scale assistant.
I have no idea what is right cause I never have to use it.

This happens on Rosetta 2. Native? I have no idea cause I still can not use Vari Audio on Native.

There must be something happens to our Mac… Unbelievable.


I’m using Cubase 12.0.60 in the Native (Apple Silicon) mode at my M1 MBPro. And VariAudio works as expected for me, including the mentioned GUI issue.

Works fine on my M1 Macbook Air

And so I also want to solve why everything normally works for many, and at me is not present. Despite the fact that similar problems as I found on the forum. macbook new, all plugins and cubase only license, all new updates cost. Very strange