Problem with dynamic (mp>)

Hello,
I would like to have dynamic, like in the first bar:


But in the second bar Dorico allowes me to put „mp” or „dim.” to the second note, but I can’t have it both, like in first bar. I tryed to untie the notes, but the result is the same. It seems, that quater note is to short for Dorico to put „mp” and then „>”. It works with half note.

Any idea how to do it properly?
I read this topic, but it’s not working:

Go into Write mode, move the input cursor to the 5th quarter (of the second bar), type a ‘>’, move the cursor with the arrow keys to the next bar and press ‘>’ again (Don’t enter the ’ sign :slight_smile: ). Now the desired diminuendo should appear.

Dear felixp,
Thanks for this tip, I didn’t know it could work like this. What I usually do starts like you : put the caret where the hairpin should start, press > and then select the rhythmical length of the hairpin (here 6) and press the space bar once. I think both methods have their advantages :wink:

Dear Marc,

thanks for the hint. I didn’t know that your way is possible too.
Dorico is like a fountain with each day a new surprise / feature :wink:
I have never used really so far the Engrave mode. I am still in entering a huge old film score. I am looking forward what will come then :wink:

Regards, Felix

Hello,
I am doing something wrong, because it’s not working in my case. When you are saying „type >”, you mean with shift+D popover? Could you explain it once again step by step, from the point, where in the second bar there is no dynamic mark at all?
I acheved my example in that way:

  1. I press shift+D in first note (second bar)
  2. I type „”
  3. Everything appeared, but „mp” was on 4th quater.
  4. When I moved manually „mp” to 5th quater, the diminuendo dissapeared.

No, we’re talking about a very fast input method. Make the caret appear at the beginning of the hairpin. Press the < or > key. Select the rhythmical value (or a small value that can be added various times). Press space bar as many times as necessary.
Once the hairpin is input, if it is not grouped with other dynamics you can very easily lengthen it or shorten it using the alt-shift-arrow trick (according to the rhythmic value of the grid.)
Hope it helps !

But still I can’t have the proper result. I can’t have “mp>” in last quater of second bar. I have “mp” or “>”, but not both.

Here are the steps that work for me.
Enter the notes

Move entry point to beginning of crescendo
Type Shift-D < return
move to where you want the crescendo to end
Type < Shift-D mp> return
move to where you want the decrescendo to end
Type > return

Dear Del-Gesu,

Here are 2 ways to do it:

The method Marc and felixp are talking about:

  1. Double click at the beginning of the 5/4 bar to show cursor.
  2. Type Shift-D
  3. Type <
  4. Press the Enter Key
  5. Use space bar or right arrow key until caret is at the 2nd note position.
  6. Type Shift-D
  7. Type mp>
  8. Press Enter
    (Marc’s method follows):
  9. Press space bar
    10.Press Escape

(felixp’s method)
9. Use the right arrow key to get to the next bar.
10. Type >
11. Hit Escape

Another method, manually moving the mp later is:

  1. Double click at the beginning of the 5/4 bar to show cursor.
  2. Type Shift-D
  3. Type <mp
  4. Press the Enter Key
  5. Use space bar or right arrow key until caret is at the 2nd note position.
  6. Type Shift-D
  7. Type >
  8. Press Enter
  9. Press spacebar
    10 Press Escape
  10. click on the mp and drag it to the right to the 2nd note position
    You should notice that the hairpins adjust automatically

With gradual dynamics such as hairpins, Dorico needs to know how long to continue them. The length of the item is more obvious when using the spacebar, because Dorico draws and lengthens the item each time you press spacebar. Using the cursor method of telling Dorico how long to make the item, you don’t get this feedback (which I think would be helpful and more consistent).

Thank you for detailed explanation, but it still don’t work.
I am ataching the video. It’s Marc’s method, but any of this method works.
mp.zip (1.13 MB)

Can you just type all at once in to the popover? It works for me as shown in the attachment. Does your method work in Page View? I’ve had the word “gliss.” not show in Galley View because there wasn’t additional spacing made automatically by the program. Perhaps that is why the last > is not showing (just a guess here). If you find out it works in Page View, but not Galley View, please let us know so the Dorico Team can be apprised as this would not be a good thing.
Screen Shot 2018-03-23 at 11.36.33 AM.png

I’m sorry Del_Gesu if I did not really answer to your specific question.
I would like to show you how you can achive the result you want with a very high flexibility.
Make sure the grid is on quarter note or shorter.
Invoke the caret at the beginning of the bar.
press <, and press space bar four times (or more if the grid is smaller.
Press shift D (the caret should now be on the quarter note tied to the whole note) and input mp. Press enter. Press > and press space twice. That’s it.

Del_Gesu - probably the easiest way to do this is to simply click once on the tied note, then (without showing the caret), type Shift-D, then . Because Dorico has the information about where to start and end, it will put things correctly. If you want to move the mp a little, just click it and drag to the right and it will snap to the beginning of the quarter note. It is really great that Dorico offers different ways to achieve this, and learning both methods is really useful.

Check out how easy this is:

https://www.dropbox.com/s/898z8hyo8of8qbx/dynamic.mov?dl=0

This is the point! „Dim.” was all the time there, but I couldn’t see it in Galley View. I didn’t check this simple thing and switch to Page View.
Thank you, musicmaven, for this cue and thank you all of your help.
So, this is a bug.

When you’ve entered the last mp> hit the right arrow once or twice (depending on the grid setting) and finish off by typing a question mark. That somehow makes Dorico give some space to the hairpin…

It gives the space, but hairpin don’t appear.

Did you enter ‘mp>’ on the last note?

Yes. It seems, in my particular situation the bar spacing is so specific, that Dorico can’t add in Galley View the space necessary to display hairpin. As I said, after Your advise there is additional space before the barline, but still I don’t see hairpin.

So now the Dorico Team is aware that certain objects might not display in Galley View, even though they are "there" because of extra space not being given to an inputted item. Page View does not seem to have this problem because (I assume) other processing regarding spacing is made.

On my system, in the OP’s case, D behaves identicallly in both Galley and Page view …