Problem with imported MIDI file and external VSTs

Okay, brand-new to Cubase. I have some MIDI song files dowloaded from the usual web sites, and just tried importing one of them that has multiple tracks. They all came in as instrument tracks.

I was able to assign instuments to the first three tracks via the SampleTank VST, but not for any of the rest (there are about a dozen). The tracks are silent. If I assign them instruments from HALion they play just fine. I can go in and pencil in new notes around the old ones in those tracks, and those new notes play fine from SampleTank (or Independence or Kontakt) but the imported notes are simply ignored by my external VSTs.

Has anyone encountered this problem, and is there something in the import settings that can mitigate it? I’ve even tried copying a track and pasting it back in but that didn’t help.

Thanks in advance!

Check your preferences under MIDI - MIDI Files and uncheck “Import to instrument tracks”

Thanks. I just tried that, now I have everything in as MIDI tracks instead of instrument tracks but now I can’t seem to be able to assign any instruments to any track, HALion or otherwise.

Any ideas?

Would it be something to do with the midi channel that the track is set to? Some instruments only receive on channel1, other all channels, others have multiple channels - i.e. check the channels for each voice if you’re using a preset.

Mike.

Actually, just thought of something else. I’ll bet the midi channel is set to Any, and the channel for each note within the midi data is set to a channel not being received by the instrument. This explains why drawing in new notes works because they’ll be set to Ch1 by default probably.

Forcing the channel for each track might solve your problem, unless you have more than one channel intentionally on a single midi track. In which case use dissolve part to separate out into multiple midi tracks.

Mike.

Would that explain why I can play those tracks using the built-in HALion VST just fine, it’s only the addon VSTs that won’t play the notes?

Thanks thus far, I’m learning!

Probably… You have to take heed of the midi channel number being sent by the track, and then match that to the midi channel being ‘expected’ by the synth (VSTi).

Then just to complicate things, some synths accept any channel so they always work, some don’t. Sounds like Halion accepts any. Kontact is multi-timbral I think, so each timbre has it’s own midi channel so they can play independently, it will need the right channels.

Then too, you’ve got your ‘Any’ setting on the track inspector. This doesn’t really mean ‘Any’, this actually means ‘use the channel encoded in the note event’. I.e. each midi note has it’s own channel… But if you set this to a channel number then it over-rides the note’s channel and all notes get sent on the same channel number. I generally set a specific channel to save confusion with the midi note channels (which in my case come from different keyboards on different channel…).

Confused? :smiley:

Mike.

In the MIDI editor, there is a “coloring” section. Set it to channel and it will color notes by channel.

Ah, and the first track is probably defaulted to channel 1, so that one worked. I said “first three” in my original post but now that I think about I might have assigned 2 and 3 to HALion instruments. :blush:

Thanks loads! Soon as I get home this evening I’ll check this out and post how it worked.

Okay, I’m confused again.

I went back to importing the MIDI into instrument tracks because when I uncheck the box and they come in as MIDI tracks I don’t see any way to assign VST instruments to them. Reading the documentation seems to indicate that when I want to try out various instruments before deciding which one to assign I want to use instrument tracks anyway. Is that correct?

Now, I have the song imported, it has 18 tracks. I can’t figure out how to tell what channel a given track is assigned to, and I can’t seem to find that specific how-to anywhere in the PDF manuals. Probably just don’t know what I’m searching for. The drum track, for example, is on track 13, and I tried selecting channel for coloration like suggested above but the existing notes didn’t change colors in the editor, and if they did I’m not sure how I’d use the colors to tell me the channel number anyway.

Help?

Thanks in advance!

Might be misunderstanding, but - No, it´s not correct

Doubleclick the MIDI part. This opens the key editor. Select one (or more) MIDI events. Make sure the info line is activated for the Key editor -> (refer to manual). You see info about the chosen MIDI event (Start, length, velocity - and also - channel), no need to do the color thing the track colour is not what was meant anyway, you can check that later. The info line is probably easier and more comprehensive.

Okay, I just have bad eyes. I zoomed the MIDI notes way up and saw they had actually changed colors. At the default size everything looks like a muddled grey to me.

I then found a setup menu at the bottom of the colors drop-down tab that shows the color mapping legend, found the channel for the drum track, and now it works.

Progress! :sunglasses:

Hmm. So should I be importing them as MIDI tracks after all? Can you give me a hint what part of the manuals tells me how to assign a VST to such a track? I tried all the same settings areas where they exist in instrument tracks and nothing gave me a VST selection menu.

Okay, I’ll try more searching key terms to see if I can find how to do this. Thanks.

(Followup) Got the info track, works a treat, thanks.

Still unsure I’m doing the right thing in using instrument tracks instead of MIDI tracks but on the plus side everything seems to be working out well.

Thanks for all the help, guys. I do try to RTFM, but at a certain point info overload takes over and I just have to start poking things and learning by doing. Hope I don’t become too pesky here.

Depending on exactly what you are doing, it should not really matter.

You need to load a VSTi into the instrument rack first, then you´ll get the option to assign a MIDI tracks output to a VSTi. Chapter in the manual would be “Recording->MIDI Recording specifics” and “VST instruments and instrument tracks”

“Thge MIDI Editors->The Key editor - Overview”

You need to understand the difference between the following things

1)Midi Tracks
2)VST Instrument RACK

3)Instrument Tracks
Which is a hybrid of the first two, but only supports STEREO AUDIO OUT and can is controlled by a single MIDI PORT (not channel)

4)Multi-MIDI Channel VSTi (like Sample Tank)
5)Multi-Audio Out (like Sample Tank)
Those are two different issues and both have configuration things you have to do that are different depending on if you use the RACK or the Instrument Track.

6)MIDI Port Assignment
Instrument Tracks only get assigned a port

7)MIDI Channel Assignment
MIDI Tracks are assigned Port & a channel or Any channel

8)MIDI Events

AND Finally, you need to understand how all of those things talk to each other. I’ll post some pictures in a bit that might help. But, go read the Operations Manual about each of the main keywords that I numbered.

When you import a multi-channel MIDI file, it isn’t really to your benefit to use the Instrument Track type. You should import to a MIDI track or explode it to multiple MIDI tracks. If you don’t explode it you can tell what channel notes are assigned to in the MIDI editor by selecting the color dropdown.
6-SelectColoring.png
The other thing to understand is the difference between Instrument Tracks and the Instrument Rack.
F11 bring up the VST Instrument Rack. This is where I think you should load Sample Tank.
1-VST Rack.png
When you add an instrument this way, it will ask you if you want to create a MIDI track …
If you already have a MIDI track from your import, say NO, But, it’s easier just to say yes and it does all the hookup for you.
2-Add MIDI.png
see next post…

The result will be a folder containing your VST Instrument (Sample Tank in this case), and a MIDI Track with Sample Tank assigned as the track output.
3-ST Loaded.png
Now the tricky part … Notice the Channel is set to one. Even though I have MIDI notes responding to 4 different channels in ST, it will only play back channel one this way.
4-OnlyChan1.png
However, if you set the track channel to ANY, each instrument will play based on the channel of the note assignment in the MIDI editor

OH, the note colors in the editor pictures are set to show that there are 4 different channels 1 thru 4.
5-Any.png

OK, now real fancy…

Multiple MIDI tracks running the same VSTi in the rack. Notice each of the MIDI tracks is set to a different channel, but they are all pointing at the one instance of ST.
Multiple MIDI tracks.png
Now, any MIDI event on any one of those tracks will only play the instrument loaded in corresponding Ch. in ST.

Hi,

Just wanted to pitch back in to say that you might find there’s some decent video tutorials about on the web, or even maybe the cubase tutorials on the installation disk? I quite often watch online videos to get a general feel of how things work and what’s possible, they tell you what buttons to push, where they are and what they do very quickly.

Mike.