Problem with M-Audio Oxygen 61!

I recently purchased Cubase 7 and connected it with my Oxygen 61. I could play in notes on the keyboard but couldn’t control any of the faders or any other features. As I am new to Cubase, I didn’t realize I had to download DirectLink as this comes as stock in Ableton, which I have switched from.
I downloaded DirectLink for Cubase and set it up in ‘Device Setup’ with the little ‘+’ button. I pressed play on my Oxygen and moved some of the faders and it worked! I was so relieved… That was until I thought I’d play something in when I got a melody in my head. Everything is exactly the opposite from what it was! The keys don’t affect anything. It registers in Cubase in ‘MIDI In Activity’ but I get no sound!

What type of track? What is the track’s input/output routing?

Is the track’s monitor button enabled?

It’s like that with all instrument tracks. The input is set to ‘Oxygen61’ with the output to ‘Stereo Out’. I never had problems until I downloaded DirectLink. I just can’t understand why a program used to make mapping easier, completely screws everything up :s

What happens if you set the track’s input to “All MIDI Inputs” ?

First things first, you don’t need Direct link to use a midi keyboard in Cubase. Also, as Slim/Scab said above, you need to engage the monitor button on your channel strip that contains the midi instrument, that or press the Record button. He also mention the ‘all midi inputs’, something that typically happens by default but may need to be checked in your case.

Hi perceptic,

I am using the M-Audio Oxygen 61 so if you are still having problems - please reply to this thread and I will see if I can help you out. As far as the use of poopy ‘Direct Link’ goes, it appears that the M-Audio Oxygen 61 drivers you are referring to; namely DirectLink for Cubase 1.1.6.exe were abandoned after the 12/13/2011 so they are clearly out of date and as such it is likely that they are unsupported by any version of Cubase after this point (but don’t quote me on this - but its kinda suspicious)! :open_mouth:

As such, if your installation of the aforementioned drivers worked, then that is surprising as I basically ditched it immediately after discovering it was useless! :angry: I can’t say I like the idea of ‘direct link’ anyway as I feel that workflow is a personal preference and not a generic thing IMO - but at the same time; the said functionality is pretty easy to setup yourself anyway!

So as ‘mr.roos’ has rightfully mentioned there really is no need for ‘DirectLink’ to be installed for you to get any of that functionality working on your M-Audio Oxygen 61 in Cubase 7 as you can just create a generic MIDI remote device (as follows) and set up your MIDI Quick Controls pretty quickly:

Try this to set up your Transport Controls:

1) Download the ‘C7_Oxygen_61_XMLs.zip’ attachment below and unzip. It contains 2 x XML files exported from my own Cubase 7 Setup so that you can mimic the functionality pictured in the attachments. [/i]

(2) Cubase 7 Menu ->> Devices ->> Device Setup ->> Click on the ‘+’ button and add 'Generic Remote’

3) Now select the new Generic Remote device entry in the Device Setup window and click on Import and select 'C7_Oxygen_61_Transport.xml’

4) Make sure that Oxygen_61 MIDI in/out is selected in the MIDI Input/Output dialogue boxes and now all of your transport controls should be working on your M-Audio Oxygen 61!

5) Click on ‘Apply’.

(please refer to ‘C7_Devices_Generic_Remote.jpg’ attachment below)


Try this to set up your Quick Controls:

1) Now select the Quick Controls entry in the Device Setup window and click on Import and select 'C7_Oxygen_61_QC.xml’

2) Again make sure that Oxygen_61 MIDI in/out is selected in the MIDI Input/Output dialogue boxes and now all of your 8 x Quick Controls should be mapped to the 8 x pots on your M-Audio Oxygen 61!

3) Click on ‘Apply’.

(please refer to ‘C7_Devices_Quick_Controls.jpg’ attachment below)

Naturally if you want your sliders working you can select the Remote Device entry again and begin working your way through adding/assigning each fader - but I haven’t bothered with this as I hate the way that the awful short-throw faders don’t map exactly onto the values in Cubase 7 (i.e. they always seem to be either above or below the level you want which is useless :cry: :exclamation: just reach over and grab a mouse or type in it for a more accurate result)! :laughing:

Hope this helps :slight_smile:

Kat

That sorted it out perfectly. Thank you! :smiley:

I guess I was just used to not having to do anything at all to set it up haha

Thanks again! :smiley:

No worries mate,

I’m glad that everything is working for you again! :sunglasses:

Hi perceptic,
Can I make this also working for my new M-Audio Oxygen 49 (2014) model?
Thanks,
Herbert

Are you saying that the only way to get faders working is through quick controls?

I’ve also just switched to Cubase 7.5 from C6, but if I can’t use my faders without having to manually set up QC for each and every midi track, that’s a major workflow killer. Wtf?

Been trying to get my Oxygen 61 working with Cubase 7.5 for several hours now and I finally succeeded, although I could not tell you how or why exactly.

These are the settings I started off with: https://www.facebook.com/photo.php?fb

And these are the steps I took to finally get it to work. I hope this is somehow helpful to someone.

  • Installed DirectLink (now called HyperControl) from http://www.m-audio.com/index.php?do=s
  • Since this installs in the directory “C:\Program Files\Steinberg\Cubase 6\Components”, I had to move it to the proper Components folder (in my case “G:\Program Files\Steinberg\Cubase 7.5\Components”)
  • In the Device Setup in Cubase, I could then add M_AUDIO Oxygen. I set MIDI Input to ‘All Midi Inputs’ and MIDI Output to ‘Oxygen 61’.
  • Lo and behold… it still didn’t work. Nothing had changed. Notes, modwheel and pitchbend worked, faders still didn’t.
  • I then figured, ok, let’s start with a clean slate. I removed the ‘M-Audio Oxygen’ device, and the ‘Generic Remote’ device that I’d created earlier (see screenshot above). I also set the MIDI Input of both the ‘Track Quick Controls’ and ‘VST Quick Controls’ to ‘Not Connected’.
  • All of a sudden, everything works. Every single fader is recognized again, notes still work… Basically I’ve got nothng set up in Cubase at the moment. It just all works.
  • Except for my Transport Controls of course. So I added a Generic Remote again and imported the settings from my C6 settings (it’s now the same way as in the screenshot again), and now everything is working fine again.

It looks like adding the ‘M-Audio Oxygen’ device once and then removing it, somehow taught Cubase how to deal with it. I have no other explanation for it.

Hi,

I also have an Oxygen 49 and would like to know how to set it up like the Oxygen 61.

Thanks,
Tom

@trax4katz
Your included attachments are gone. why?
(Xml file, midi map for oxygen 61)

Could you please please upload them again?
Thanksss

Dear all,

I just had the same problem with my Oxygen 61 (blue) & Cubase Pro 8. I didn’t use the direct link as M-Audio is do not care their clients at all. So:

  1. Unfortunately the forum doesn’t let me to attach an XML file here. So please copy paste the below text in a file and save it as XML:
<?xml version="1.0" encoding="UTF-8"?> ReWind176151141271 FastForward176151151271 Stop176151161271 Play176151171271 Record176151181271 Cycle176151131271 Fader 117615331271 Fader 217615341271 Fader 317615351271 Fader 417615361271 Fader 517615371271 Fader 617615381271 Fader 717615391271 Fader 817615401271 Pan 117615171271 Pan 217615181271 Pan 317615191271 Pan 417615201271 Pan 517615211271 Pan 617615221271 Pan 717615231271 Pan 817615241271 Master Fader17615411271 Mute 117615491271 Mute 217615501271 Mute 317615511271 Mute 417615521271 Mute 517615531271 Mute 617615541271 Mute 717615551271 Mute 817615561271 Mute Master17615571271 Prev Track176151101271 Next Track176151111271 Transport-14018257 Transport-14017257 Transport-140161 Transport-140151 Transport-14019257 Transport-14022257 Mixer1volume0 Mixer2volume0 Mixer3volume0 Mixer4volume0 Mixer5volume0 Mixer6volume0 Mixer7volume0 Mixer8volume0 Mixer1panner:panX0 Mixer2panner:panX0 Mixer3panner:panX0 Mixer4panner:panX0 Mixer5panner:panX0 Mixer6panner:panX0 Mixer7panner:panX0 Mixer8panner:panX0 Mixer9volume0 Mixer1mute256 Mixer2mute256 Mixer3mute256 Mixer4mute256 Mixer5mute256 Mixer6mute256 Mixer7mute256 Mixer8mute256 Mixer9mute256 ProjectSelect Track: Prev1 ProjectSelect Track: Next1
  1. In Cubase go to Menu Devices -> Device Setup … -> Add a “Generic Remote” in “Remote Devices” (Use + sign to add)
  2. Import the created XML file here.
  3. Enjoy it!

That’s all.
:smiley:

THANK you !!! <3 <3 <3

Thank you so much guys, this works like a charm, Kudos to the guy

Basically, all you need to do is install the “DirectLink” Setup from the M-Audio Website, copy the OxygenCubaseDirectLink.dll into the “components” folder of Cubase (if the installer doesn’t do that for you), open up the “Devices” dialogue, add “M-Audio Oxygen” as a remote and set MIDI Input to “Oxygen XX (49,61)” and the Output to “Not connected”. Check “Allow Auto” checkbox and close the dialogue with OK. Then press the “Auto” button on the Oxygen and off you go…

Just did that after upgrading to Cubase 8 Pro, works like a charm.

Hi Masroor, i use Cubase elements 8 for Mac and i own an Oxygen 61 MK IV, can i do the same steps to map my keyboard?
Thank you for your support

Sorry to say, this did not work, so i had to tweak it till i get it correct.
It now works perfect with 3 layers, 1-8. and 9-16, and 17-24. That as far i take it this time.
Easy to expand to more channels.
if you follow the others correct notes until Import, save my notes in notepad, and give name Oxygen61.xml
save it on HD for keep.
Ohh, forgot to say, this is done on Cubase Pro 9, Win7 x64
Best of luck.
Regards, Hans, artist as Pax Greger


<?xml version="1.0" encoding="UTF-8"?> ReWind176151141271 FastForward176151151271 Stop176151161271 Play176151171271 Record176151181271 Cycle176151131271 Fader 11760741271 Fader 21760711271 Fader 31760911271 Fader 41760931271 Fader 51760731271 Fader 61760721271 Fader 7176051271 Fader 81760841271 Pan 11760751271 Pan 21760761271 Pan 31760921271 Pan 41760951271 Pan 51760101271 Pan 61760771271 Pan 71760781271 Pan 81760791271 Master Fader176071271 Mute 17001271 Mute 27011271 Mute 37021271 Mute 47031271 Mute 57041271 Mute 67051271 Mute 77061271 Mute 87071271 Mute Master7081271 Prev Track176151101271 Next Track176151111271 Transport-140180 Transport-140170 Transport-140161 Transport-140151 Transport-140191 Transport-140221 Mixer6volume1 Mixer7volume1 Mixer8volume1 Mixer9volume1 Mixer10volume1 Mixer11volume1 Mixer12volume1 Mixer13volume1 VST Mixer0panner:panX1 VST Mixer1panner:panX1 VST Mixer2panner:panY1 VST Mixer3panner:panX1 VST Mixer4panner:panX1 VST Mixer5panner:panX1 VST Mixer6panner:panX1 VST Mixer7panner:panX1 VST Mixer32volume0 Mixer6mute257 Mixer7mute257 Mixer8mute257 Mixer9mute257 Mixer10mute257 Mixer11mute257 Mixer12mute257 Mixer13mute257 VST Mixer32mute257 ProjectSelect Track: Prev1 ProjectSelect Track: Next1 Transport-140180 Transport-140170 Transport-140161 Transport-140151 Transport-140191 Transport-140221 Mixer14volume1 Mixer15volume1 Mixer16volume1 Mixer17volume1 Mixer18volume1 Mixer19volume1 Mixer20volume1 Mixer21volume1 VST Mixer8panner:panX1 VST Mixer9panner:panX1 VST Mixer10panner:panX1 VST Mixer11panner:panX1 VST Mixer12panner:panX1 VST Mixer13panner:panX1 VST Mixer14panner:panX1 VST Mixer15panner:panX1 VST Mixer32volume0 Mixer14mute257 Mixer15mute257 Mixer16mute257 Mixer17mute257 Mixer18mute257 Mixer19mute257 Mixer20mute257 Mixer21mute257 Mixer32mute257 ProjectSelect Track: Prev1 ProjectSelect Track: Next1 Transport-140180 Transport-140170 Transport-140161 Transport-140151 Transport-140191 Transport-140221 Mixer22volume1 Mixer23volume1 Mixer24volume1 Mixer25volume1 Mixer26volume1 Mixer27volume1 Mixer28volume1 Mixer29volume1 VST Mixer16panner:panX1 VST Mixer17panner:panX1 VST Mixer18panner:panX1 VST Mixer19panner:panX1 VST Mixer20panner:panX1 VST Mixer21panner:panX1 VST Mixer22panner:panX1 VST Mixer23panner:panX1 VST Mixer32volume0 Mixer22mute257 Mixer23mute257 Mixer24mute257 Mixer25mute257 Mixer26mute257 Mixer27mute257 Mixer28mute257 Mixer29mute257 Mixer32mute257 ProjectSelect Track: Prev1 ProjectSelect Track: Next1 VST Mixer0volume0 VST Mixer32volume257

Now it’s not worrking for Cubase 9.5. Please help me :frowning: