Problem with Plugin Alliance plugins

Just now, I’ve updated my BX Digital V2 from version 2.3 to 2.3.1.
Hoping that this bug was fixed:
http://www.steinberg.net/forum/viewtopic.php?f=47&t=25351

The result:
I CAN’T OPEN A MASTER SECTION PRESET I SAVED LAST WEEK.

WaveLab says it can’t find the plugin.
Just because the version is 0.0.1 different…
This is incredible…

FYI this doesn’t happen with Pro Tools.
Even when the version changed from 2.1.5 to 2.3 it worked fine without any problem.
This indicates that the problem is within WaveLab and maybe Plugin Alliance as well.
So PG, please, stop blaming on plugin venders and start looking into this ridiculous bug.
This is a serious bug.
This needs to be fixed ASAP if you claim that WaveLab is a “professional” software.

WaveLab 7.2.1
Mac Pro 2x2.4 Quad with 16GB RAM
OS 10.7.4

WaveLab ignores completly the plugin’s internal version.

If you have a VST-2 plugin, its name can’t change, else WaveLab won’t find it.
If this is a VST-3 plugin, the name can change because each plugin has a unique internal ID WaveLab can relies on.

In your case, I guess it’s just a VST-2 plugin and you could solve the problem by renaming it.

When you have the choice between VST-2 and VST-3, always choose VST-3 if you can.

Did you mean that as written?

Paul

Oops, I reformulate:
When you have the choice between VST-2 and VST-3, always choose VST-3 if you can.

bx digital v2 is VST3

FWIW …

My transition from iLoks to Plugin Alliance did not go at all well.

Aside from initial licensing errors … which support overcame after a few days … the ‘new’ version does not load the previous version’s settings. This happens even if those setting were separately saved … meaning separate to the master section pre set. So, I don’t think this looks like a WL issue … the plug won’t load it’s own setting that it created in its previous version.

Now for one VST2 plug … which became VST3 … I kind of understand that and because I had the previous iLok version still loaded I could re-create the settings.

But the other plug was the plug in’s author’s/PA issue I believe. I really don’t see how the host program (WL) can deal with this.


BTW, ProTools does not use VST.

talking about pro tools, when i updated bx digital from 2.1.5 to 2.3 it was rtas in pt8. 2.3 to 2.3.1 was aax in pt10.
in both format the update did not introduced any problem at all.
only in wavelab, vst3, has the problem.
maybe i should ask someone to check with cubase.

i’ve also reported this to plugin alliance and they said that they are going to contact pg.
i really hope they can find a way out.

tested with ableton live. (bx digital v2.3 to v2.3.1)
works.
plugin: found
settings: recalled
ableton reads vst2 i think.

does anyone here can test with cubase or even other daws?
simple test:
1.create a session file with bx digital or other plugin alliance plugins
2.update the plugin to a newer version
3.reopen the session file to see if the daw can find the plugins

A better question would be directed at PG, to test it with Wavelab. Apparently that’s where your problem is.

any progression??
i guessed not

I got a contact with the company. I now have to study the case.

The problem is that WaveLab 7 uses the plugin company name as part of identification of a plugin. Since Brainworx has changed to a new company name, the new plugin version has an indentification that is not compatible with references stored in the past by WaveLab.

Thank you for that advice and effort PG.

That explains everything for me.

FYI, next WaveLab version won’t have this dependency.

i got an email from plugin alliance developer.
just like i suspected, the problem was a bug on wavelab.
the problem i reported months ago is now finally solved.
solved??
not really.
because i have to upgrade to wavelab ver8 to have this problem fixed lol
what kind of joke is this??
off course i get a free patch or a free upgrade, right??

I would not call this a bug per se, but a non-covered case: WaveLab did not expect that a company name could change. Unusual case, isn’t it?

Anyway, you can save the plugin preset(s) with the old version of the plugin, and load it into the new version of the plugin. Hence you have a workaround.

Philippe

Vadim here from Plugin Alliance. On October 23rd, 2017 we released an update that addresses general instability issues with our plugins in Cubase, AAE6 errors in Pro Tools and a number of other bugs.

To see a full list of which plugins were updated and exactly what was fixed, please consult the Update History at the bottom of our Support page. If you have experienced any of the aforementioned issues, update your plugins to the latest versions either by downloading the installers from your Manage Registered Plugins page or by using our Installation Manager V1.1.

If you are still experiencing any issues after updating, please contact our Support Team and we will troubleshoot with you and work towards a solution.

Thank you and have a wonderful day!


Vadim
Plugin Alliance