Problem with recorded events grid behaviour

Hello, I have a problem with events that were multitracked from my hardware sampler not following the grid position. Every time I record a bunch of tracks, they are out of sync and that i try to manually adjust.
But then it appears that there is a white vertical line on audio recording (eg. drum break) that the grid recognizes, instead of following begining of my precisely cut block of waveform. So far I must TURN OFF the GRID in order to insert clip exactly at the beggining of new bar - NOT few miliseconds before. Is there a way to turn this record point off and stick to normal grid-by-event-begining?

Thanks!

The white line is the snap point, and you can move it:

I don’t actually know whether you can disable it, but you can move it to the start of the event:
Select Event
Transport->Set Project Cursor Position->Locate Select Start
Audio->Snap Point to Cursor

1 Like

Yes when you record audio, the snap point is automatically set on the first bar it comes across, but there are currently some issues with the Snap Point, including this one where the audio slightly moves backwards.