Problemkind ASIOGUARD ?

Hallo,

da ich in vielen threads und nicht nur in diesem Forum, oftmals über Probleme mit dem asioguard gehört habe, mal eine Frage in die Runde wer in welchen Situationen oder Konstellationen (auch in Verbindung mit bestimmter hardware)Schwierigkeiten hat, sei es in Form von asiopeaks oder freezes oder anderen Instabilitäten.
Ich finde es ärgerlich das eine solch essientielle Funktion die ich gerne immer nutzen würde, immer öfter als Verursacher denn als Beschützer auftritt.

Bei mir machen insbesondere vsts von Drittanbietern Probleme. Leider Probleme mit ominösen Vollausschlagspeaks beim asioaverage meter oder diverse Hänger bishin zum totalen freeze von cubase die Regel.
Besonders mies ist allerdings das, dass selektive Ausschalten für Vst Instrumente nicht immer das Problem löst. Meist hilft dann doch nur die globe Keule : Asioguard ganz aus und Gut.
Gerade erst die ganze Woche wieder rumgeärgert weil ich ipad und studiomux nicht ohne massive asiopeaks und freeze aktionen betreiben konnte. Jetzt ist der guard aus und siehe da es läuft ohne Aussetzer.
Dieses Verhalten ist unabhängig von der gewählten Buffergröße oder der Auslastung des Sytems. Selbst bei ansonsten leeren Projekten lässt sich dieses Fehlverhalten erzeugen.
Selbe Situation mit Overbridge von Elektron nur ohne Asioguard einsetzbar, dann allerdings läufts ok.
Aslo wirklich liebe steinberger nur wenn der guard ausschließlich mit euren apps reibungslos läuft aber bei etlichen anderen plugin Anbietern Probleme bereitet sollte dieser guard etwas kompatibler designt werden, auch eurem support zu liebe.
Mfg

Erwähnt sei vor allem noch das mein System gottlob ansonsten sehr stabil ohne irgendwelche Probleme läuft. Das ist auch der Grund warum ich zumindest bei mir den Guard als Wurzel des Übels in Betracht ziehe.

Schön, dass nicht nur ich Probleme habe. Ich kann das nur bestätigen. Bei mir tritt der Fehler auch auf: Zuordnen konnte ich bisher nur das Instrument NI-B4 (in jbridge) als Störfaktor (ein altes 32 Bit Plugin im VST 2.1 Format). Mit eingeschaltetem Asio-Guard friert Cubase ein. Bei mir ist das aber erst seit den letzten zwei Updates der Fall.
Benutzt Du jbridge? Wenn ja, versuche doch mal, die Plugins, die zum Freeze führen, nicht über jbridge laufen zu lassen, oder umgekehrt: Wenn die Cubase VST-Bridge Probleme macht, dann jbridge zu verwenden.

Hi rolander,

…schön ist anders, besser wäre keiner hätte probleme, oder nur wir beide , dann wäre klar es liegt an unserem Equipment und nicht am guard,aber es ist wie es ist. :wink:
Jbridge möchte ich nicht auch noch da zwischen hängen, da ich immer sehr skeptisch bin, je mehr sich dazwischen schiebt desto schwieriger die Ursachenfindung wenn etwas nicht rund läuft. Zudem verwende ich bis auf dei uad1 und dem zufolge ihrer 32 bit plugins (und die laufen absolut klaglos mit der interen cubase bridge keine weiteren 32er.
Es scheint aber der Fall zu sein, dass der Guard in einigen Konstellationen eher störend wirkt und leider dann auch das selektive abschalten des guards im pluginmanager keine Erlösung bringt. Ich hoffe halt das hier hinsichtlich Kompabilität nachgebessert werden kann.

Hallo,
dass nur zwei Nutzer Probleme haben, würde ich aus den vorhandenen Meldung nicht gerade schließen.
Ich bin zwar noch nicht lange hier, habe aber so den Verdacht, dass viele, wenn etwas nicht funktioniert, das dann einfach nicht nutzen, oder eben das bestehende System verändert wird (z.B. VST 32 Bit auf VST 64 Bit updaten, oder anderes Instrument kaufen, das funktioniert).
Ich selbst nutze den Asio Guard nicht, weil mir die genaue Funktion noch nicht klar ist.

Aber kann man den Asioguard nicht für bestimmte Instrumente (VST) ausschalten? Irgendwo hab ich das mal gesehen. Müsste im PluginManager sein.
Evtl kann man damit das Problem umgehen, wenn das Einfrieren an einem VST liegen würde.

Gruß
Gerd

Hi Vollgerd,

ebendas bemängele ich ja.s.o. “Besonders mies ist allerdings das, dass selektive Ausschalten für Vst Instrumente nicht immer das Problem löst. Meist hilft dann doch nur die globe Keule : Asioguard ganz aus und Gut.”
Erstaunlich ist eben das sich nach dem ausschalten das System auch nicht stabiler verhält. Erst wenn die gesamte, im eigentlichen Sinne durchaus nützliche, Funktion deaktiviert wird gibt es keine Peaks, welche genau er ja verhindern soll.

Nach meinen Erfahrungen mit dem Asioguard…
Viel zu oft werden Spike- Probleme im Asioguard und seinen Einstellungen gesucht.
Immer dann wenn neue Plugins installiert werden, und das müssen noch nicht einmal Drittanbieter- Plugins sein, besteht die Gefahr das Cubase nicht mehr sauber läuft.
Spikes, plötzliche Ausschläge, mit der Zeit anwachsende Asio- Auslastung. Alles ist möglich und liegt dann eben nicht an der Hardwareumgebung.
Gemein ist das sich beim Ändern der Asioguard- Einstellungen diese Effekte verbessern können, bzw. verändern. Aber im Asioguard liegt meistens gar nicht das Problem.

Das Einzige was dann meistens hilft, Preferences- Ordner neu erstellen lassen. Das nervt, ist nicht sauber, aber ist bis heute die einzige Lösung.
Bevor man nach Neuinstallationen lange mit Asioguard- Einstellungen herumbastelt, erst einmal die Prefernces neu erstellen. In der Regel ist dann Ruhe.
Gruß,
schrubbi

Ist es nicht eh etwas paradox sich über mehr Leistung im Grenzbereich Gedanken zu machen. Habe noch nie jemanden gesehen der sich über mangelnde Leistung beklagt wenn der Rechner schnell genug ist. Macht halt schon nen Unterschied ob man son i7 oder zwei Xeon CPUs mit bis zu mittlerweile möglichen 18 Kernen betreibt. Das son bisschen wie beim Arzt wir behandeln nicht die Ursache sondern lieber die Symptome. Um mal ein beliebtes Auto Beispiel zu nennen XD
Man kann nen 4 Zylinder treten und kommt auch schnell voran aber mit nem V8 ist es halt schon deutlich entspannter weil man in der Regel genug Leistungsreserven hat und den Karren nicht so treten muss.

Äh, halt mal, du verwechselst da was!
Den ASIO-guard haben nicht die Nutzer gefordert, weil ihre Systeme zu schwach für neue blink-blink-VSTi’s waren.
Die Funktion würde mit größter Werbung eingeführt und es wurde das Himmelreich auf Erden versprochen.
Was daraus geworden ist kann man ja hier im Forum zur Genüge nachlesen.
Also ist für die Lösung nicht der Nutzer verantwortlich, der sich einen performanteren Rechner kaufen soll, sondern die Firma, die einfach eine unfertige Funktion verkauft.

Wollte nicht den User als Schuldigen hinstellen. Mir ging es mehr darum dieses ganze Asio Guard Ding generell in Frage zu stellen. Laut der netten Werbegrafik auf der Steinberg Seite könnte man vermuten das Cubase 8 50% mehr Asio Leistung ermöglicht im Vergleich zu 7.5. Wenn man sich diese Funktion aber mal genau anschaut läuft es doch darauf hinaus das man versucht die Gesamtleistung zu verbessern gerade im Grenzbereich der Leistung. Über Dropouts braucht man sich ja keine Sorgen machen wenn man nur eine Spur geladen hat. Die Idee als solche ist ja nett aber irgendwie nicht zu Ende gedacht. Man kann ja optimieren wie man will am Ende des Tages zählt aber die Gesamtleistung des verwendeten Systems. Ich halte den Zugewinn der Leistung für so klein das es irgendwie keinen Sinn macht sich darüber überhaupt Gedanken zu machen. Ich lasse mich gerne eines besseren belehren aber bis jetzt hat Asio Guard auf meinem System keine spürbare Wirkung.

OK, dann hab ich dich verstanden miß.
Auch bei meinem, zugegebenermaßen nich aktuellem, System wäre der Verlust der Funktion ASIO-Guard kein Leistungsverlust sondern eine(seltene) Fehlerquelle weniger.
Allerdings auch nur auf dem ‘normalen’ System, wo aller Quatsch installiert ist. Auf dem ‘sauberen’ Studiosystem stört der ASIO-Guard immerhin nicht. :mrgreen:

So als idee.
laut Manual läuft ein 32 bit plugin nicht mit 64 bit Windows. Wenn Plugins probleme machen kann man für die den asio guard deaktivieren. Möglich das es, sobald ein *bridge ins Spiel kommt es probleme gibt.

Ich selbst habe keine probleme mit dem asioguard. Ich benutze allerdings nur 64 bit plugins und nur die von cubase. Ich hatte allerdings den waldorf nave als demo, auch da keine probleme.

Hier auch ein alter thread in dem gegen ende ein lösungsansatz steht.
http://www.steinberg.de/forums/viewtopic.php?p=474993

Der modus für optimierte audio leistung schaltet das hyperthreadung ein, sofern vorhanden. Entweder hat er den an oder aus geschaltet. Ich denke das ist mal ein test wert.

Probleme sind das eine Nutzen das andere. Hat jemand wirklich einen spürbaren / messbaren Leistungszugewinn durch Asio Guard? Ich kann wie gesagt auf meinen System keine Änderung des Verhaltens oder der Leistung nachvollziehen. Mit spürbar messbar meine ich nachvollziehbare Zahlen. Seien es Anzahl der Plugininstanzen oder prozentuale Angaben der Auslastung eines Projektes zb. Man liest immer nur das jemand Probleme hat der andere nicht aber nie das Asio Guard wirklich für mehr Leistung sorgt. ( Evt habe ich auch die zahlreichen glücklichen Userkommentare nur nicht gesehen. Über einen Link würde ich mich sehr freuen.)

http://www.steinberg.net/de/products/cubase/neue_features.html

Unter Substantieller Umbau der Audio-Engine ist folgendes zu lesen. Zitat “Während der Entwicklung haben wir uns ambitionierte Benchmarks als Ziel gesetzt und die Ergebnisse sprechen für sich.”

Kann man diese Benchmarks irgendwo einsehen? Warum werden diese nicht gleich auf der Seite veröffentlicht um den Zugewinn zu dokumentieren? Und ist dieser Benchmark realitätsnah oder nur theoretischer Natur? Man kann ja zb seine SSD und den Raidcontroller benchen bis man schwarz wird in zig verschiedenen Einstellungen. Wenn man jetzt nen Controller Test macht und einfach nur die volle mögliche Bandbreite checkt hat das mit der Leistung in der Realität herzlich wenig zu tun.

Details zum asio guard.
https://www.steinberg.net/de/support/knowledgebase_new/show_details/kb_show/details-on-asio-guard-in-cubase-and-nuendo
Meistens wird doch nur geposted wenn es probleme gibt. Windows ist dadurch gross geworden. Dadurch das sich alle aufregten ist es bekannt geworden, systeme die liefen kannte keiner weil niemand darüber redete und sind deshalb verschwunden, :mrgreen:

Der asio guard macht mich nicht glücklich. Eigentlich hat der keinen einfluss auf mein gefühlszustand. :wink:
Also, das demo projekt teleporter läuft mit 32 samples ohne audioaussetzer durch. Ohne gibt es beim ersten durchlauf einige aussetzer. Die performance ist ein wenig besser geworden.

Mhm jetzt bin ich durchaus verwirrt. Hab mal das Demo Projekt Eight Good Reasons runtergeladen. Mit Asio Guard läuft es super ohne ist es nicht abspielbar bei 64 samples. Das merkwürdige ist so verhalten sich meine eigenen Projekte nicht. Da ist es egal ob an oder aus macht keinen Unterschied. Die Aufgabe für die Nacht ist klar :smiley:

Die Aufgabe für die Nacht ist klar > :smiley:

Da bin ich aber gespannt auf Ihren Bericht :unamused:

Wie darf ich denn das Augen rollen verstehen? XD Im Vergleich zu nem eigenen Projekt ist der Leistungszuwachs echt enorm. Hab aber so generell auch keine Probleme was die Leistung angeht wenn der Asio Guard ausgeschaltet ist. Deswegen ist das jetzt schon etwas verwirrend, weil das ist ein echt heftiger Unterschied im Demo Projekt, den ich so in meinem Alltag nicht feststellen kann. Als erstes kommt natürlich die Arbeitsweise in den Sinn dsps, effekte reinrendern usw. Muss das mal genauer beobachten, weil so auf den ersten Blick unterscheidet sich das Demoprojekt nicht groß von dem was so in nem eigenen Projekt los ist.

Ich schon. Ich kann jetzt in einem vollen Projekt ne Gitarre immer noch mit 64 oder 128 samples einspielen, während ich früher schon auf 256 oder 512 samples hoch gehen musste was natürlich für softwaremonitoring spielen zu viel war.

Hi,

genau das ist der Punkt. Die angedachte Funktion soll sein in solchen Situationen den realtimepeak zu buffern.
Was er auch tut, darum steigt ein wenig die asioaverage Belastung und ein wenig der Ramspeicher Verbrauch. Schaut euch mal das Verhälnis der beiden Anzeigen an, unter Last, mit und ohne den aktivierten guard.
Macht also in vielen Situationen Sinn. Allerdings eben nur wenn er dies ohne wenn und aber tut. In einigen Konstelllationen, sei es diverse thirdparity plugs oder manchmal auch eben Hardwarekonstellationen sorgt er eben eher für Ungemach. Hier kann Steinberg ggf. nachbessern. Ich bin kein Progr. somit kann ich nicht beurteilen ob und warum und wie, aber schön wäre es wen STEINBERG, da noch mal drüber schaut. Vielleicht sogar im Zusammenhang mit der noch ausstehenden Win10 Kompabilität. :laughing:
Im übrigen hatte ich auch schon Kontakt zu plugin Hersteller die sich der Sache angenommen haben, also auch von dieser Seite gibt es wohl Möglichkeiten. Deshalb von hier nochmals herzlichsten Dank an Pascal und Christian von Studiomux die haben das Prob. mit asiopeaks und aktiviertem guard souverän und schnell gelöst. Vielleicht schaffen die leute von elektron dies ja auch mit ihrer Overbridge die eben u.a. auch dies unliebsame Verhalten der peaks unter dem guard auslöst.
Also da geht was, um diese nützliche Funktion korrekt einzubetten.

Wird der Asioguard nicht deaktiviert bei aktiviertem Monitor Button?

Ja, beim aktivierten Monitor Button und bei Record wird der deakftiviert. Aber nur für diese Spure/n.

@sps. Ich habe überlesen. Das du Windows 10 verwendest. Es gibt da bekanntermassen Probleme. Ich habe da nochmal nachgesehen.
https://www.steinberg.net/nc/de/support/knowledgebase_new/show_details/kb_show/product-compatibility-info-regarding-microsoft-windows-10.html
https://en.wikipedia.org/wiki/Multimedia_Class_Scheduler_Service

(Du weisst ja, Wer gegen die Systemempfehlung des Software hersteller verstösst wird mit Fehlfunktionen und Ingoranz des Supports bestraft :wink:. Ein Scherz am Rande.)

Die Asio Threads verwenden wohl den Multimedia Class Scheduler Service (MMCSS). Jetzt ist mir auch klar warum der Wechsel einer Soundkarte und damit auch der Wechsel des Asiotreibers Problem verursachen bzw. beheben kann.

Windows 10 ist eher Glücksache ob Cubase vernünftig läuft. Gibt es bei Steinberg eigentlich sowas wie bei Protools. Die “Steinberg Certified Workstation” ?. Ich finde da gerade nichts.

Ich denke derzeit empfiehlt Steinberg Windows 7 und 8. Ich denke da ist es eher berechtigt sich zu beschweren das es nicht sauber läuft. Aber nicht bei Windows 10. Und wenn ich in den obigen Links so nachsehe ist es eigentlich Microsoft Schuld das Cubase da nicht vernünftig läuft, da die einen Service nicht kompatibel gehalten haben. (Und jetzt nicht, “Alte Zöpfe abschneiden”, die das sagen möchte ich hören wenn ihre alten Projekte nicht mit einer neuen Cubase Version laufen).