Project file corruption in a project testing Softube plugins

I’m two years too late, but I just experienced this “Invalid Cubase Project File” issue and I have high suspicions that it has to do with iLok related plugin licensing. I very recently had a trial for a couple of Softube plugins, which I later bought and then registered to my iLok. Immediately after registering the plugins and syncing with my Softube software and account, I got this project file corruption issue for the project that I was testing the Softube plugins on.

I was able to open the backup .bak project files to around the time when I was testing the plugins in demo mode, and pretty much exactly when I decided to buy the plugins (but not yet activate the licenses to my iLok). Let’s call this checkpoint 1.

From here on out I continued to work on the project, then found that my Softube licenses were not acknowledged by the Softube software or on their website in my account, so I opened up iLok (which ran through an update while Cubase was open), and after a few minutes the licenses were activated and synced with the Softube software and on their website. Let’s call this checkpoint 2.

Now it seems that all of the .bak project files and the main .cpr files since checkpoint 1 are all corrupt. And not only that, they are 4 gb as opposed to 1 gb in size (when the only thing that changed was two additional plugins on an FX channel (this makes no sense to me).

Either way, I was able to open the “06.bak” file, which was still 1 gb, and then I saved it as a .cpr file, and it became 4 gb in size. Everything seems to work fine now. This was the only time I’ve ever experienced this issue in the 10+ years of using Cubase since version 6 (I’m currently on 12.0.52 on Windows 10).

Corrupt projects are usually caused by errors during file saves – mainly crashing. And note that there are different manifestations when Cubase crashes, and it might not be obvious.

Omg, ok nevermind! I wrote too soon. The “06.bak” file that I saved as a .cpr file doesn’t open either, it’s also corrupt. I tried saving it again and still that file failed to open. I also noticed that when I open up the “06.bak” file that does open, Cubase is running at about 11 gb of my 16 gb RAM, which doesn’t seem right (although the file I’m working on from a client who’s using several kontakt orchestral libraries). I’m going to run the memory test suggested above and see what happens.

I haven’t had Cubase crash on me for quite some time now so it’s nothing to do with crashing.

In that case, you should focus troubleshooting on ruling out VST plugins that aren’t causing the problem.

I also just tried removing the two Softube plugins in question and saving as a .cpr file and that didn’t work either.

I don’t think you can resurrect those already corrupt files. Especially with the symptoms you described of the size going up to 4gb.

Hopefully you have backups (if this is a project you’ve been on for more than today)?

Yup, I’ve always made sure to have Cubase automatically save .bak backups and I run daily backups on my system. I’m going to start going through those system backups in a bit.

But things seem to get weirder. I can open the “06.bak” through “10.bak” auto backup files, all of which are 1 gb in size. But I can’t open “.bak” through “05.bak” nor the “11.bak”, all of which are 4 gb large. The 11.bak is the weird one because it’s the oldest auto backup but won’t open, but the newer 10.bak opens. And every time I save those 1 gb .bak files they save as 4 gb .cpr files.

Also, all of the backups I’ve opened use from 10 gb to 11 gb of RAM (on my 16 gb system). When I open those .bak files and save as a .cpr project file, the saving takes quite a while (I get the spinning wheel for about 30 seconds).

Some info on the project itself. There are several Kontakt based orchestral instruments (around 40), all of which are frozen, there are no audio tracks, I only have 3 third party plugins along several instances of Frequency (roughly one per track) and about 6 instances of Reverence.

Not sure if this would help, but can you still import individual tracks from the corrupt projects into a not corrupted project?

If that still works, it might provide a (partial?) path from the last working version (before checkpoint 1) towards recovering the work you did since then ?

I just tried that using the corrupt .cpr file and Cubase shows a loading bar, and once done goes completely blank. So there’s seemingly no way to access the content of that file. I was however able to import the tracks from the 06.bak file that still opens.

The good thing is that I didn’t do very much since that 06.bak file was generated.

1 Like

I’m going to add yet more confusing info. The original project file I received from my client is 43 mb. When I open it up and save it as a new file (without making any changes whatsoever) that file size becomes 96 mb (more than doubles in size). BUT if I save it while the project is not active the file size is the same at 43 mb.

I also opened the original .cpr file, unfroze 4 of the Kontakt tracks, and saved as a new file and the .cpr file dropped to 23 mb!

The 06.bak file which does open is 1.07 gb, and here’s a breakdown of all the changes to that original project (i.e. all the mixing I’ve done so far):

  • 56 added Frequency plugins
  • 11 added Group tracks
  • 7 added FX tracks (6 with Reverence, 1 with a Waves plugin + 2 Softube plugins)
  • 2 tracks with minimal volume automation
  • 1 added Marker track
  • 1 added Ruler track

I don’t recall any other changes to that original project. I would not expect the project file size to balloon from 43 mb to 1 gb from those changes alone.

what happens if you do that after starting with a totally new Cubase preferences file?

And upon further testing, I’ve opened the original .cpr file at 43 mb, imported all of the tracks from the 06.bak and saved it as a new .cpr and the file size grew to 4.3 gb again. And I get the same error in question when trying to open that new .cpr file.

I also tried importing everything but the FX tracks and it grows to 4.3 gb and can’t open it. I also tried removing all plugins and leaving just the original tracks plus the imported tracks and it was still 4.3 gb and can’t open it.

One more update:

I started by opening the original .cpr project file, imported all of the tracks from 06.bak, and proceeded to transfer all track data (volume, EQ, plugins, pre, send, automation, etc) to their respective tracks in the original .cpr file. I then deleted the imported tracks from 06.bak until I noticed a change.

While doing this process to about half of the tracks, the newly save .cpr project files kept lowering by very small amounts at first (from 4.3 gb, to 4.2 gb, to 4 gb, and to 3 gb), until finally at the halfway point it dropped dramatically to 32 mb.

The kicker is that every time I open this new 32 mb file, do absolutely nothing but save the project, close Cubase and repeat, the file size approximately doubles in size. First from 32 mb to 54mb to 150 mb, to 350 mb (a total of four saves).

I was able to open all projects lower than about 4 gb, but the large ones (3 gb to 4 gb were very slow to load).

What I’ve decided to do is open the 06.bak file, render all of the frozen instrument tracks to audio, transfer all of the track processing and save that as a new project file and call it a day and move on. All of this testing has me burnt out.

Well fml haha, you can’t render in place for frozen instrument tracks :frowning:

if it’s frozen, shouldn’t there be an audio file of the rendered track in the project folder?

Yes but the audio files that are generated are not timestamped in any way. For me to import all of the audio files to their exact location would take several hours. In some ways that’s not worth the effort, but I guess if I needed to do it I would.

But now that I think about it, it would be easier to just route every frozen instrument track to their own audio tracks and to record them in real time. Maybe that’s an ok work around in this case.

aahhh - too bad :frowning_face:

… and the time stamp info is probably somewhere in all that corrupted track mess of the project file.

would exporting multiple tracks still work on those? Or is that also hooped?

What do you mean by “exporting multiple tracks”?

File > Export > Audio Mixdown…