Project Logical Editor acting odd?

Hiya, no massive expire on the project article Editor I created this logical Editor to disable and hide a track. its been working fine . I found today that in an existing projects, it does weird things and disables. The selected track seems to hide random tracks not the one that it’s just disabled anyone got any ideas.

The first video is the project that seems to be acting up and is it justice project seems to be when you’ve been working for awhile.

The second one is a fresh, creative project and is working perfectly

I think as written the top part of your PLE preset is kind of ambiguous. Rather than specifying a Selected Track it is saying to apply the Preset to anything that is Selected - A Track, a MIDI Part, an Audio Event, etc. What you want is to specify that it is Selected AND that it is a Track. So you’ll need 2 lines at the top. The stock PLE Presets have examples for how this is done.


thanks man , sorry for what the stock PLE ?


The missing line is:
( Container Type is | Equal | Track | And
Property | Property is Set | Selected )

All the ones that come with Cubase.

Thanks Martin. Wasn’t at Cubase and didn’t want to wing it.

1 Like


Me neither, but I took the risk. :wink::grin:


Epic , will try that tomorrow… top man!

Use at Martin’s risk :slight_smile:


Bold move.


Not sure I have this right ? , but its still acting up - cubase logic editor v3 - YouTube

It’s doing what you told it to do.

Can you simply state what you want to have happen? Using words.

You probably want to disable the track before you hide it as the Disable command operates on the selected track(s) and a hidden can’t be selected.

1 Like

I am trying to Disable and the hide the selected track .

Sometimes it work , other time is Disables the selected track , but hides a random one

I do , not sue what I am doing wrong :slight_smile:

You’re right, you have the Disable command as a Pre-Process command. Sorry about that.
I haven’t tried this particular PLE, but I have had issues with the Pre and Post commands in the PLE before. My conclusion was that they do not execute sequentially as one would expect.

Have you tried creating two separate PLEs and combining them as a macro?

What @mlib said, and also, you should try different methods of doing the same thing. Really it would be easy and simple to just have two key commands set up and do it manually.

1 Like

I had similar issue with one macro where are about 8 PLE steps happening and applying them manually one by one they works, but in macro results are half successful (sometimes work sometimes not) on busy project.
As others mentioned try to devide that PLE into 2 and assign them to macro. Also you can try to put some random command/s (like snap on and off or whatever) that will act like “sleep” which will take some time to be executed and eventually make a bigger gap between two PLEs and making them more reliable.

If nothing above works you can try autohotkey/keyboard maestro and make that sleep time between PLES manually. That will kinda look like this:
[Disable and Hide Track Key command]::
Send, key command of PLE1
Sleep 100ms
Send, key command of PLE2

This is how i solved “unreliable” PLEs/macros as i mentioned above.

I do have 2 functions set up on MetaGrid , so really easy to make a macro on there , but I trying to understand the Logical editor and learn it . just seems odd that when I created the function it worked fine , and also on a fresh project , but once I start working on larger projects its seem to break


As @User131231 mentions, the commands might be firing to fast.

So I don’t remember this happening before , but it seems that even if I disable a track with a mouse click , the track selection jumps to another track . is this correct ?
if so this is why its not working … even with a macro on my Meta grid app

1 Like